FAQ: Updating to 1Password v7.4 from a previous version gives an error message

BenBen AWS Team

Team Member
edited March 31 in Mac

Hi folks,

The problem

I can’t update 1Password 7 version 7.4 from the App Store. I get the error message “Close This App to Update Click continue to quit."

The solution

This was indeed an issue in previous versions. It was fixed for quite some time, and now it has cropped up again. :( I'm sorry for the trouble. Fortunately this should be fixed in the v7.4 update (meaning updates subsequent to 7.4 shouldn't need any special workaround). To get up to v7.4, please try this:

  1. Quit 1Password completely by opening it and then pressing ⌃⌥⌘Q (control-option-command-q)
  2. Quit Safari
  3. Drag the 1Password app from the /Applications folder to the Trash. Do not use any "cleaner" apps (AppZapper and the like) to "clean up" 1Password support files.
  4. Reboot the Mac
  5. Empty the Trash
  6. Install a fresh copy of 1Password: Download for Mac

(if you are currently using 1Password from the Mac App Store you may substitute step 6 with reinstalling from the Mac App Store if desired)

Again I apologize for the inconvenience.



  • I can’t update 1Password 7 version 7.4 from the App Store. I get the error message “Close This App to Update Click continue to quit." I’ve tried several things and it’s the same exact problem as described for the 7.0.4 update. I tried all the suggestions in that old thread like Ctrl+Alt+Cmd+Q and ALL of the other suggestions there.

    1Password Version: Not Provided
    Extension Version: Not Provided
    OS Version: Not Provided
    Sync Type: Not Provided
    Referrer: forum-search:I get the error message “Close This App to Update Click continue to quit. I’ve tried several things and it’s the same problem as described for the 7.0.4 update.

  • I'm having the same issue. I click continue and it fails.

  • ag_anaag_ana

    Team Member

    Hi @Janet_Northway and @dbaxter33!

    Please make sure that 1Password mini in the menu bar is also not running. If you see the 1Password icon there in your menu bar at the top of your screen, please right-click on it and select Quit 1Password Completely in order to continue with the update.

  • It's definitely an issue with the update package - I'm used to quitting 1Passwort completely before upgrading and it does not help in this case.

  • Fixed: I noticed "1Password (Safari)" was still running in Activity Monitor, even though I had used the menu bar entry to quit 1P completely.
    I quit Safari, it took about 15 secs until the above mentioned process stopped running, and finally I was able to upgrade 1P to 7.4 from the Mac App Store.

  • ag_anaag_ana

    Team Member

    Thank you for the update! I am glad to hear that you managed to complete the update this way :)

  • I was experiencing the same problem since yesterday and closing Safari worked.

  • Still not working. I don't even have the mini-menu activated. And I made sure all the browsers were also closed. The app downloads to 98%, then the warning pops up to close the app that is not even open. I click "continue" to have the installer close it.. and it actually opens the app and then I get the error. I also made sure no password 1 was automatically logging on during startup. No luck. Me thinks your update needs an update.

  • Fixed: Using the Activity Monitor to "quit the process" and turning off the Chrome extension worked for me too.

  • ag_anaag_ana

    Team Member

    Thank you all for the updates :)

  • Thanks for this thread. I love 1Password but find the update process frustrating. I wish there was more notation about this being an ongoing issue. After trying several times to install the update without success, I spent 30 minutes researching the issue and found this thread...again, thanks, but still not clear how this "Quit Completely" is still part of the update process--I seem to recall seeing a post from 1Password several updates ago suggesting this was going to be fixed in future updates (thus, my confusion). But again, love the program. Thanks for the help Forum.

  • Agreed T-Rod. The updates need an update!

  • NeoxellosNeoxellos Junior Member

    Indeed! This update issue is an old one. Very frustrating.

  • BenBen AWS Team

    Team Member

    Hi all,

    Please see this message for the latest information. We'll keep that post updated if new information becomes available.


  • Thank you Ben, that worked perfectly. Nothing else suggested did.

  • ag_anaag_ana

    Team Member


  • Okay works would suggest to include (quit Safari also) in the 1st post (read it in the middle) as it does not shut off automatically when closing 1PW with the above shortcuts now 7.4 is installed. Thanks

  • brentybrenty

    Team Member

    Thanks for the suggestion! I've updated it. Glad to hear that worked for you. :)

  • dpolzinedpolzine
    edited November 2019

    Are steps 3-6 important? I completed steps 1 and 2, but in reverse order tried the update from the Apple Store again, it worked, and things seem fine now.

  • BenBen AWS Team

    Team Member

    Depends on the situation. Apparently in yours they weren't. ;)


This discussion has been closed.