Unable to establish connection with a 1Password desktop app

I just installed 1Password X and I was loving it. I then received an upgrade today on 1Password 7 to Version 7.4.1 (70401002). Now the 1Password X isn't unlocking or working with Touch ID.

I am using 1.17.3 version of 1Password X.

Any ideas?

Thanks,

Adam


1Password Version: 7.4.1
Extension Version: 1.17.3
OS Version: 10.15.1
Sync Type: Not Provided

Comments

  • Forgot to add Google Chrome Version

  • Same for me after updating desktop app. Notably, updating the Mac App took me from beta to regular, with no beta updates available. running MacOS, 1PX (beta) 1.17.2 in Firefox. Desktop integration no longer works.

  • Same here. The macOS app auto-updated and integration no longer works. I get the same message that a connection could not be made.
    1password X BETA 1.17.3 and 1password macOS 7.41 (non-BETA). Chrome Version 78.0.3904.97 (Official Build) (64-bit)

  • you need the beta 1P app to get the communication.

  • Current beta:
    1Password 7
    Version 7.4.BETA-0 (70400000)
    1Password Beta

  • mannym122mannym122
    edited November 12

    I had the BETA but it is no longer available after my 1password macOS app auto-updated. Even the link to download the BETA version on the 1password website redirects you to download 7.4.1 (non-BETA). The user above me also explained the same thing.

    If you know how to download the BETA you are referring to, please link it to us, because apparently it no longer exists. Thanks.

  • I have attached a console log which shows the error in 1passwordX here: https://www.dropbox.com/s/p9kerrgldtoo85u/1passwordX_7-11-19.log?dl=0

    Looks like the relevant lines are:
    19:46:45.886 background.js:27 Attempt #3 to reconnect to the native app
    19:46:45.887 background.js:27 Connecting to native app XXXXXXXXXXX.com.agilebits.1password
    19:46:45.985 background.js:27 Preparing hello payload for device XXXXXXXX:
    19:46:45.985 background.js:27 (accountUUID, userUUID, server) => (XXXXX, XXXXXXX, 1password.com)
    19:46:45.991 background.js:27 Native app port disconnected. Error: Access to the specified native messaging host is forbidden.
    19:46:46.000 background.js:27 Signing payload for account XXXXXXX with kid XXXXXXXX
    19:46:46.002 background.js:27 🌈 Sending message to native app
    19:46:46.002 background.js:27 💥 Failed to send because our port was disconnected. Browser code signature became invalid?

  • make sure the "Include beta builds" check box is checked on the updates page.

  • I have that checked and I am not on a beta build.

  • mannym122mannym122
    edited November 12

    That box is checked. 1password auto-updated to 7.4.1. There is no longer any new BETA build. There are also no BETA builds currently available for download either.

  • I'm in this same boat. "Include beta builds" checked in 1Password, but it appears no betas are available. And the 1Password X Chrome extension is reporting that it can't communicate with the desktop app.

    I presume we're all just waiting for either a new beta build, or for someone at Agile Bits to enable 1Password X communication with the non-beta desktop app and push a new version?

  • In case anyone wants it, I just downloaded and re-installed 7.4.1 BETA-0 and it fixed the connection issue. Here's the link to the download, if this is not ok to post then just delete it and accept my apology. https://c.1password.com/dist/1P/mac7/1Password-7.4.1.BETA-0.pkg

  • mannym122mannym122
    edited November 12

    In case anyone wants it, I just downloaded and re-installed 7.4.1 BETA-0 and it fixed the connection issue.

    Thank you so much! I was looking for this but couldn't find it anywhere. The official download link directs you to the non-BETA 7.4.1.
    I can confirm installing the 7.4.1 BETA solved the connection issue with 1Password X. In the meantime, I've disabled automatic updates ;) Appreciated.

  • ag_michaelcag_michaelc

    Team Member

    I'm glad everyone's all set now. :smile: I'm sorry for the temporary Desktop App Integration outage the lack of a beta update caused — usually we follow up with a beta right after the stable, so this doesn't happen, but things were a bit delayed this time. If you're going to turn off automatic updates, I do recommend you at least keep the check for them turned on and only turn off automatic installation. You wouldn't want to get several versions behind and not know it. :smile:

  • Wait — are we really all set? What I'm reading is that we should all downgrade to the beta version of the current release version if we want to keep integration between 1Password X and the Mac desktop app? That... doesn't make sense. If that IS what we're being asked to do, is there any thought being given within Agile Bits to releasing another beta version that's downstream of the current release and re-enables integration?

  • mannym122mannym122
    edited November 12

    As I understand it, there is now a new BETA available (7.4.2-BETA) so downgrading is no longer necessary. The issue was that this BETA was not released at the same time as the stable, which caused everyone’s clients to auto-update to the newest Stable version instead, breaking the Desktop App Integration.

  • brentybrenty

    Team Member

    Indeed, it's not possible for us to release a new beta simultaneously with a stable release, but it's usually a very short while before a new beta is deployed -- barring any unforeseen issues with doing so. :)

  • I was also having issues these last few days too. I reinstalled both beta app and beta Chrome extension still didn't connect. Then restarted Chrome, still not working. Restarted Mac, now it works.
    Not sure if this helps anyone, but this is what worked for me.

  • brentybrenty

    Team Member

    Thanks for letting us know! Glad to hear you're back up and running. :)

  • Still having this issue even after updating Mac app to 7.4.2-BETA-0 and Chrome app version 1.17.6

    logs attached (accountUUID and userUUID removed)

    22:04:12.471 background.js:27 Initializing 1Password X...
    22:04:14.701 background.js:27 Initializing Desktop App Integration. Attempting to connect to native app. 💌
    22:04:14.714 background.js:27 Connecting to native app 2bua8c4s2c.com.agilebits.1password
    22:04:15.012 background.js:27 Preparing hello payload for device 5zvvthfcp3jpfuyuwlafhv5kwi:
    22:04:15.012 background.js:27 (accountUUID, userUUID, server) => (, , 1password.com)
    22:04:15.015 background.js:27 Finished initializing beta 1Password X 1.17.6 in chrome (20093)
    22:04:16.354 background.js:27 Native app port disconnected. Error: Native host has exited.
    22:04:17.066 background.js:27 crypto tests: 2356.864013671875ms
    22:04:17.066 background.js:27 Signing payload for account with kid 6hwu2syxfoe3353xahpbpwuxwi
    22:04:17.080 background.js:27 🌈 Sending message to native app
    22:04:17.080 background.js:27 💥 Failed to send because our port was disconnected. Browser code signature became invalid?
    22:04:18.856 background.js:27 Attempt #1 to reconnect to the native app
    22:04:18.857 background.js:27 Connecting to native app 2bua8c4s2c.com.agilebits.1password
    22:04:18.970 background.js:27 Preparing hello payload for device 5zvvthfcp3jpfuyuwlafhv5kwi:
    22:04:18.970 background.js:27 (accountUUID, userUUID, server) => (, , 1password.com)
    22:04:18.971 background.js:27 Signing payload for account with kid 6hwu2syxfoe3353xahpbpwuxwi
    22:04:18.973 background.js:27 🌈 Sending message to native app
    22:04:19.134 background.js:27 Native app port disconnected. Error: Native host has exited.
    22:04:24.138 background.js:27 Attempt #2 to reconnect to the native app
    22:04:24.139 background.js:27 Connecting to native app 2bua8c4s2c.com.agilebits.1password
    22:04:24.248 background.js:27 Preparing hello payload for device 5zvvthfcp3jpfuyuwlafhv5kwi:
    22:04:24.248 background.js:27 (accountUUID, userUUID, server) => (, , 1password.com)
    22:04:24.249 background.js:27 Signing payload for account with kid 6hwu2syxfoe3353xahpbpwuxwi
    22:04:24.259 background.js:27 🌈 Sending message to native app
    22:04:24.353 background.js:27 Native app port disconnected. Error: Native host has exited.
    22:04:34.355 background.js:27 Attempt #3 to reconnect to the native app
    22:04:34.355 background.js:27 Connecting to native app 2bua8c4s2c.com.agilebits.1password
    22:04:34.470 background.js:27 Preparing hello payload for device 5zvvthfcp3jpfuyuwlafhv5kwi:
    22:04:34.470 background.js:27 (accountUUID, userUUID, server) => (, , 1password.com)
    22:04:34.471 background.js:27 Signing payload for account with kid 6hwu2syxfoe3353xahpbpwuxwi
    22:04:34.474 background.js:27 🌈 Sending message to native app
    22:04:34.475 background.js:27 Native app port disconnected. Error: Native host has exited.
    22:05:10.877 background.js:27 PBES2g-HS256(100000): 47.161865234375ms
    22:05:11.041 background.js:27 [LM] Started (minutes=10, lock on sleep=true).
    22:05:11.053 _generated_background_page.html:1 Unchecked runtime.lastError: Could not establish connection. Receiving end does not exist.
    22:05:11.054 _generated_background_page.html:1 Unchecked runtime.lastError: Could not establish connection. Receiving end does not exist.
    22:05:12.035 background.js:27 PBES2g-HS256(100000): 40.83203125ms
    22:05:12.608 background.js:27 Signed in successfully to and loaded account details. Elapse time 1487ms.
    22:05:12.748 background.js:27 Ensuring device keys are available for 1 accounts now that we are unlocked.

  • brentybrenty

    Team Member

    @samtumbaa: Do you maybe have a pending update in Chrome that needs to be finished and then restarted?

    22:04:17.080 background.js:27 💥 Failed to send because our port was disconnected. Browser code signature became invalid?

    There are other things that can cause that, but that's by far the most common. No matter what, it's a deal breaker for the desktop app to connect if it cannot be validated.

  • I'm also getting the same error message in the 1Password X app.

    Versions:

    1Password X Beta: 1.17.6
    1 Password Mac app: 7.4.2-BETA-0

  • Logs:

    Attempt #3 to reconnect to the native app
    06:49:59.003 background.js:27 Connecting to native app *****.com.agilebits.1password
    06:49:59.125 background.js:27 Preparing hello payload for device *****:
    06:49:59.126 background.js:27 🌈 Sending message to native app
    06:49:59.126 background.js:27 Native app port disconnected. Error: Access to the specified native messaging host is forbidden.

  • brentybrenty

    Team Member

    @bezhermoso: Which exact browser and OS versions are you using?

  • I'm going to jump on this thread as well. Desktop app: 1Password 7 Version 7.4.2.BETA-0 (70402000) 1Password Beta. Chrome extension 1Password X Beta 1.17.6. I don't know where the logs are to look for additional info. Once I find them, I'll add a new comment.

  • kaitlynkaitlyn

    Team Member

    Hey @mpflugfelder! Thanks for jumping in. Are you seeing the same "Unable to establish connection with the 1Password desktop app" error when you take a look at the 1Password X settings page? If so, your 1Password X log may be helpful. You can find our guide that explains how to obtain your 1Password X log here. If you'd rather send it in via email, you're welcome to send the file to [email protected] with a link to this forum post as well as your forum username in the body of the email. We'll take a look and go from there.

  • OK, I don't know what happened, but for the first time in a few days, when using the browser, I was prompted for my fingerprint (macbook pro) to unlock 1password. Was an update released? I do know that this morning I upgraded to the latest MacOS. Maybe that had something to do with it? Maybe this is just a one-time thing? #crosses-fingers

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file