Galaxy S10 1Password Auto-fill asking to save phone pin

Hey there,

I've got an issue at the moment which I've tried to find a solution for on these forums, so forgive me if I just haven't stumbled across it yet.

The jist of it is that when I go into for example, a security settings on my Galaxy S10 running Android 9, I need to enter my phone's PIN; however doing this then triggers 1Password prompting if I want to "Save" this under a new login.

You can see how this is not ideal as I'm doing this every so often, I haven't found a way to disable this only for system level logins.

Any help is appreciated, thanks all!


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

Comments

  • Almost 24 hours and still no reply yet, does nobody else experience this issue?

  • I have the s10 myself and have stumbled across this issue. I wish I could help you , since no one has yet responded I would suggest emailing the team then you should definitely get a response .

  • There seems no configurable autofill parameters that allow you to exclude certain apps from being included with that feature . I would temporarily disable autofill, that's the best advice I can offer but as I said before email the team.

  • Thanks Montana, I'll definitely be in touch with the support team.

  • andiAGandiAG

    Team Member

    Hi @Shawpaw, thanks for getting in touch.
    We've heard of this happening for some customers, though so far it only seems to affect Samsung devices. These are the only devices where we've heard of the 1Password Autofill prompt coming up in the Settings app. I'm not sure sure if there's anything that we can do about this, but the development team is aware and we'll investigate. :)

  • Thanks for the reply @andiAG. Is there no current way to blacklist certain system applications from using the autofill API?

  • periperi

    Team Member
    edited December 2019

    @Shawpaw There isn't currently a way to blacklist apps from Autofill, but I'll share this request with our development team.

    ref: dev/android/onepassword-android#815

  • Hello there, I've had the same issue with various Galaxy S10s over the last year and can reproduce it at will. I can provide diagnostics for this if you'd like. It's still there with Android 10. It's not a big deal, just slightly annoying.

  • periperi

    Team Member

    Thanks, @etheberge. A diagnostics won't be necessary for this issue, though I appreciate the offer! This is a case of 1Password detecting non-login fields as login fields, rather than something specific to the device or 1Password setup. I have opened an issue internally for our development team to look into!

  • Alright good to know, thanks!

  • andiAGandiAG

    Team Member

    No problem @etheberge, have a great day :)

  • Any updates on this? I just got an S10 and was surprised to see this... It's quite annoying! Thanks

  • periperi

    Team Member

    @dansauve Sorry, I don't have any updates for you at the moment.

  • Thanks for the update @peri. It's quite a surprising bug (I'd categorize as a bug anyway, it's not working as designed if asking to save system PIN requests IMO). If it's like this on other Samsung OneUI devices it seems it could affect enough users to warrant prioritizing. Thanks!

  • periperi

    Team Member

    @dansauve Unfortunately it's difficult to address, as PIN codes and other fields are often part of login fields. So if 1Password were to stop detecting these fields, we'd be unable to fill in PIN fields in other apps.

    We have an open issue to allow excluding apps, and I've forwarded your request. :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file