Putting in my master password in twice

primeprime
edited November 2019 in iOS

So on my iPad I have it set up that after a restart, I have to put in my master password. Now this issue has been around for a while, but I had a work around until now.

This issue: after the restart, I have to put in my master password. So I put it in, and it’s unlocked. Works how it should. Then let’s say I go on a website and I want to put in my login and password, the extension wants my master password again. This issue has been for as long as I can remember. What I would do is go into the app itself, copy my master password, and paste it when the extension pops up. Because I am lazy and I don’t want to put it again, especially the app itself is unlocked (use Touch ID).

Today this happened and I no longer can copy my master password and paste into the extension.

So why do I need to unlock my 1Password to use Touch ID then unlock it again when the extension pops up?

This issue doesn’t happen on my iPhone. Always on my iPad.


1Password Version: Latest iPadOS.
Extension Version: Not Provided
OS Version: Latest ipados
Sync Type: Membership

Comments

  • BenBen AWS Team

    Team Member

    Hi @prime

    Do you have 1Password > Settings > Advanced > Security > Always show lock screen for Password AutoFill turned on? Could you please try toggling that setting, and see if the behavior is more in line with what you're looking for?

    Thanks!

    Ben

  • primeprime
    edited November 2019


    @Ben this?

  • BenBen AWS Team

    Team Member
    edited November 2019

    If you turn that on... and then also make sure 1Password > Settings > Security > Lock on Exit is turned OFF... how does that work for you?

    Ben

  • @ben I will give this a shot. As of now (before the changes in settings) all the setting matches my iPhone. This issues is after a restart and I have to put in my master password in the app, then my master password again on the extension when it pops up to auto fill. After that, it’s all fine from there, until the next restart.

  • BenBen AWS Team

    Team Member

    That really shouldn't be necessary if Touch ID is on. Please let me know what the outcome is. :)

    Ben

  • @Ben that did work. But the settings are now different from the iPhone that I didn’t have this issue with. I power cycled the iPad and I had to put in my master password (as I have the settings for this) and when I logged into this site, the extension popes opened and I didn’t need my finger to open it.

  • BenBen AWS Team

    Team Member

    Thanks @prime. Glad to hear that combination of settings is working better for you. If you'd like, you could probably set that same combination on the iPhone so the behavior matches.

    Ben

  • primeprime
    edited November 2019

    @Ben thats just it, I don’t have issues with the iPhone. After a restart, I put in my master password into the app itself, and that’s it. The extension only needs my Face ID to unlock then (I don’t need to re-enter my master password a 2nd time like I needed too for the iPad). I don’t need to put in my master password in a 2nd time.

  • BenBen AWS Team

    Team Member

    That's good. :)

    Ben

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file