Getting an error "We are unable to reach the server" when trying to save a password in Chrome

Internet is fine as I'm connected to all kinds of other things. The integration to 1Password desktop seems to be working fine too. Here are my settings:

Error:


1Password Version: 1Password 7 Version 7.4.2.BETA-0 (70402000)
Extension Version: 1Password X Beta 1.17.6
OS Version: MacOS Catalina 10.15.1
Sync Type: 1Password.com

«1

Comments

  • kaitlynkaitlyn

    Team Member

    Hey @bradical! If your internet seems to be acting fine, that error typically means that you'll need to re-authenticate your 1Password account. I've seen it happen when a change is made to an account (enable/disable 2FA, update email, change Secret Key/Master Password, etc.). To solve it, please visit your 1Password sign in domain and log into your account again (with your new credentials if they've recently changed). That should fix the connection with 1Password X, but let me know if that doesn't seem to do the trick.

  • bradicalbradical
    edited December 2019

    Would that be the case even if I'm using the 1Password X Beta with the desktop integration "Integrate with 1Password for Mac"? Is it still relying on connecting through the browser to 1Password.com in that case? I don't see any of the vaults listed in the extension view or the typical Signed Out message that I would see in the 1Password X (non-beta)

  • ceceliacecelia

    Team Member

    Hey @bradical! I just tested to confirm that you shouldn't have to re-authenticate in both the browser and the desktop app - just one. Have you already re-authenticated the changed account in the desktop app?

  • The Desktop App appears to be authenticated and nothing has changed there. Is there any way for me to confirm it's authenticated? I see two accounts: one personal (Family) and one work (Teams) and both say subscribed.

  • Hmm I'm guessing it's related to my other question here. When I attempt to sign into my 1Password for Families account on the 1password.com website, I'm getting the following: "Can’t sign in. LegacyServerError: Operation is not permitted." I'm confident the master and secret key are correct.

  • ceceliacecelia

    Team Member

    @bradical Ah, yes, that makes a lot more sense. We've had a few scattered reports about issues like this, and I believe the developer team has has tracked down the cause.

    1Password X isn't correctly clearing a previously created device secret when a user authenticates using [MFA](https://support.1password.com/two-factor-authentication]. Do you have MFA enabled on your 1Password account?

    The team is already working on a fix for this. In the meantime, reinstalling 1Password X should get everything working. Could you please try the following:

    1. Make sure you have your 1Password account credentials, especially your Secret Key, before reinstalling.
    2. Right-click the 1Password icon in the Chrome menu bar and select "Remove from Chrome".
    3. Install the latest beta version of 1Password X from the Chrome Web Store.

    Please let me know if that works and we'll reach out when we've published those MFA updates.

  • bradicalbradical
    edited December 2019

    1Password X isn't correctly clearing a previously created device secret when a user authenticates using [MFA](https://support.1password.com/two-factor-authentication]. Do you have MFA enabled on your 1Password account?

    I do!

    In the meantime, reinstalling 1Password X should get everything working. Could you please try the following:

    That worked -- thanks.

    Though I still seem to be experiencing a syncing issue where logins saved to my iOS are not syncing to my 1Password for Mac desktop app. Would that be possibly related? Do I need to do something to reauth my desktop app or mobile app? Both appear to be successfully logged in. Now that I'm able to access 1Password.com again, I can see a recently created login from the mobile app in there so it appears that it's the desktop app having trouble syncing.

  • ceceliacecelia

    Team Member

    Hey @bradical — I'm glad that worked! I'm not sure if that has anything to do with this issue but I'm happy to ask the devs. To be honest I'm a bit rusty when it comes to syncing the 1Password for iOS and Mac apps, but while we await a response, can you check if you still have a standalone vault in 1Password on your iOS device? It's possible the Login item you're changing on iOS is in a standalone vault that hasn't been swapped over to your 1Password account's vault(s).

  • Thanks @cecelia. I did not have a standalone vault but restarting my computer fixed the syncing issue. Confirming that I'm able to login to 1Password.com with both accounts using 2FA, save passwords and sync across devices again. All set. Thanks for the assistance.

  • kaitlynkaitlyn

    Team Member

    That's awesome, @bradical! I'm glad to hear that you're all set now. If there's anything else we can help you with, don't hesitate to reach back out. :chuffed:

  • Hmm so this is happening again in the same browser, different profile. The procedure mentioned here is not fixing it this time. Any suggestions on how to deal with this? Clear local cookies in this browser session?

  • I'm seeing the following error in the console associated with this:

    Sign in failed:  LegacyServerError: Operation is not permitted.
        at new t (https://app.1password.com/js/b5-52a40cd6216134a3d6f8.min.js:1:128613)
        at https://app.1password.com/js/b5-52a40cd6216134a3d6f8.min.js:1:343080
        at Array.l (https://app.1password.com/js/vendor-bea8729b2c834818cb7c.min.js:65:142354)
        at https://app.1password.com/js/vendor-bea8729b2c834818cb7c.min.js:65:142016
        at https://app.1password.com/js/vendor-bea8729b2c834818cb7c.min.js:65:21723
        at _ (https://app.1password.com/js/vendor-bea8729b2c834818cb7c.min.js:65:21833)
        at s (https://app.1password.com/js/vendor-bea8729b2c834818cb7c.min.js:65:21196)
    
  • kaitlynkaitlyn

    Team Member

    @bradical – Do you recall what action was associated with the Sign in failed error? I'm wondering if that error appeared after you tried to save a new Login item or something else. It's hard to tell with only one log, so I'm hoping that you remember. If not, perhaps you can reproduce the issue and let us know.

  • It was happening on login to 1Password.com at the same time I was seeing this error: "Can’t sign in. LegacyServerError: Operation is not permitted."

  • I'm getting this issue.

    Here's what I've done so far:

    • Uninstalled/reinstalled 1Password X
    • Uninstalled 1PX and installed 1PX-beta - issue persists
    • When I get to login page it first says it's not a supported browser on both extensions. (Using Brave v1.1.20)
    • Perform a hard refresh, login page shows up (on both extensions) but then get:

      Can’t sign in.
      LegacyServerError: Operation is not permitted.

    • Attempt above steps a private window - issue persists

    Let me know what I can provide to help y'all resolve this. I'm going insane without it.

  • ceceliacecelia

    Team Member

    Hey @JREakin and @bradical - I've reached out to both of you separately via email to sort this out. :) See you there!

  • hi I have the same problem loggin in my.1password.com

    I'm trying with chrome 79, 78 and firefox 72 and 73 and always have the same problem.

  • kaitlynkaitlyn

    Team Member
    edited January 11

    Hi @woakas! Since the issue is going to be account specific and we wouldn't want to discuss any account-related info in a public forum, I'll go ahead and reach out to you via email.

    ref: UID-72714-715

  • I've having the same problem today: "Can’t sign in. LegacyServerError: Operation is not permitted."

    I have reached out to Support. I'm locked out of the web interface of 1Password so any help would be appreciated.

  • kaitlynkaitlyn

    Team Member

    Thanks for letting us know, @bradical. Did you end up being able to sign into your account later that day? Also, which browser did it happen in?

  • I was able to sign back in once the support team reset something on the app. Seems like there is still an issue with using 2FA where occassionally we run into this.

  • kaitlynkaitlyn

    Team Member

    @bradical – I'm glad my team was able to help. We've got something in the works which should hopefully end this once and for all. It still needs to be tested internally, then we'll eventually push it to the beta build first. You're doing the right thing by remaining on the beta.

    ref: dev/core/core!756

  • Thanks! I saw mention of a 1.18.4 but can't seem to download it

  • ag_anaag_ana

    Team Member

    @bradical:

    What happens exactly when you try to download it? Do you get an error message, or does something else happen?

  • I was using the in-app Updates button on the extension:

    as well as the Check for Updates button on the extension's right-click menu:

    The latter just said that it was "up-to-date" on v1.182. The former just said extensions updated but the Extension stayed on the same version.

    Do I need to go re-download it from the Store?

  • .@kaitlyn It looks like the issue has returned with 18.4

    I'm attempting to update a password that was tagged as compromised in 1P, in Twitter settings, and this has occurred. I'm using Brave
    v 1.2.43

  • Yea, now I'm having a different issue after finally getting the upgrade to 1.18.4 to work:

  • kaitlynkaitlyn

    Team Member

    @bradical – The 1.18.4.beta update was published around 7am Pacific time today, so that's likely why you weren't seeing the update before that.

    I haven't seen that error before myself. Before you noticed it, were you attempting to add your account to 1Password X, or what other steps were you taking prior to the error?

  • I haven't seen that error before myself. Before you noticed it, were you attempting to add your account to 1Password X, or what other steps were you taking prior to the error?

    No steps take prior. Just updated the extension and attempted to login to my 1Password for Teams account online

  • kaitlynkaitlyn

    Team Member

    @bradical – Do you mind if we switch over to email? Since this is account specific, and I wouldn't want to confirm anything on a public forum, I think it'd be better to move to email. I'll reach out to you there.

    ref: XRW-74365-767

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file