7.4.2 Beta is broken

So I downloaded the update. Installed just fine. No biggie.

But then Chrome and the app didn't recognise each other. Uninstalled and re-installed the extension. Quit and restart Chrome. No dice.

Then I noticed the Mini wasn't opening up in Safari either, nor when I clicked on it in the menu bar. So I right-click 'Quit 1Password Completely'. And it goes away....

....for a few seconds. Then it starts itself right back up again! Without my permission! And this happens every single time I quit it. The app and menu bar icon go away completely, and then it starts right back up again a few moments later.

I had to slay it in the middle of a 1Password 7.4.1 re-installation just to get it to go away long enough for the install to complete, and I think I may have just about managed it. Then, of course, as soon as I open 7.4.1 it prompts me to update!

Put this one back in its cage please guys!


1Password Version: 7.4.2
Extension Version: Not Provided
OS Version: macOS 10.15.1
Sync Type: Not Provided

Comments

  • ag_tommyag_tommy

    Team Member
    edited December 2019

    Hi @Sheza

    Thanks for writing and especially for taking the time to document the problems you experienced. While I cannot say for sure what happened, I can say this is a very early beta, and it will only get better. I also have the beta installed and haven't noticed such an issue. But our systems could be vastly different.

    Did you get 7.4.1 reinstalled? If so, and you want to move off the betas temporarily. Please open the 1Password preferences, Updates tab, and deselect "Include beta builds."

    Lastly, I am going to move this over to the beta category. Please let us know if you need any assistance. We're always here to help!

  • I am having the same issue as @Sheza is having.

    I updated to 10.5.2 which prompted me to update to 7.4.2. I did. Everything works fine in Chrome, however, with Safari the extension will not come up to log me into websites.

    macOS 10.15.2
    1Password 7.4.2.BETA-0 (70402000)
    Safari 13.0.4 (15608.4.9.1.3)

  • ag_tommyag_tommy

    Team Member

    @jdpierce21

    I have to admit, I have seen some weirdness with the last few updates from Apple. I would recommend trying a few troubleshooting steps, which you may have already completed.
    1. Open Safari Preferences > Extensions toggle the browser extension from on to off, ending in the on position.
    2. Restart Safai
    3. Restart the Mac * Lately, I have been using shutdown, and then doing a full restart.

  • I am seeing the same issue as @jdpierce21, with 1Password 7.4.2.beta-0 on macOS 10.15.2.

    1password in Safari does not work.
    If I use the 1password shortcut, press the 1 password icon in the menubar or safari addressbar nothing happens. If I switch to a different app (any app will do), the menubar icon works again.

    There are no issues in Chrome running 1passwordX.

    I have successfully downgraded to 7.4.1 and restored 1password in safari

  • I am seeing the same issue that on Mac OS 10.15.2 the plugin for safari in the 7.4.2 beta does not work at all.

  • jeffreyhjeffreyh
    edited December 2019

    I seem to have solved my problem by deleting the beta from my system, reinstalling 7.4.1 from agilebits.com and then reinstalling the beta from the 7.4.1 preferences. Once I reinstalled things started to work again.... Really strange.... This solved both my problem with safari not working and 1passwordX on Chrome not communicating with the beta.

  • ag_tommyag_tommy

    Team Member

    Thanks for the report @mosins and @jeffreyh I am glad you're both up and running again. If you notice any additional behaviors, please post back.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file