1Password 7 extension for Microsoft Edge on Mac

pcalliespcallies
edited December 2019 in Mac

I see that Edge build 80.0.361.5 now supports extensions. Will there be a 1Password 7 extension created? I'm using 1Password X, but really, really miss touch ID support because I use a long, secure master password. I don't like needing to type it in every time I need password info.


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

«1

Comments

  • LarsLars Junior Member

    Team Member
    edited January 2

    Welcome to the forum, @pcallies! Microsoft Edge for Mac is now built from a Chromium base, which means we don’t need a separate extension -- though we may indeed have one in the official MS Edge for Mac extensions store at some point. For the present, this isn’t exactly pretty, but it can be done if you want to use the companion 1Password extension instead of 1Password X. You’ll need to be using the beta version of MS Edge (not Dev or Canary) and the beta of 1Password 7 for Mac You'll also need to have already had Chrome installed on your Mac. If you've never had Chrome, install it first, then install the 1Password extension for Chrome from the Chrome Web Store. Then proceed:

    • Update to the latest beta version of 1Password for Mac, if you’re not already running it (you can enable beta builds by clicking the "Include beta builds" checkbox in 1Password > Preferences > Updates)
    • Install Edge beta from Microsoft
    • Click Microsoft Edge > Microsoft Edge Extensions, then click Allow extensions from other stores at the bottom left of the extensions window.
    • Visit https://1password.com/browsers and click the Chrome option, which will take you to the Chrome Web Store page for the 1Password companion extension. Install it into Edge.
    • Quit Edge.
    • On your Mac, in Finder, choose Go > Go to Folder, then copy and paste the following in the pop-up: ~/Library/Application Support/Google/Chrome/NativeMessagingHosts/
    • In Finder again, type ⌘N to open a new Finder window.
    • Choose Go > Go to Folder once more, then copy and paste the following in the pop-up:~/Library/Application Support/Microsoft Edge Beta/NativeMessagingHosts/
    • Return to the first window (Chrome folder), and single-click the file titled 2bua8c4s2c.com.agilebits.1password.json in that folder to select it, then use command-c to copy that JSON file to your clipboard.
    • Switch to the second folder (Edge folder) and paste the copied JSON file into this folder.
    • Open Edge from your Applications folder.

    Now, when you click the 1Password extension icon in your browser's toolbar, you should get the familiar 1Password mini pop-up. Let me know how that works for you.

  • Hi,

    I've just tried the above solution @Lars and get an error message about 1Password not trusting Edge...

  • I have the exact same issue and did apply the solution proposed by @Lars. Resulting in the same experience that @Tezcatlipoca encountered.
    I do need to say that on my other system the Edge extension works perfectly. Both are running Cataline latest release with all updates. More or less the exact same applications and configuration as well as the latest 1Password application.
    I do a lot of development on Microsoft Azure IoT solutions and do need Edge as my preferred browser.
    Please advice as this is very annoying.
    Thnx,
    E

  • ag_anaag_ana

    Team Member

    @Tezcatlipoca, @EdwardV:

    Can you please let us know what version of the 1Password app and of the Edge browser this is happening with?

  • EdwardVEdwardV
    edited December 2019

    Hi @ag_ana, I'm using Edge Beta version Version 79.0.309.54 (Official build) Beta (64-bit) and 1Password 7 Version 7.3.2 (70302004) both on MacOS Catalina 10.15.2 on all my Macs.
    Hope this helps.

  • ag_anaag_ana

    Team Member

    Thank you for the confirmation @EdwardV! Can you please try updating 1Password to version 7.4.1? Version 7.4 included some fixes for the Edge browser, so I would like to see if this can be fixed by updating your app.

  • Unfortunately the update didn't do the trick.
    I conducted the following steps:

    • Removed the plugin from the Edge browser and restarted the Mac
    • Updated 1Password7 to the 7.4.1 version and restarted the Mac
    • Installed the plugin on the Edge Browser, followed the steps from @Lars and restarted the Mac
      The Icon is present (grayed out) and I can select 1Password however nothing happens.
      See attached screenshots.

    Thnx,
    E

  • Hi @ag_ana

    I'm using 1Password 7 Version 7.3.2 (70302004) from the 1Password Store, which according to the "Check for updates" menu option is the latest version?

    Edge is Version 79.0.309.54 (Official build) Beta (64-bit).

    Both are running on a 2019 iMac with macOS 10.15.2

  • I've just tried this again, after updating to 1Password 7.4.1, and it still does not work :( I still get the error message about 1Password being unable to verify the browser's identity.

  • Any further ideas to help? :)

  • Anyone?

  • LarsLars Junior Member

    Team Member

    @EdwardV - the "gray" part is a little misleading. If you have Dark Mode enabled, that's actually the way it looks; it's the same for me here. Out of curiosity, if you click edge://extensions/, is Allow Extensions from other stores checked in the lower-right of the window? If so, click the 1Password extension listed there: what do you see? Can you post a screenshot of that, please?

  • LarsLars Junior Member

    Team Member

    @Tezcatlipoca - did you restart both Edge and quit 1Password 7 for Mac completely, then restart it? It may be simpler to restart your Mac, but you can Quit 1Password 7 completely by typing ^⌥⌘Q (or just holding down the Control and Option keys as you choose Quit from the 1Password menu). You'll also want to make sure that both 1Password for Mac and MS Edge for Mac are located in your main /Applications folder, and not anywhere else, or code-signing will fail.

  • Thanks @Lars . I did quit Edge completely, but I didn't quit 1Password completely as that wasn't mentioned above. I shall give that a go...

  • Hi @Lars -

    Nope, still no joy :(

    I made sure that Edge and 1Password were quit completely prior to copying the JSON, and then even rebooted afterwards for good measure, and it still does not work.

  • LarsLars Junior Member

    Team Member

    @Tezcatlipoca - thanks for checking that. Is it possible you have more than one copy of 1Password installed somewhere -- perhaps an older version, on an external/backup disk? If so, try unmounting that disk first and seeing whether that changes anything.

  • @Lars -

    Nope. There was a zip (now deleted) in Applications from when I updated to 7.4.1, and the only backups are my Time Machine backups (external drive temporarily unmounted) - still no luck.

  • Hello @Lars, first a happy New Year and keep up the good work!
    Attached the screenshots.
    I disagree with your explanation regarding the grayed out 1Password icon in Edge. Again it is working (and the icon isn't grayed out) on my other systems.
    Anyway. I removed the plugin from Edge. I completely quit and removed 1Password from my Macbook. Reboot. Installed 1Password again. Reboot. Added the plugin to Edge. Completely quit 1Password. Copied the JSON file. Reboot.
    Exactly the same issue . . . again.
    I give up.

    Best,
    Edward

  • LarsLars Junior Member

    Team Member

    @EdwardV - sorry for the continued difficulty. Please try the following:

    • Quit MS Edge for Mac, and quit Safari if it is running
    • In 1Password 7 for Mac, click 1Password > Preferences > Updates
    • Check the box marked "Allow beta builds"
    • Click "Check Now," and install the beta version of 1Password 7 for Mac.
    • Re-open both 1Password 7 for Mac and MS Edge for Mac.

    Try visiting a website and signing in using the 1Password extension.

  • LarsLars Junior Member

    Team Member

    @Tezcatlipoca - please see my instructions above to @EdwardV and see if the beta version of 1Password for Mac allows you to do this.

  • LarsLars Junior Member

    Team Member

    For anyone else following this thread, this should be considered an beta/experimental feature at this point, since as of yet we don't have an extension available in the Microsoft Edge for Mac store. The above instructions will work, but only if you're willing to run the beta of both Edge and 1Password 7 for Mac, and are comfortable copying the Native Messaging JSON file around. Having to jump through those hoops is not the kind of experience we want users to have to go through, which is why I say it should be considered at this point an advanced option that’s not yet fully supported.

  • @Lars -

    Installing the beta worked! I'm posting this from the Chromium version Edge having logged in using a working 1Password extension :)

  • LarsLars Junior Member

    Team Member

    @Tezcatlipoca - excellent! My apologies for the confusion; I've been running the betas of our software for so long that it didn't initially occur to me that might be a requirement for this; apparently it is. Glad to hear you're all set.

  • @Lars, Houston, we have a lift-off :-)
    The last installed Beta is working like a charm. Icon is still grayed out but that is a minor issue that I don't concern as a show stopper.
    Thanks for your assistance perseverance @Lars, appreciated.
    Great way to start the year, chapeaux for Agilebits support!!
    Thnx,
    E

  • ag_anaag_ana

    Team Member

    On behalf of Lars, you are welcome! If you have any other questions, please feel free to reach out anytime.

    Have a wonderful day :)

  • DJFriarDJFriar Junior Member

    Now that it is late February is there any update on this? I want to be able to use the standard Cmd-\ shortcut but it doesn't seem to work. I installed the 1Password X but it is making me click the icon, then click on AutoFill, then click on login.

    Is native 1Password 7 integration coming or is X the only way to do it? I can't use the Beta versions as it is a work machine.

  • BenBen AWS Team

    Team Member

    @DJFriar

    I don't have anything to add at the moment. Integration between 1Password for Mac and 1Password X is being beta tested. Once we feel it is stable enough to release we'll push it out to the non-beta channel. There is still work to be done there though, so I wouldn't expect that to happen in the immediate future.

    Still a work in progress. :)

    Ben

  • DJFriarDJFriar Junior Member

    I am not a fan of the X initiative, (its ugly, and I would need the app installed anyway so there is really no point in X to me), so I really only care about 1P7 having integration to Edge. X is fine I guess for those people who are using the very basic feature set, but its pretty lacking in my opinion compared to the actual app, and since I have to have the actual app installed anyway, I don't want to also have to install X as well.

  • BenBen AWS Team

    Team Member

    Thanks for the feedback. :+1:

    Ben

    • 1Password 7, Version 7.5.BETA-1 (70500001), 1Password Beta
    • 1Password extension, Version 4.7.5.90 (Chrome Web Store)
    • Chromium Microsoft Edge for Mac, Version 81.0.416.64 (Official build) (64-bit)
    • macOS Catalina, Version 10.15.4

    As everything was running smoothly, I thought I'd completely remove Chrome from my Mac, only to find that doing so stopped the 1Password extension in Edge from working.

    Not wanting to keep Chrome or the insidious Google Updater, I now have the "~/Library/Application Support/Google/Chrome/NativeMessagingHosts/" folder containing the 1Password JSON file, but with no actual trace of Chrome itself there or anywhere else.

    Is there no way to use the 1Password Chrome extension on Chromium Edge without first installing Chrome or manually creating the Chrome NativeMessagingHosts folder?

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file