Autofill initially fills incorrect form details. Autofilling a second time enters the correct info

As per a comment on this discussion, @kaitlyn asked me to provide more information.

I've experienced this on a handful of pages, one reliably reproducible one is https://console.aws.amazon.com

Clicking on Autofill for the relevant login, appears to make use of the account2 and username2 web form details the first try. Clicking on Autofill a second time will use the correct account and username web form details.

As mentioned in the previous discussion, modifying/removing the web form details is not possible on 1PasswordX.


1Password Version: Not Provided
Extension Version: 1.17.0
OS Version: Linux (Firefox)
Sync Type: Not Provided

Comments

  • Hey @mheynz, thanks for this report. Would you be able to attach a screenshot of the sign-in page, too, and/or provide steps to get to the page you're having trouble with? I think the page I'm hitting might be a bit more simplified and not what you're looking at. Thanks!

  • On AWS this is happening to me as well. My 1P entry for this account has an OTP associated with it, and even though the additional form details has a value for the account field, it's getting replaced by an OTP value.

  • kaitlynkaitlyn

    Team Member

    Hi there @berto! You're running into a separate issue, but I'm still happy to help. A couple weeks ago now, the AWS sign in page was changed under the hood, which threw off 1Password a bit. Since then, we've pushed a fix to 1Password X. That said, I can see that you're using the 1Password companion extension rather than 1Password X. I don't have an update on when the fix will be released to the 1Password desktop apps. We did find a workaround, though. What you can do is add a custom section with a label of account and a value of [your account number]. That should resolve filling in the meantime, even with the 1Password companion extension that you're using. Let me know if you have any trouble!

  • Yes, adding a field by that name worked!

    I’m confused as to why the value by that name in “additional form details” is not used.

  • kaitlynkaitlyn

    Team Member

    @berto – I'm happy to hear that worked for you! After the 1Password desktop apps update the filling algorithm, the workaround won't be necessary any longer. :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file