"No items in this vault." - firefox extension not syncing correctly

leifdenbyleifdenby Junior Member

When I open the 1Password X firefox extension there are no items in my vault (!) However they appear correctly if I visit my.1password.com and in the Chrome extension. See screenshot for details.

I think this might have occurred because my computer ran out of space and the local database that the firefox extension uses to store the vault has become corrupted. I have tried reinstalling the extension and I have also tried removing the files that I think the extension stores data in (requiring me to log in again). Neither have worked unfortunately.


1Password Version: Not Provided
Extension Version: 1.17.0
OS Version: CentOS 7
Sync Type: via 1Password.com

Comments

  • I'm having the same issue, however, it is not due to a space issue. I've tried logging out and back in again via the 1PasswordX extension, however, that does not fix the issue. The strange thing is that I see my personal and family vaults, however, there are no logins.

    Extension Version: 1.17.0
    OS: Deepin 15.11
    Sync Type: 1Password.com

  • I had this problem too, and I solved it by upgrading Firefox. It turned out that the version of Firefox managed by the OS was lagging behind, and I was several version numbers behind. I downloaded the latest Firefox and now it's working.

    There's a technical discussion at http://openbsd-archive.7691.n7.nabble.com/Firefox-extension-broken-in-current-s-v71-0-td380061.html that mentions possible interference with the uBlock Origin extension (which I also have), in case that helps anyone.

    I'm on Ubuntu 14.04.

  • Can confirm this problem happens on:
    OS: openSUSE Leap 15.1
    Browser version: Firefox 71
    Extension Version: 1.17.0

    Reproduction steps:

    • Install openSUSE Leap 15.1 system (Firefox 71 will be installed by default)
    • Open Firefox and install 1password extension
    • Login to 1password
    • Go to a website which you have credentials stored on 1password
    • 1password extension should show the suggestions/fill autologin info, but show the image on the original post ("No items in this vault")

    This doesn't happen on:

    • SUSE Linux Enterprise Desktop 15 SP1 up-to-date, Firefox 68.3.0esr, 1password 1.17.0
    • Windows 10 up-to-date, Firefox 71, 1password 1.17.0
  • leifdenbyleifdenby Junior Member

    Thank you! I just updated to Firefox 68.3.0esr and I can now see the items in my vault.

  • Didn't even think to look at the FF version. Was running 60.4.0esr. Upgraded to the latest (71) and now 1PasswordX is behaving normally again. Thanks!

  • kaitlynkaitlyn

    Team Member

    I'm loving the collaboration here! I'd always recommend staying up to date on browsers, but our plan is to raise 1Password X's minimum version as well so we can avoid any confusion in the future. We want as many people to have the ability to use 1Password X as possible, but it's crucial for us to put our focus on the most up to date versions for both privacy reasons and because that's where we're primarily doing our own testing.

    I'm glad to hear that updating Firefox worked for you, @leifdenby! If anyone else is still having trouble or has any questions for me, don't hesitate to ask. :)

  • I was caught out by this recently, and an only one-year old version was suddenly not new enough.

    Where do you publish your required minimum version of firefox?

    PLEASE mark these things in either 1Password X (ideal - just a message saying Unexpectedly Empty? Try upgrading your browser) or at least in the release notes. These release notes made no reference to this breaking change in 1.17.x

  • kaitlynkaitlyn

    Team Member

    @j_son – The minimum versions are stored in the 1Password X code, but updating the minimum version is something we did only recently. It should be in the 1.18.1.beta update once it's approved (as well as the 1.18.1.beta changelog entry here), but it's not something you'd see right now. Out of curiosity, what version of Firefox are you running?

  • I was running Firefox 65, released Jan 2019.

    The average user isn't going to go into the code - they're going to wonder where their passwords went. I'd strongly suggest a note be added to the release notes (if people look there), the website, and into 1Px itself to make people aware that a rather new version is now required.

  • ag_anaag_ana

    Team Member

    Thank you for the feedback :+1:

  • I'm using 1password in Chrome and Firefox and desktop
    Chrome & Desktop are up to date
    Firefox is not it's not syncing

  • ag_anaag_ana

    Team Member

    @aalkhubaizi:

    What version of 1Password X are you currently running, and on what version of the Firefox browser?

  • edited January 21

    1password x version 1.17.0

    firefox 72.0.2

  • kaitlynkaitlyn

    Team Member

    Hey @aalkhubaizi! When you say that Firefox is not syncing, do you mean that you're seeing the same "No items in this vault" message like the original comment in this thread? Otherwise, is 1Password X not syncing with a desktop app you have installed? Or are you seeing an error of some sort? Let me know; I'm here to help.

  • @kaitlyn I can see only old information,

    my default browser is Chrome and my 1password x extension in chrome is my main application to add new passwords

    so any new entry I added via chrome it's i can find it on the desktop app

    for testing purposes, I do need to switch to Firefox I need to use 1password x to login to my portal i found that

    1password x in Firefox is not up to date, it has old data, new data is not exist

  • ceceliacecelia

    Team Member

    Interesting. Thanks for clarifying, @aalkhubaizi. If you sign in to your 1Password account on 1Password.com in Firefox, do you see the new data there?

  • Yes when I logged in into my account via Firefox i can see my new data

  • kaitlynkaitlyn

    Team Member

    @aalkhubaizi – I see what you're saying. It sounds like 1Password X needs to be re-authenticated in Firefox. As a troubleshooting step, could you try removing your account and re-adding it? Please follow these steps to do so:

    1. Right click on the 1Password icon in your Firefox browser toolbar and select Settings.
    2. Scroll to the bottom of the page, and click the Sign Out button next to your account.
    3. Click Sign in to another account.

    Please take a look at the 1Password X pop-up after that, and let me know if your new items have populated.

  • works fine now after i followed your steps, thanks a lot

  • kaitlynkaitlyn

    Team Member

    No problem at all, @aalkhubaizi! Let us know if you run into any more trouble.

  • edited February 6

    @kaitlyn I have a similar problem here with 1.18.0 (Empty vault and not syncing) whereas 1.17.0 worked flawlessly (but doens't either since upgrading to 1.18.0 and downgrading to 1.17.0 again). My setup:

    1. FrontMotion Firefox 60.8.0 (can't change that :-))
    2. 1Password X 1.17.0 -> worked flawlessly -> upgrade to 1.18.0 -> broke -> downgraded to 1.17.0 (removing all cookies, adding the account again) still broken

    Looking into the debug logs, it seems that in my case, it's related to MFA (I recently had a security key setup w/ 1Password which posed no problem with 1.17.0).

    With either version of the extension,

    • starting from no accounts and all cookies deleted,
    • once I've added the account to 1Password X, while of course
    • using the 2MFA key when logging into the account in the browser to add the vaults to the extension,

    whenever I unlock the vault from 1Password X, I see an empty vault and the following error appears repeatedly and systematically in the console:

    [...]
    TypeError: O is undefined[Learn More]  background.js:27:48465
    [action/Session#verify] ClientError: Please authenticate with MFA
    Stack trace:
    [email protected]://c693641b-adea-43cb-9fb1-1d1f37b8d356/background/background.js:27:161257
    e/this.verify/</<@moz-extension://c693641b-adea-43cb-9fb1-1d1f37b8d356/background/background.js:27:365513
      background.js:27:174209
    [action/auth#signInWithMpAndSk] ClientError: Please authenticate with MFA
    Stack trace:
    [email protected]://c693641b-adea-43cb-9fb1-1d1f37b8d356/background/background.js:27:161257
    e/this.verify/</<@moz-extension://c693641b-adea-43cb-9fb1-1d1f37b8d356/background/background.js:27:365513
      background.js:27:174209
    [action/auth#signIn] ClientError: Please authenticate with MFA
    Stack trace:
    [email protected]://c693641b-adea-43cb-9fb1-1d1f37b8d356/background/background.js:27:161257
    e/this.verify/</<@moz-extension://c693641b-adea-43cb-9fb1-1d1f37b8d356/background/background.js:27:365513
      background.js:27:174209
    [...]
    

    As far as I can tell from the profile folder, no local data exists anymore (extension-data directory of the extension is empty, and nothing related to 1password found in other storage locations I could identify).

    Is this something you can confirm, any idea where to look for a solution? As outlined above, what's special is the fact that until upgrading to 1.18.0, everything worked fine with 1.17.0, but now even having downgraded again, I can't get back to a working setup anymore.

  • kaitlynkaitlyn

    Team Member

    Thanks for getting in touch, @johannrichard. I'm actually pretty surprised that 1.17.0 worked as well as it did for you. We recently raised the minimum Firefox version required to use 1Password X to Firefox ESR 68. You mentioned that you're using Firefox 60.8.0, and that can't be changed, but I'm curious why you're unable to update.

    The MFA errors you're seeing in your 1Password X log are more than likely red herrings. Is that the only error you've ever seen other than the "No items in this vault" message? I'm thinking the outdated version of Firefox is the culprit here, as that's been the case with other reports. Do you have any other computers with a up-to-date version of Firefox you could try it out on? The current version of Firefox is 72.0.2.

    Let me know what you find!

  • For the Firefox version: that's related to IT policies (Work environment), and a slow upgrade pace.

    As for the problem itself: I have downgraded to 1.16.2 now and there everything works again. Might have been lured to believe that I had had 1.17.x installed because it is marked as having Firefox 60 as minimum version. Your comment on 1.17.0 working that well was the key, thanks again!

  • drizztdrizzt
    edited February 12

    Same problem here on Fedora 31 running FF 72.0.2 and 1P Addon 1.18.0. It was working for two days and not I get the "No items in this vault" error.

    Logging out and in in the addon as suggested by @kaitlyn did not help.

  • kaitlynkaitlyn

    Team Member

    @johannrichard – I'd suggest attempting to get your work to upgrade the system as quickly as they can. Running outdated browser software can cause more harm than good.

    @drizzt – That's interesting that you're seeing it in Firefox 72. What happens when you restart Firefox? Do you see the same error?

  • edited February 29

    Hi I'm using firefox 68.5 ESR and onepassword X 1.18 and I have the same problem.
    I am logged in and I just see nothing in my vault. It's empty.
    @kaitlyn
    1password works everywhere else on my laptop (desktop client) and chrome browser.
    I tried restarting and logging in and out, also uninstalling and reinstalling - no luck.

  • Update:

    I uninstalled and reinstalled the extension

    ALSO: I tried using it from my home WIFI vs my work.
    Now it's working.
    Not sure what "fixed it" though.

  • ag_anaag_ana

    Team Member

    @giladgressel:

    Thank you for the update! I am glad to hear that you managed to get things sorted out already :+1:

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file