TOTP autofill on Epic Games not working

The TOTP autofill does not work on the Epic Games login page using 1Password X Beta (tested with Brave and Firefox) while the username and password work just fine.


1Password Version: Not Provided
Extension Version: 1.18.0
OS Version: OS X 10.15.2
Sync Type: Not Provided

Comments

  • ceceliacecelia

    Team Member
    edited January 4

    Hey @Terethlor! Thanks for reporting this. This is a somewhat tricky one. It looks like the "remember me" box on the username/password page of the login form being checked changes the some things behind the scenes in the TOTP field on the next page. The changes are just enough of an indicator to make 1Password believe it shouldn't fill there. If you get to the TOTP page and we haven't filled that field, you can re-prompt from the pop-up by clicking the Autofill button and your TOTP code should fill just fine.

    I say it's tricky because Epic defaults to that box being checked every time you load that page, so with the current configuration, you'll have to either remember to uncheck that box (before filling your username and password) every time you sign in or re-prompt 1Password to fill the TOTP on this page.

    I apologize for the obstruction this has been to your flow, and I've gone ahead and filed an issue for this with the developers to see if they can improve the filling experience here. I hope the workarounds I provided will help a little while we wait for them to take a look.

    ref: dev/core/core#741

  • ceceliacecelia

    Team Member
    edited January 2

    Hey again @Terethlor — This seemed so weird I couldn't help but poke around some more and found some new info that I hope will make your life easier. It turns out this issue only occurs when the Login item is saved from the login form page because we're saving the "remember me" box in the Login item which is causing 1Password to believe it doesn't need to fill TOTP. If you don't mind I'd like to ask you to try a few steps and see if this fixes things:

    1. Open and unlock the 1Password desktop app.
    2. Navigate to the Epic Games Login item.
    3. Choose the Edit option.
    4. Scroll down in the Login item's details and click "View Saved Form Details."
    5. Find rememberMe and click the encircled red minus sign next to that field.
    6. Save the changes and try filling the Login item on epicgames.com. 🤞🏻
  • Hi @cecelia! After deleting the checkbox element from the web form details, the TOTP autofill now works as expected. Good to know that the saved web form details affect the TOTP autofill behaviour. Thank you very much for your help!

  • ag_anaag_ana

    Team Member

    On behalf of cecelia, you are welcome! If you have any other questions, please feel free to reach out anytime.

    Have a wonderful day :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file