Auto-fill won't let me pick from multiple accounts for the one domain

Some websites I have several accounts spread across different vaults (e.g. personal, work, and team Apple IDs).

Using the keyboard shortcut sometimes auto-fills one of the accounts, instead of showing the extension window so I can select which account I want to use for the website. It will keep doing this for a while, and then spontaneously go back to showing the list of accounts, seemingly without me changing anything.

When it auto-fills, it's the same account every time, as if I only have the one account that matches the domain. But if I click on the extension icon I can see that multiple accounts are matching.

This is currently happening sporadically for me at https://idmsa.apple.com (when trying to log into https://developer.apple.com/account), but seen it on other sites as well.

Thanks all!


1Password Version: 7.4.2.BETA-1
Extension Version: 4.7.5.90
OS Version: macOS 10.15.2
Sync Type: 1Password

Comments

  • YaronYaron

    Team Member

    Hey @commscheck ,
    If your 1Password is currently viewing a specific vault, and that vault only contains one login item for the website, then autofilling would immediately use that login instead of showing all options (since this is the only option to view in that vault). However, if you are on the "All Vaults" view in 1Password, then it will show you all the logins from all vaults. The moment 1Password mini will see there's more than one login for a website, it will show up and ask which login you want to use instead of autofilling on its own.

    You can switch between a specific vault view in numerous ways:

    • You can open the 1Password desktop app, click the "Vault" menu on the top menu bar of your Mac and select "Switch to vault" -> "All vaults".
    • You can choose a vault on the left sidebar of the 1Password desktop app (or choose "all vaults").
    • You can click the 1Password extension icon in your browser to show 1Password, then click the little vault icon on the top left next to the search bar and switch from there.

    I hope that clarifies things.

  • Hey @Yaron, thanks for the reply! I checked the vaults setting in both desktop and mini, I can reproduce the problem when both are set to "all vaults". I very rarely switch to specific vaults, usually just rely on search.

  • Sorry, just figured it out. One of the accounts had a slightly different subdomain that was a closer match than all the others. Thanks again!

  • ag_anaag_ana

    Team Member

    On behalf of Yaron, you are welcome! Thank you for the update :)

    If you have any other questions, please feel free to reach out anytime.

    Have a wonderful day :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file