1Password X problem in Edge browser

SystemSystem

Team Member
This discussion was created from comments split from: 1password extension not working on new edge chromium browser.

Comments

  • I have the same issue with the 1Password extension too but am already running 7.4.1. I am also finding that the 1PasswordX extension doesn't disable any characters when entering the master password to unlock my vaults.

  • ag_anaag_ana

    Team Member

    Hi @nikoxley!

    Can you please let us know what version of 1Password X you are using? The original poster in the original discussion was using the companion browser extension, rather than 1Password X like you. So if you could confirm that, it would be very useful. Thank you!

  • I've been attempting to use both the 1Password and 1PasswordX extensions. The 1Password extension doesn't appear to be able to connect back to the 1Password desktop app successfully for me at all hence me then attempting to use the 1PasswordX extension. The latter is on version 1.17.0.

  • kaitlynkaitlyn

    Team Member

    @nikoxley – Ah, I see what you're saying. You should be able to use the desktop-dependent 1Password extension in the new Chromium-based Edge after the next update of 1Password for Mac. You are welcome to use 1Password X for now if you'd like. I'm not sure what you mean when you said that 1Password X "doesn't disable any characters when entering the master password to unlock my vaults." Could you elaborate on that or let me know the steps you're taking to reproduce the issue? Thanks!

  • Sorry my bad, I meant to type that no or not all characters are displayed when I type my master password when unlocking 1PasswordX. If I type my password in correctly it does actually unlock though however.

  • ceceliacecelia

    Team Member

    Thanks for clarifying @nikoxley. That sounds familiar. Would you happen to be using 1Password X on an external display when this behavior occurs?

  • I most certainly am yes!

  • kaitlynkaitlyn

    Team Member

    @nikoxley – Cecelia's onto something! There's currently a bug in Chromium that causes some lag in extensions that have pop-ups while using an external display. If you're curious about the issue, you can check it out here. The good news is that your Master Password is being typed even though you can't see it in its entirety. Typing your Master Password and pressing enter allows you to sign in or you can always move the browser window over to your primary display. I hope that helps clear things up.

  • I tend not to use the 1PasswordX extension and certainly don’t use Chromium browsers much until Edge shipped so that will explain why I’ve not come across this bug before.

    Thanks for making me aware of that anyway. Any news on when the new 1Password desktop app is likely to be released so I can go back tot the full extension?

  • kaitlynkaitlyn

    Team Member

    @nikoxley – As far as I know, the next update to 1Password for Mac should allow you to fill in the stable version of Edge. When that's coming, I'm not too sure of. As of right now, the Edge beta is still supported since that's the way it was before the stable version was released.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file