1Password X on chromebook-controlling autofill-but autofill not working

Aloha! I have been using 1Password X on my Chromebook, and according to Chrome settings, 1Password X is controlling Autofill. But, autofill is not working on any web page where I need to enter my address, phone number, email, etc. How do i get this feature to work? I don't see a setting inside 1Password X for anything related to Autofill. Thanks!!


1Password Version: Not Provided
Extension Version: 1.17.0
OS Version: Chrome OS 79.0.3945.123 (Official Build) (64-bit)
Sync Type: I don't know...I use 1Password.com
Referrer: forum-search:autofill

Comments

  • kaitlynkaitlyn

    Team Member

    Hey @chasapple! I wouldn't recommend using both Chrome and 1Password to autofill for you. They tend to fight for your attention, so it can be a confusing process. 1Password X can actually fill addresses, phone numbers, emails, etc. by filling an Identity item, so that's an option as well.

    However, if you do want to allow Chrome to autofill in addition to 1Password, you can disable the setting in 1Password X that controls Chrome's autofill. To do so, right click on the 1Password icon in your browser toolbar, and select Settings. From there, scroll down a bit and disable the setting titled, "Make 1Password the default password manager."

    Let me know how that goes, and I'll be here if you have any questions!

  • aloha Kaitlyn: Thank you for the reply.

    Is there a way to make 1Password X do the Autofill, instead of the chromebook chrome browser? If so, I cannot figure out how to get that to work.

    Currently, there is no autofill of any kind that I get for forms/fields requiring my name, phone number, email, etc.....the only autofill I get is with username/password fields where 1Password is rightfully trying to do those for me. Thank you again!

  • ag_anaag_ana

    Team Member

    @chasapple:

    Is there a way to make 1Password X do the Autofill, instead of the chromebook chrome browser? If so, I cannot figure out how to get that to work.

    Can you please try turning off the built-in password manager in your Chrome browser, and see if 1Password X is able to work properly then?

  • Thank you ag_ana. The built in password manager of Chrome browser is already turned off. It says that 1Password X is controlling this setting. Let me reboot, check for Cromebook OS updates, etc. and see what happens.

  • ag_anaag_ana

    Team Member

    Sounds good, thank you! Let us know how it goes :+1:

  • So what I am finding on my Chromebook is that 1Password X Autofill works for passwords---but it still does not work for form fields like my email address, home address, telephone number, etc. 1Password X Autofill settings only say 'offer to fill and save passwords' so does this mean 1Password X cannot autofill other form fields on a webpage? in Chrome preferences, under autofill-Addresses and more....., it says 1Password X is controlling this setting. Kaitlyn above wrote that 1Password X should be able to autofill name, address, etc. but I cannot get that to work. Thank you!

  • kaitlynkaitlyn

    Team Member

    @chasapple – I'm happy to help! 1Password can fill much more than just passwords. There are three different item categories that 1Password has the ability to fill – Logins, Credit Cards, and Identities. Logins are your typical username and password items. Credit Card items contain your credit card information, which you can fill on a payment form for example. Identity items contain your email address, address, name, phone number, etc.

    I think it'd help for you to see some real examples of Identity items being filled so you can familiarize yourself with the workflow. All in all, it'll be pretty similar to filling Login items. Here are a couple of examples:

    Scenario: I'd like to create an account on amazon.com.

    How to:
    1. Visit this link to visit the Amazon registration page.
    2. Place your cursor inside the email field, and select your Identity item in the inline menu. (If you don't already have an Identity item created, you'll want to do that first)
    3. Click OK in the prompt asking if you'd like to fill your Identity item.

    An alternative way to get the same result:
    1. Visit this link to visit the Amazon registration page.
    2. Click the 1Password icon in your browser toolbar.
    3. Hover over your Identity item in the left sidebar and click the Autofill button.

    Scenario: I'd like to order some AirPods from apple.com.

    How to:
    1. Visit this link and click the Add to Bag button.
    2. Click Check Out, then choose Continue as Guest for this demo.
    3. Click Continue to Shipping Address
    4. Click the 1Password icon in your browser toolbar.
    5. Hover over your Identity item in the left sidebar and click the Autofill button.

    In both of these scenarios, you should see your personal info fill, whether that be your name, email, address, phone number, or all of the above. If you have any questions at all, let me know!

  • Oh---I did not realized I need to do the 'hover--then click Autofill' part, for form fields. Thank you-I will give that a try.

  • kaitlynkaitlyn

    Team Member

    @chasapple – Perfect! Let me know how it goes. :)

  • I'm having exactly the same problem and it's driving me nuts! >_< I never get any autofill of my information on any page since switching to 1Password X. My satisfaction with 1Password has gone way down because I have two different keyboard shortcuts to remember depending on which browser I'm using.

    I've confirmed that in Chrome on macOS the autofill option is set to allow 1Password to control it, and the Chrome piece is disabled. I have an identity in 1Password, and when I go to the Amazon URL above and click on name, nothing happens. I did the keyboard shortcut to trigger 1Password, and nothing happens. There is no drop-down showing the identity.

  • ag_anaag_ana

    Team Member

    @jasondunn:

    My satisfaction with 1Password has gone way down because I have two different keyboard shortcuts to remember depending on which browser I'm using.

    May I ask why you are using two different 1Password extensions? You can certainly do that, but typically people choose one or the other, in all of their browsers, so they don't have to remember two different keyboard shortcuts.

  • @ag_ana I started using 1Password X in Chrome at the suggestion of 1Password support because the regular extension was being so flaky. I’d greatly prefer to not use it and just use the regular extension everywhere, but it seems Chrome is giving your team some trouble.

  • kaitlynkaitlyn

    Team Member

    @jasondunn – Can you give these particular steps a try?

    1. Visit this link to visit the Amazon registration page.
    2. Click the 1Password icon in your browser toolbar.
    3. Hover over your Identity item in the left sidebar and click the Autofill button.

    Let me know if you have any trouble.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file