Bug: In-Memory Data Model Corrupt After "Move to Vault" Used

invalidptrinvalidptr Junior Member
edited January 26 in Mac Beta
  • I have 7 vaults
  • One of those vaults is called Archive
  • Archive has been removed from "Show in all vaults"

Searched for logmein (15 items sorted by title)
Selected 4 items > right clicked > Move to Vault > Archive
When I arrow up and down over the remaining 11 items they all say they're in the Archive vault.
That is incorrect. There should be in 3 different vaults.

Canceled the search
Searched for logmein
Everything still indicates its in the Archive vault

Restarted the App
Searched for logmein
Everything still indicates its in the Archive vault

Even without a search. Everything indicates its in the Archive vault

Had to Quit 1Password Completely from the helper menu on the title bar

Searched for logmein
The results are now correct again. The are across 3 different vaults.


1Password Version: 7.4.2.BETA-2 (70402002)
Extension Version: Not Provided
OS Version: 10.15.2 (19C57)
Sync Type: 1Password

Comments

  • ag_anaag_ana

    Team Member

    Hi @invalidptr!

    I have followed your instructions but I could not reproduce this issue (all of the other items showed the correct vault for me). Are you able to replicate this again, even after quitting 1Password completely?

  • invalidptrinvalidptr Junior Member

    Thanks for the follow up @ag_ana. Please view this screen recording with audio as I demonstrate the bug after a fresh reboot. (Please remove the link after you capture it)

  • When selecting items, the containing vault is handily displayed underneath the title of the item. However, after moving an item from one vault to another, that display seems to be "locked" to the new destination vault, even when you select another, different item, regardless of the vault (or account even) in which that subsequently selected item resides.

    If it matters, I have two accounts (one business, one personal), both loaded into 1P at the same time, both with at least 6 vaults.


    1Password Version: 1Password 7 Version 7.4.2.BETA-2 (70402002)
    Extension Version: 1.18.4 (not relevant, though, AFAICT)
    OS Version: 10.14.6
    Sync Type: 1P

  • I should have added that it "fixes" itself when 1P is locked and then unlocked again.

  • rudyrudy

    Team Member

    @esquared, @invalidptr,

    This was reported previously by https://discussions.agilebits.com/discussion/110021/vault-display-error#latest and is fixed in 7.4.2.BETA-3 which will be out soon.

  • ag_anaag_ana

    Team Member

    :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file