1Password 7 requiring master password when it shouldn't

Just switched to 1Password 7 (7.4.2.BETA-3) on macOS Catalina.

I've noticed twice now 1Password has asked for my master password when I have the following settings enabled:

This is after already unlocking 1Password and not having been fast user switching... or doing anything other than closing the lid on my MacBook Air.

Any idea what this is? Seems like it really isn't obeying the settings as listed.


1Password Version: 7.4.2.BETA-3 (70402003)
Extension Version: Not Provided
OS Version: macOS 10.15.2
Sync Type: 1Password.com
Referrer: forum-search:1Password 7 requiring master password when it shouldn't

Comments

  • ag_anaag_ana

    Team Member

    Hi @joeyconnick!

    Is this happening in the 1Password desktop app, or in the browser extension (or both)?

  • Both. It's as if I've done something that triggers it to lock. I'll go to the browser extension first and it'll ask for my master password. If I leave it as is (i.e. don't fill in the master password) and then check the desktop app, it also asks me for my master password.

  • ag_anaag_ana

    Team Member

    @joeyconnick:

    Can you please let us know what version of the 1Password browser extension you are currently using?

  • sure: 4.7.5.90

  • Hi... still doing it, would appreciate any guidance or help you can provide 🙂

  • rudyrudy

    Team Member

    @joeyconnick,

    I think we'd need to look at a Diagnostics Report, as the only known issue that would cause errant lock is 1Password X, but you indicate that you're using 4.7.5.90, which isn't 1Password X.

  • ag_tommyag_tommy

    Team Member
    edited February 13

    @joeyconnick

    Please create a diagnostics report, use the following link to create that report for your device.

    https://support.1password.com/diagnostics

    The diagnostic report doesn't include any private information like your logins, Master Password, or Secret Key:
    About 1Password diagnostics reports https://support.1password.com/diagnostics-privacy/
    Please send that report to [email protected] Be sure to include the following information with your submission.

    Your user name here in the forum. joeyconnick
    A link to this topic. https://discussions.agilebits.com/discussion/110916/1password-7-requiring-master-password-when-it-shouldnt

    • Please do not post your diagnostic report to the forum. This is for your privacy and security.
      The report will be in zip format, please send the entire file to [email protected]
      Once we receive the report we will be in a better position to assist you.

    Once you submit the report, please post the ticket id, that will be returned to you via our autoresponder.

  • Hi - I am having the same problem. My master password is required every time I launch 1Password, and the ability to select allow touch ID in preferences is now grayed out. I've done all the obvious things - rebooted mac, completely quit 1P. My settings require the master password every 2 weeks. Today it's been four times so far.
    Thanks!

    1Password 7
    Version 7.4.3.BETA-0 (70403000)
    1Password Beta

    Mac
    10.15.3 (19D76)

  • ag_tommyag_tommy

    Team Member

    Hey @iamecho

    Can you try:
    1. Disabling System Preferences > Touch ID option for "Unlocking your Mac"
    2. reboot
    3. Enable System Preferences > Touch ID option for "Unlocking your Mac"

    Are the 1Password preferences now active and selectable?

    If not please try enrolling a new fingerprint.

  • @ag_tommy That worked. Thanks for the quick response!

  • ag_tommyag_tommy

    Team Member

    Glad to help!

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file