1Password mini keeps disappearing in the last beta (7.4.738) [Fixed in 7.4.741]

2»

Comments

  • I just noticed that on the mini window opening the last active app window is being brought to front which hides the mini window. Sometimes it is a random (or a previous app, not sure). The result differs based on when and where I move the mouse pointer after clicking the tray or FF ext icon.

    Not sure how or if it helps.

  • I may go back to 1P X for now - running these monitors at 125% reduces the real estate available to apps by a noticeable amount. With a browser I can change the zoom, but in FF you have to do it for each page (although there is an about:config setting to set defaults). Other apps, not so easy.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi guys,

    Just a small update, we believe we may have figured it out and have a fix; it is related to .NET but this one is a difficult one to reproduce.

    We'd like to send you a private build to confirm the fix. We're still testing to ensure there are no regressions but stay tuned.

  • I have tried out the provided test version and it seems to have fixed the issue.

    Strangely enough, after returning to the last beta, I am no longer experiencing the issue anyway.

  • MikeTMikeT Agile Samurai

    Team Member

    That is odd that you cannot reproduce it anymore with the last build, that does mean our fix may not be the cure either.

    We'll do a another review to see what it could be.

  • Thanks to 1Password support and Neil for chasing down the issue - it turns out it was related to external monitors and scaling.

  • MikeTMikeT Agile Samurai

    Team Member

    Yea, we're a bit concerned about the very slight degradation in the sharpness but we'll looking into it.

    We're likely to ship the fix in the next update.

  • MikeTMikeT Agile Samurai

    Team Member

    @njitman @finwe, please give 1Password 7.4.741 a try and let us know if it is still solid and looking fine.

  • Looks good - it has already updated to 7.4.740 so I manually forced the update to 7.4.741, Works on all monitors at various scaling levels.

  • MikeTMikeT Agile Samurai

    Team Member

    Great thanks!

  • Seems OK.

  • MikeTMikeT Agile Samurai

    Team Member

    Awesome, thanks again.

  • MikeTMikeT Agile Samurai

    Team Member

    @njitman,

    In regards to

    In Firefox, the regular 1P extension prompts for the master password but there is no text cursor,

    The February 2020 rollup update for .NET fixes this, I was able to confirm it on my PC: https://devblogs.microsoft.com/dotnet/net-framework-february-2020-security-and-quality-rollup/

    The KB article ID is: 4534132, it may take a while before it shows up via Windows Update. I had to download it manually to get it but it should be made available to everyone soon.

  • Update is installing now - I had to manually do a check for update. Will post back after restart with results.

  • All good now - cursor is back on different monitors. Thanks for chasing that down.

  • ag_anaag_ana

    Team Member

    Thank you for the update @njitman! I am glad to hear that things are working as expected again :)

  • I'm running 7.4.763, have no new updates available for Win10 but am still getting this issue. Don't believe it's been completely fixed. I've tried re-installing, looking for fresh updates, switching to beta mode, all of which failed.

    Really not sure what else to do as this bug requires me from having the full app open at all times whenever I want to access a password. It's exactly as others have described, I'll either perform the global hotkey combo or click the browser extension icon and 1Password Mini displays for a split second before disappearing again. If i somehow manage to click into the search bar within 1Password Mini in that moment it's displayed I've noticed it remains intractable, otherwise it w200ms later.

    I've noticed others commenting about monitors and scaling. I use a single ultra-wide display on my machine, not sure if this is somehow related. The scaling is at the default 100% and 1Password Mini works fine on my OSX Machines.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @GFargo,

    Please use this guide to generate the 1Password diagnostic report and email it to us at [email protected]. Also, in the email, include the link to this thread along with your forum username, so that we can connect the email to this thread.

    Let us know here when you've sent it, so we can confirm we got the email.

  • Hey @MikeT, just got around to submitting the diagnostics report via email to the support team.

    Let me know if there's anything else I can do to assist debugging!

  • ag_anaag_ana

    Team Member

    @GFargo:

    Thank you! I confirm that I have managed to locate your diagnostics report in our system :+1: We will take a look at it and get back to your email as soon as possible.

    Thank you for your patience!

    ref: EGC-86157-973

  • GFargoGFargo
    edited April 27

    Wanted to follow up on this post. Per support staff's request, I updated to the 7.4.767 beta build and the issue appears to be resolved.

    Anyone who comes across this issue in the immediate future before this fix has made it's way into a main releases can update to the beta build via this help page.

    Thanks again for the assistance @ag_ana & @MikeT!

  • MikeTMikeT Agile Samurai

    Team Member
    edited April 27

    1Password 7.4.767 update is already out on the stable channel. :smile:

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file