CR at cvs.com possible?

cvs.com uses a 2-page signin (email address collection, then separate password collection).

At the email address step, things work normally if I enter the email address by hand, then press Return.

But if I fill the email address via hotkey (CMD+), the focus moves to their "remember me" box instead and the Return key does nothing. If I want to avoid clicking the Continue button with the mouse, I have to type "tab tab spacebar," or "tab tab Return."

Normally the Return key works just fine after auto-filling, whether user and pw are collected in 1 step, or are 2 separate steps (like on Amazon).

Is there something at cvs.com that confuses 1password? Some flaw in their web page design, or something that 1password can eventually fix?

Thanks.


1Password Version: 7.4.1
Extension Version: Not Provided
OS Version: 10.14.6
Sync Type: iCloud

Comments

  • ag_michaelcag_michaelc

    Team Member

    Hey @Tonetony! If you open the item in the main 1Password app and look under "View Saved Form Details", is there information saved about the Remember me" checkbox? If so, edit the item, go to those same web form details, and just remove that line. Generally speaking I do not suggest just editing these details on a whim, but something like this'll be totally okay. :smile:

  • No, there's nothing listed in the WEB FORM DETAILS section except password and username.

  • ag_michaelcag_michaelc

    Team Member

    Hmm. Does it change anything if you save a new login manually for that page?

    https://support.1password.com/save-login-manually/

  • The instructions you linked are oriented toward pages where user name and pw are on the same page, which is not the case here.

    I can do an entirely manual process. I know the user name and pw in my existing login item are correct - all I have to do to login is click Continue with the mouse, or tab over to it then press Return or spacebar.

    I have just found something potentially interesting - if I put cursor in the email field and then manually backspace to erase the email address, then try autofill again, it works correctly. It leaves the cursor at the end of the email address, and then CR triggers the Continue button as it should.

    If I refresh the page - then it's back to the bad behavior, same as upon first entry to the page.

    All the same behaviors on this page exist in Firefox for Mac (using 1Password, not 1PasswordX which I have not been trying).

  • YaronYaron

    Team Member

    Hey @Tonetony ,
    Since this is a multi-page login, perhaps this link will serve you better: https://support.1password.com/create-multi-page-login/

    Make sure to keep the "remember me" checkbox unchecked when you save it as a new login, then test and let us know how it goes.
    I'm unable to access the website since I'm not in the USA so I'll have to try and guide you "blindly" :)

  • Thanks, Yaron. The instructions don't 100% match the Mac extension, in a minor way: technically you click "New Login," not "Save New Login," after clicking the gear icon.

    In any event, I saved the old password, then created a new Login item, gave it a new name. Now when I initiate autofill, I get the 2 suggestions (the old login item, and the new one). The new one doesn't make any difference - after 1Password autofills, it advances focus to the Remember Me box.

    There are CVS locations in Canada, so I'm surprised there is no access to either this website or another one they setup identically. Can you access the site via a VPN that will simulate a US origin for you?

    I suppose this is quite easy to visualize, but I attached a screencap, with email address obscured. This is right after autofill - focus has moved to the box, which is outlined in blue by Safari, and CR will have no effect.

  • YaronYaron

    Team Member

    Thanks for the followup and screenshot @Tonetony .
    I'm on the other side of the world right now, so I fired up the old VPN and managed to get in.

    I saved a new login with the email field, and when I autofilled it the focus remained on the email field, allowing me to hit the Enter key and proceed. I believe there might be something else in your Safari that is causing this focus on the "remember me" checkbox. Do you have any other extensions in Safari? Or perhaps other apps on your Mac that might affect Safari?

  • I am using Safari 12.1.2 still, with Mojave. I have some other extensions installed, but have tested with all of them disabled.

    The problem also occurs with Firefox 72.0.2 on Mac.

    I just tried it in Firefox 72.0.1 for Windows 7 inside a Parallels VM. Same behavior.

    In all 3 browsers, if I backspace over the email address and then autofill again, it works - the cursor remains at the end of the email field, where it belongs. That is indeed odd - autofill, place cursor at the end of the email address, backspace, then autofill again and cursor remains where it should be.

    I hope that after you created the test login, that you refreshed the page. Things work normally if you erase and try again on the page.

    This is the only site where I've seen this problem.

    I have gotten used to the workaround: hotkey, tab tab Return. Or hotkey, click Continue. The workaround is not going to kill me. But it is definitely a curiosity.

  • YaronYaron

    Team Member

    Thanks for the update @Tonetony .
    Curious indeed. I went ahead and tested things on multiple browsers and even on Windows - the "remember me" box is never focused after autofilling. Here's an example of Firefox on Windows: https://recordit.co/YE2daeBhRn

    My Mac setup is Mojave with Safari 13, I also tested this on the latest Chrome and Firefox. Didn't encounter this issue once. To clarify, here are my exact actions:
    1. Go to cvs.com.
    2. Get to the login page, manually fill in the email and save it as a new login.
    3. Refresh the page and autofill with CMD+\ or CTRL+\ - works as it should, I am able to hit Enter and proceed.
    4. Refresh the page, try to autofill by clicking the 1Password extension icon in the browser's toolbar and autofill form there - works as well.

    Not sure why (or how) do you manage to reproduce it every time on every browser (and in Windows too!). How strange :)
    Let me know if you find any other points of interests we can explore.

  • Thanks, Yaron. I was able to follow along the gif to see the steps you took. Yup, that's how it should work.

    If it weren't happening in Firefox too, I'd suggest it's a Safari 12 thing. But it must be something else.

    If I see this happening anywhere else or discover a pattern I'll check back in. But in the meantime, thanks for your efforts!

  • ag_tommyag_tommy

    Team Member
    edited February 5

    Hey @Tonetony

    I recently had to change Pharmacies, and your post got me intrigued as I am now a CVS customer. I tried out your noted fill behavior using 1Password 7.4.3 beta-0 on macOS Catalina, * all of my test browsers have no additional extensions, or add-ons installed. Above, you mentioned not having tried 1Password X, so I included my testing here. Even if this information doesn't help you, maybe this will help assist @yaron
    I was able to replicate the behavior of the backspace and fill a second time correctly.

    Safari 13.0.5/1Password 7 extension
    CMD+\ :-1: , and browser extension :-1:

    Microsoft Edge 79.0.309.71/1Password X 1.17.0
    In-line 1Password X button :-1: , Toolbar button :+1:

    Chrome 79.0.3945.130/1Password X beta 1.18.6
    In-line 1Password X button :-1: , Toolbar button :-1: , and CMD+\ :-1:

    Firefox 72.0.2/1Password X beta 1.18.6
    In-line 1Password X button :+1: , Toolbar button :+1: , and CMD+\ :+1:

    Vivaldi 2.10.1745.27/1Password X beta 1.18.6
    In-line 1Password X button :-1: , Toolbar button :+1: , and CMD+\ :-1:

    edit: typo

  • When you write "I was able to replicate the behavior of the backspace and fill a second time correctly" are you implying that you had first replicated the behavior of the normal use of the page NOT working correctly, but working as I described? Are your thumbs up and down intended to document which tests worked and which failed? It looks like Safari failed every test and is the worst of the browsers you tested, all of which have at least one successful test.

    I switched FF to 1PasswordX and it fails for me as 1Password does. It's actually a bit worse - for me, it doesn't even work after backspacing. But 1PasswordX is not of concern to me - I am sticking with Safari.

  • Correction: it looks like you also had no luck with Chrome 79.0.3945.130 / 1Password X beta 1.18.6.

  • YaronYaron

    Team Member
    edited February 6

    This is crazy, I can't replicate this even if I purposely try to mess with the "remember me" check box.

    I just tested again in Safari, Chrome and Firefox with both extensions, and in Windows on Chrome, Brave and Firefox - all of them worked as they should, autofilling the email field and not focusing on the "remember me" checkbox afterwards, allowing me to hit Enter after autofill.

    I then saved a new login with the remember me check box checked, and when autofilling it does check it and focus it. I went to the login in 1Password, edited the saved web form details, then removed that check box entry, saved the item and it resumed autofilling it properly and kept focus on the email page. Check it out: Link Removed

    I've tested on:

  • New clue:

    I have spent more time creating new logins. And have a theory about why you can't duplicate this problem.

    The MAIN problem I see is:

    Once the new Login item has a password in it, the autofill problem occurs.

    If I create a Login item and never add a password to it, or erase the password if I had one in there, autofill works properly.

    That's the entire story. The rest are more details.

    In your videos I can see that you never go beyond the step where you are creating a Login with an email address. So you have no password in that Login item yet. And of course, without an account you can't move to the next step - CVS first verifies that the email address maps to a real account.

    If that is the case, try manually adding some dummy password in your Login's password field (the value doesn't matter, since you aren't going to try to actually log in), and see if you duplicate the autofill problem on the email input page.

    I've noticed some other things that I can itemize here, though I'm not sure if any of this has significance.

    My original Login item's form details show 2 fields:
    password (type=Password, icon=key)
    username (type=Text, icon=face)
    (My guess is these are the field names because the login was imported from my prior password manager.)

    When I create new Logins, 1Password creates these fields:
    emailField (type=Text, icon=face)
    password (type=Password, icon=key)
    rememberMe (type=Checkbox, no icon)
    password (type=Password, no icon) (sometimes I get this second, empty password field)

    I don't know anything about having "extra" passwords, but I can observe this:
    1) Only one of the passwords can have the key icon
    2) The one with the key icon is the password shown at the "top" of the Login item

    Regardless - it seems that if ANY password field in the form details, with or without a key icon, is non-empty, then autofill on the email input page breaks. If I delete the passwords or erase their contents, autofill works.

    It appears that if 1Password has a password, it's determined to try to use it, and the unfortunate result is that focus moves to the next input field (the checkbox).

  • YaronYaron

    Team Member

    Great catch @Tonetony !
    Indeed, 1Password tries to auto-focus on the next available field, and that checkbox dupes it into thinking its something usable.

    I was able to reproduce it and forwarded it to our developers. Hopefully we can improve this behavior on our side of things. Thank you for your persistence on the matter! Much appreciated.

  • ag_tommyag_tommy

    Team Member
    edited February 6

    @Yaron That's great news, thanks. @Tonetony Thanks for noticing that detail.

  • My pleasure. I'm glad you could duplicate this, and it's a relief that it's not something obscure and unique in my personal settings, because those are the hardest problems to solve.

  • YaronYaron

    Team Member

    Indeed, glad we could pinpoint the problem! :+1:

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file