Cannot Connect to Desktop App

While I was using MS Edge browser the 1PW X beta extension installed an update. After the install it said it does not support my browser. I closed and reopened Edge and now I seem to have lost touchID for login. When I open 1PW preferences, it says "Unable to establish a connection with a 1Password Desktop App"


1Password Version: 7.4.2
Extension Version: 1.18.6
OS Version: OSX 10.15.3
Sync Type: Cloud

Comments

  • Also seeing this. I assume 7.4.2 being pushed overrode the betas and removed the desktop app integration.

  • Same here.

  • kaitlynkaitlyn

    Team Member

    Hey @edbro @plttn @BrianInMD!

    @plttn was spot on. 1Password for Mac 7.4.3.BETA-0 was released shortly after. Go ahead and try checking for updates if you haven't already, and let me know how you get on once you've got 7.4.3.BETA-0 installed.

  • Yes, it works again. However, I gotta say the roll-out of these updates could have been handled better.

  • kaitlynkaitlyn

    Team Member

    Thank you for the feedback, @edbro. I agree that the update process in regards to Desktop App Integration has some room for improvement. The good news is that once the feature gets pushed to the stable versions, we won't run into the same issue.

    I hope you have a great rest of your week. I'll be here if you have any other questions!

  • edbroedbro
    edited February 6

    It's back! Once again, 1PW X is not communicating with the desktop app. When I open the desktop app, it encourages me to install the 1PW extension, which is already installed.

    1PW-X 1.18.6
    1PW 7.4.3 BETA-0
    MS Edge: 79.0.309.71

  • kaitlynkaitlyn

    Team Member

    @edbro – Do you see the same error on the 1Password X settings page?

    I wonder if Edge is pending any updates. Could you click Microsoft Edge in the macOS menu bar with Edge option, then select About Microsoft Edge. Do you see any pending updates that are requiring you to restart Edge?

    If that's not the case, it'd be helpful to take a look at your 1Password X log to see if it tells us what's going on with the connection. We've got a guide that explains how to grab your 1Password X log here. If you'd rather not post it on a public forum, feel free to shoot us an email at [email protected]

  • There are no Edge updates pending.

    I tried to follow the guide on grabbing the log but it told me to enable "Enable extension developer features". There is no such flag in my install. I verified by pasting that in the search box.

  • ag_anaag_ana

    Team Member

    @edbro:

    It looks like the Enable extension developer features is only available in the Windows version of Edge, according to Microsoft's own documentation page.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file