7.4.3.BETA-0 with broken extension in Safari Tech Preview

Had 1Password update today (to 7.4.3.BETA-0 [70403000]) and broke the extension in STP Release 99 (Safari 13.2, WebKit 15610.1.1). Essentially can't enable the extension. Upgraded to 10.15.13 afterwards without any change.

I don't know the steps to reproduce, aside from saying:

  1. Open STP preferences
  2. Navigate to Extensions Tab
  3. Click to checkbox enable 1Password extension.
  4. Click mare fails to take.

Is this unique issue to me?


1Password Version: 7.4.3
Extension Version: 70403000
OS Version: OS X 10.15.13
Sync Type: Not Provided

Comments

  • Also, tried to uninstall and reinstall 1Password without improvement.

  • ag_tommyag_tommy

    Team Member
    edited February 5

    @stretchmonkey

    Can you try the following > Safari > Preferences > Websites tab > Content Blockers > * If there is an entry for 1password.com set it to "Off"
    Completely quit the Safari browser and restart it.
    Try re-enabling the STP extension.

    The above was taken from another user's post, where they were also unable to enable the extension. https://discussions.agilebits.com/discussion/comment/545784/#Comment_545784

  • edited February 5

    Oddly enough - there was no such entry under Content Blockers, it was all websites.

    Tried to re-enable after navigating to that tab, and the setting took this time.

    Weirdness - sorry for the trouble. 🤷🏽‍♂️ Thanks!

  • ag_tommyag_tommy

    Team Member

    @stretchmonkey

    Thanks for sharing, and the important thing is that you're up and going now. :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file