Can I get the browser plug-ins to work please with v 6.8.8?

I have been a loyal customer for years and years. Now the plug in stopped working and it is coercing me into buying v7, which is a SaaS. I hate this blackmail, and hate tracking my monthly payments for saas, Can you do the decent thing and get me back the functionality I've been used to?

Respectfully, Oleg


1Password Version: 6.8.8
Extension Version: Not Provided
OS Version: 10.15.3 and Catalina too
Sync Type: iCloud

Comments

  • BenBen AWS Team

    Team Member

    Hi @olegdesh

    Which web browser are you trying to use and having difficulty with? 1Password 6 will not work with Safari, but it should still work with Chrome or Firefox. You can read about the situation with Safari here:

    1Password 6 in Safari — 1Password Forum

    Please let me know.

    Ben

  • ok thank you Ben. Is there an option to purchase v7 once, not pay monthly?

  • BenBen AWS Team

    Team Member

    @olegdesh

    Licenses are no longer being advertised, and membership is the recommended way forward, but we do still make licenses available for customers who want them. We do also offer annual subscription terms if paying each month is the concern. A license can be purchased within the 1Password 7 for Mac application from the welcome screen. Select the "need a license? We have those too" option at the bottom.

    I hope that helps!

    Ben

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file