1Password 7.4.2 from the Mac App Store hangs when adding a 1Password membership account to the app

eak9000aeak9000a
edited February 18 in Mac

AgileBits Update: Please see this post for the latest information on this issue: https://discussions.agilebits.com/discussion/comment/547954/#Comment_547954


I have been using 1Password 7 for Mac, iOS for a long time. I had an older Mac running High Sierra 10.13.6 (17G11023) that was still using 1Password 6, so I uninstalled that and installed 1Password 7 (7.4.2) from the App Store. When I go to add my account from 1Password Families, it offers my existing one based on my email address. If I select that and type in the master password, it just hangs (spinning wheel) until I give up. If I try scanning the code or manually entering the secret key and password, it also hangs. I can however login with this secret key and password on 1password.com, so that's not the problem. I do have 2FA set up, and it never asks me for the 6 digit code. How can I make it work?


1Password Version: 7.4.2 (70402005) Mac App Store
Extension Version: Not Provided
OS Version: 10.13.6
Sync Type: 1Password.com
Referrer: forum-search:high sierra setup fails

Comments

  • ag_anaag_ana

    Team Member

    Hi @eak9000a!

    Do you get the same issue if you use the 1Password 7 app downloaded from our website instead?

  • Hi @ag_ana,

    I deinstalled the Mac App Store version and installed the website download instead, and it works now, so I'm happy, but I imagine someone should investigate why it makes a difference.

    Thank you.

  • ag_anaag_ana

    Team Member

    @eak9000a:

    Thank you for the update! I am happy that you managed to get things sorted out. We will keep an eye out for similar reports about the Mac App Store app :+1:

  • I experienced this same issue, except installing on macOS Mojave through the app store. I discovered if I disabled 2-factor authentication, setup would complete. But when I re-enable 2FA, I can't unlock 1password.

  • BenBen AWS Team

    Team Member
    edited February 18

    Hi all,

    I apologize for the difficulty here. I'm working with our development team to figure this out. If you are currently experiencing this issue, we'd like your help figuring it why it is happening. If you just need things to work then uninstalling 1Password and installing it from our website appears to work around the problem. If you're willing to help us track it down:

    The next time this happens, where 1Password hangs, please send us a process sample and diagnostic report (before working around the issue). First, note the time at which 1Password began to hang. Then generate a process sample:

    • Open the Activity Monitor application (you can use Spotlight to find it) and search for "1Password 7"
    • Select 1Password 7 in the list and choose "Sample Process" from the Gear icon in the toolbar.
    • When it is finished, save the sample.

    Then generate a diagnostic report:

    Sending Diagnostics Reports (Mac)

    Attach the diagnostics and sample to an email message addressed to [email protected].
    (the diagnostics file name should be something like "1PasswordDiagnostics-yourcomputer-date.zip" and the sample should be named something like "Sample of 1Password 7.txt" - please do not try to send us the "1PasswordTroubleshooting.zip" or "1PasswordTroubleshooting.app" files that you download from our website)

    With your email, in addition to the diagnostic report and sample attachments, please include:

    • A link to this thread: https://discussions.agilebits.com/discussion/111261/
    • Your forum username
    • The time at which 1Password froze

    That way I can "connect the dots" when I see your diagnostics in our inbox.

    You should receive an automated reply from our BitBot assistant with a Support ID number.  Please post that number here so I can track down the diagnostics and ensure that this issue is dealt with quickly. :)

    Hopefully with this information we should be able to track down the issue. Thanks very much!

    Ben

  • Hello,

    I just submitted case #BLU-22856-666 with the requested info.

    Thanks.

  • BenBen AWS Team

    Team Member

    Thanks @anwright. I see brenty has been working with you on the issue. We appreciate the report!

    Ben

  • I reckon it will be trivial to reproduce: install a fresh copy of Catalina, and install the App Store version of the app. Failed the 5 or 6 times I tried (uninstalling and reinstalling the App Store version) before I finally tried the version from the website.

  • BenBen AWS Team

    Team Member

    Indeed, we do believe we have this figured out, but it wouldn't hurt to send the information requested above for anyone still having the trouble. Thanks!

    Ben

  • I just sent a couple emails about this as well. Same issue. 2FA. If you need more information, just let me know. I’m going to try and download the version off the web to see if it works for me.

  • ag_tommyag_tommy

    Team Member

    @mostman

    You should receive an auto-reply with a ticket number. Please post that back here when you get it.

    Thanks

  • JEI-13713-344

  • ag_anaag_ana

    Team Member

    @mostman:

    I confirm that we have received your emails. Someone will get back to you over there as soon as possible.

    ref: JEI-13713-344

  • Thanks - for the record, the direct download solved my issue.

  • BenBen AWS Team

    Team Member

    Thanks @mostman. :)

    Ben

  • I wasn't in a hurry to get 1Password working on my laptop, so I did not install direct from the website. I just upgraded to 7.4.3 via the App Store, and can confirm that my issue is now resolved. Thanks!

  • ag_tommyag_tommy

    Team Member

    @anwright

    Thank you for letting us know that your issue was resolved by the update.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file