Firefox Plugin for 1Password (not 1Password X) not working

Hi,
my 1Password App got updated yesterday and since then the Firefox extension seems to be broken.
When I open 1password from a login form, it asks me to install the extension, even though I already have it installed:

And the extension icon in Firefox blinks all the time:
(Please image screengrab video here, which is not allowed to be uploaded)
this blinks about every 2 seconds:

Steps taken:

  • Restarted FireFox
  • Restarted 1Password
  • Removed extension, restarted FireFox, installed extension again

All to no effect.


1Password Version: 7.4.1 (70401001)
Extension Version: 4.7.5.90
OS Version: macOS 10.15.2
Sync Type: iCloud

Comments

  • ag_anaag_ana

    Team Member

    Hi @NicholasFe! Welcome to the forum!

    Before we try anything else, have you also tried rebooting your computer once? I see that you have tried restarting both Firefox and 1Password, but I wonder if a complete reboot will help here.

  • "Have you tried turning it off and on again?"

    Will do...

  • ag_anaag_ana

    Team Member

    Thank you @NicholasFe! Let us know how it goes :+1:

  • Experienced the same issue here. Restarting (and letting system updates install) cleared it up for me.

  • One reboot (and an update to macOS 10.15.3 I forgot about) later and it's working again.

    Thanks for the help. :+1:

  • ag_anaag_ana

    Team Member

    @grncdr, @NicholasFe:

    Thank you both for the update! I am glad to hear that installing system updates and a rebooting helped fix the issue :)

    If you have any other questions, please feel free to reach out anytime.

    Have a wonderful day :)

  • edited February 25

    Hi,
    this just happened again. Without any outstanding system updates. So now I think, your update process is broken.

    1Password 7
    Version 7.4.2 (70402005)
    Mac App Store

    Here is a excerpt from the debug log of the Firefox extension:

    Unchecked lastError value: Error: Could not establish connection. Receiving end does not exist. background.js:1
    [Exception... "Component not initialized" nsresult: "0xc1f30001 (NS_ERROR_NOT_INITIALIZED)" location: "JS frame :: resource://gre/modules/ExtensionChild.jsm :: api/register/publicAPI.onDisconnect< :: line 266" data: no]
    api/register/publicAPI.onDisconnect<@resource://gre/modules/ExtensionChild.jsm:266:42
    [email protected]://gre/modules/ExtensionChild.jsm:323:17
    [email protected]://gre/modules/ExtensionChild.jsm:404:15
    [email protected]://gre/modules/ExtensionChild.jsm:232:44
    _handleMessage/</<@resource://gre/modules/MessageChannel.jsm:962:27
    _handleMessage/<@resource://gre/modules/MessageChannel.jsm:961:9
    [email protected]://gre/modules/MessageChannel.jsm:959:16
    receiveMessage/<@resource://gre/modules/MessageChannel.jsm:225:14
    [email protected]://gre/modules/MessageChannel.jsm:218:10
    MessageChannel.jsm:964

  • Addendum: This time, restarting the 1Password App helped. But should not that have been done by the update process?

  • ag_tommyag_tommy

    Team Member

    It sounds as if the mini process was running in the menubar, prohibiting the update. This seems like an issue with 7.4.2. The team is working to make this a better experience.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file