"Lock after system is idle for..." setting resets 1PasswordX (Firefox on Ubuntu linux) updates.

The setting to lock 1Password after the system is idle resets to the default 10 minutes every time 1PasswordX updates (at least, I think that's the reason).
Is there a way to make my setting choice permanent?
Otherwise, where are the settings stored? Perhaps I can modify it on system startup or similar to set it back to my preferred choice.


1Password Version: Not Provided
Extension Version: 1.18.0
OS Version: Ubuntu Linux 19.10
Sync Type: Not Provided
Referrer: forum-search:Lock after system is idle for..." setting resets 1PasswordX (Firefox on Ubuntu linux) updates

Comments

  • ag_anaag_ana

    Team Member

    Hi @avanwyk! Welcome to the forum!

    When 1Password X updates, you will have to authenticate once again. I am afraid there is no way around this since 1Password X closes during an update.

  • That's a pity. Thanks for the reply.

  • kaitlynkaitlyn

    Team Member

    @avanwyk – We may have misunderstood the issue here, actually. Your auto lock idle time shouldn't reset upon updating 1Password X. That data is stored in your browser's local storage, so one way it can get reset is by clearing your cache. Do you happen to have Firefox set up to clear your cache/cookies every so often?

  • Hi,

    Ah ok, thanks for the feedback, so the setting is stored in local storage.

    Yes, I do have Firefox set up to clear the cache/cookies when I close the browser, but there are some cookies I allow. Perhaps it only appeared to happen during an update, because I infrequently do a full Firefox restart.

    I could try and whitelist the cookie, do you know the actual domain or sub-domain used?

    Thanks this has helped.

  • kaitlynkaitlyn

    Team Member

    @avanwyk – I'm not sure if you can whitelist when it's coming from an extension. You're welcome to try 1password.com to test it out. I'm wondering what your Firefox security settings look like. I've got the "Delete cookies and site data when Firefox is closed" setting enabled (with no exceptions), but my 1Password X settings stick around when I fully quit Firefox.

    How do yours differ?

  • I have the same settings, but I do have some Permissions set up, although, all of them are to allow cookies.

    I also have custom history settings, and I notice that one of the settings clears offline website data, could it be related to that?

  • kaitlynkaitlyn

    Team Member

    @avanwyk – That's what you'd think, but I've got that checked in my Firefox settings as well:

    Do you happen to have any other extensions in Firefox that could be clearing local storage?

  • No, I have no extensions that manage history or cookies for me.

  • kaitlynkaitlyn

    Team Member

    @avanwyk – If you have some spare time, I wonder if you'd be able to create a new profile in Firefox and try to mimic the privacy settings that I've posted as screenshots in this thread. What I've been doing is changing the auto lock time to 22 and if it goes back to 10 (the default) after quitting, then I know I've reproduced the error. That said, I haven't been able to get my auto lock time to reset to 10.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file