1Password Mini and browser extension not working in Safari

After a recent update to 1Password through the AppStore, 1Password mini and the browser extension has stopped working.

  • The 1Password Mini in the menu bar works when Safari is not in the foreground, but it nothing happens when clicking on it when Safari is in the foreground.
  • The Safari Toolbar doesn't work.
  • The 1Password right-click menu item doesn't work in Safari.

I have checked that 1Password is enabled in the Extensions preference pane in Safari. I have checked that 1Password Extension Helper is running through the preferences in 1Password. I have quit Safari and also restarted. Nothing has worked.

It is working fine in Chrome (Chrome version is

1Password Version: 7.4.2
Extension Version: 7.4.2
OS Version: 10.15.3
Sync Type: 1Password subscription


  • PS. That's Chrome version of the 1Password extension is

  • Anybody able to assist with this?

  • It would be appreciated if somebody from AgileBits could respond please.

  • ag_tommyag_tommy

    Team Member
    edited February 25

    Try updating to the latest version from the Mac App Store. 7.4.4

    It sounds as if the mini process is running in the menubar, prohibiting the update, or possibly the Safari extension which is now part of the 1Password app is preventing the update.

    1. Quit Safari, completely. (Right click the Dock icon and then chose Quit)
    2. Open and then quit 1Password completely using ⌘⌥⌃Q (Command Option Control Q)
      • You do not have to unlock to quit, it can be done from the lock window.
    3. Update from the Mac App Store.
    4. Launch 1Password.
  • viskwalviskwal Junior Member

    I'm having the same issue with the non-appstore version 7.4.3
    Tried everything, including the list of steps that Ben posts to every problem, but still no go...

    Is there a way to downgrade to an earlier working version ?

  • ag_tommyag_tommy

    Team Member


    We don't generally recommend downgrading as an option, because of improvements we have made in the newer versions. Even then, I'm not sure a downgrade would rectify the problem based upon the wide range of people and various setups this has occurred with. I would tend to think maybe an OS problem, but that's just an assumption on my part, I have no facts for that.

    I think the best option would be to temporarily switch to a different browser if you can manage it, for a brief time. Hopefully, that bit of time will help us to resolve the issue. If a downgrade is absolutely necessary, then yes, it could be done. Let me know, and I can give you some details.

  • viskwalviskwal Junior Member

    thnx Tommy for the reply.
    I'll bite my teeth for a bit, and use Firefox until this is resolved.

  • ag_tommyag_tommy

    Team Member

    You're welcome for the words. :) I know you will be more thankful when this issue is behind us. I can assure you, we both want to see it in the rearview mirror.

  • I installed a clean macOS Catalina system today, it's fully updated. I then installed 1Password 7.4.4 via the App Store and I too cannot enable the Safari extension. It shows up under Safari Preferences/Extensions, but is unchecked and cannot be checked.

  • I'm experiencing the same issue. Using MacOS 10.14.6 (Mojave,) Safari 13.0.5 and 1Password 7.4.4. If I reboot it will work temporarily but then quits working again.

    At this point, I have to say WTF, agile bits???!!! You tell people they have to upgrade to version 7 to get 'great new features' (there are none) and Safari integration, and force people into a never-ending subscription model only to let them discover after they've upgraded that the one useful feature of 1Password 7 doesn't actually work.

  • ag_anaag_ana

    Team Member


    Thank you for letting us know your experience as well. It does sound like you encountered the same issue that our developers are currently working on fixing, so thank you for your patience while we get to the bottom of this :+1:

  • ag_anaag_ana

    Team Member


    We apologize for the inconvenience. Our developers are hard at work to get this issue resolved.

  • Same here. 1 Password extension is visible and activated, but nothing happens when I click the icon in Safari. Also the menu bar item is giving me a strange message, eben though the extension is activated - see screenshot. 1Password app however is working as it should. I don't know when this started. I'm on Safari 13.0.5 and macOS 10.15.3 and 1Password 7.4.2.

  • BenBen AWS Team

    Team Member

    Hi @iCoco

    I'm sorry for the trouble. Have you restarted the Mac since this problem began?


  • @Ben: I closed and restarted Safari, but not the Mac before (or at least I'm unsure because I don't exactly know when the issue first occurred). However, I did restart the Mac right now, and 1Password extension is working again. :)

  • BenBen AWS Team

    Team Member

    Glad to hear that did the trick, @iCoco. :) Thanks for the update.


Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file