How can I stop 1Password Autofill prompt from popping up?

ashleykashleyk
edited February 19 in Android

I have Autofill disabled inside the settings of apps and browsers, yet it still insists on popping up repeatedly when using the banking app and others, often obscuring areas of the screen that need to be accessed to proceed.

I found myself in a ridiculous situation at the end of January when I was struggling to pay my tax bill, because 1Password kept thrusting that stupid popup to the front with every button press. The bank uses the mobile app to provide a security code for transactions and the 1Password popup was obscuring that, so I couldn't even pay by the desktop browser. I remember this was bad when the Android app first appeared and it seems to be just as bad now.


1Password Version: 7.5 beta2
Extension Version: Not Provided
OS Version: Android 9
Sync Type: 1Password

Comments

  • periperi

    Team Member

    Hi @ashleyk. Sorry for the trouble you had here. When Autofill or Accessibility are enabled in 1Password's settings, you'll see the Autofill with 1Password prompt in login fields.

    Currently, you should be able to dismiss the prompt by tapping elsewhere on the screen, or by typing. It sounds like this may not have been your experience, though I'm not able to reproduce that.

    We have an open issue to exclude apps from Autofill, which would allow you to prevent the pop up in certain apps. I'll add your feedback to this issue. ref: dev/android/onepassword-android#815

    Let me know if you have further questions.

  • Autofill is disabled, but the pop up still appears. I had enabled accessibility but in 1Password it suggests this only affects browsers and I am seeing it across apps as well. No amount of tapping elsewhere on the screen will make that pop up go away.

  • periperi

    Team Member

    Sorry about that. I see what you mean about the description for Accessibility, and I've brought this up with our development team. For now, I'd recommend enabling Autofill, as that will allow you to dismiss the prompt by tapping away or typing. You could also disable Accessibility to prevent the pop up from appearing.

    ref: dev/android/onepassword-android#928

    ref: dev/android/onepassword-android#974

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file