Autofill not working properly in Chrome on macOS

I never get any autofill of my information on any page since switching to 1PasswordX. My satisfaction with 1Password has gone way down lately because I have two different keyboard shortcuts to remember depending on which browser I'm using (I use the regular extension in Firefox and Safari).

I've confirmed that in Chrome on macOS the autofill option is set to allow 1Password to control it, and the Chrome piece is disabled. I have an identity in 1Password, and when I go to the Amazon URL suggested and click on name, nothing happens. I did the keyboard shortcut to trigger 1Password, and nothing happens. There is no drop-down showing the identity. When I click on the icon in the browser toolbar, no identity comes up.


1Password Version: 1PasswordX
Extension Version: 1.18.0
OS Version: macOS 10.15.3
Sync Type: Cloud

Comments

  • kaitlynkaitlyn

    Team Member

    Hi there @jasondunn! πŸ‘‹

    I'm glad you reached out. I'm curious to learn more about what you're experiencing. I'm wondering what you do see when you click the 1Password icon in your browser toolbar. Does it open to Suggestions or do you see a different view? There are a few different options that can easily be tweaked in settings, so I want to make sure we're looking at the same thing before giving you any instructions. Let me know what view you see, and we'll go from there.

  • Hi Kaitlyn, thanks for responding. On the Amazon registration page link you shared in the other thread, I just get "Search 1Password". Even when clicking in the fields, I don't get anything related to the identity I have stored in 1Password. On other forms where I'd expect to have autocomplete of name, address, etc. I get nothing at all.

  • kaitlynkaitlyn

    Team Member

    @jasondunn – Search 1Password will almost always be visible in the 1Password X pop-up. I'm interested in what's directly underneath Search 1Password.

    What do you see where the arrow is pointing in the above screenshot when you open the pop-up on the Amazon registration page, for example?

    As far as clicking inside fields goes (the inline menu), Identities should show up inside email fields.

  • In that list I see various Amazon accounts, all of my credit cards, then at the very bottom I see my ID card. When I click on it, then click Autofill, it does put my name in but not my email. Is this the way it's supposed to work? If so, it seems very inefficient and I'd prefer to use Chrome's autofill function.

  • kaitlynkaitlyn

    Team Member

    @jasondunn – That's the way! However, your email should have filled. Can you take a look at your Identity item and make sure an email address is stored inside it?

    You can also fill an Identity using the inline menu inside the email field. Logins will appear above Identities, but if you're creating an account for the first time, then you likely wouldn't have any Logins yet. Amazon may not be the best example since it sounds like you already have multiple Amazon accounts stored inside 1Password.

  • I do have an email address in my profile, but even if that was filled in, having to scroll to the bottom of a large list of choices to get to my ID is inefficient and slow. I appreciate the help but it seems like this feature just doesn't work in a way that I need it to, so I've turned it off and will resume using Chrome's autocomplete. I hope 1Password re-thinks how this works because I can't imagine anyone liking it this way. πŸ€”

  • Ok, so it looks like if I go into Chrome's settings and disable 1PasswordX for form autofill, it disables the entire extension. 😒Kaitlyn, is there a way for me to use Chrome's autofill on forms, but keep 1PasswordX?

    I was a happy 1Password customer for years but it seems ever since 1Password starting having issues with Chrome things have gotten worse, fast. Far more hassles than before. 😞

  • kaitlynkaitlyn

    Team Member

    @jasondunn – The email address wouldn't necessarily be in your 1Password profile, but you'd have to save your email inside an Identity item as well. Keep in mind that you can also begin typing into a field, and 1Password X will refine the results in the inline menu to match what you're typing. The same goes for the 1Password X pop-up as well – search results will appear as soon as you begin typing.

    Here's an example of a test Identity:

    Of course, you can add much more information to it, like your address and phone number, but my goal was to show you the basics and where your email would be if there is one saved inside the Identity item.

    To re-enable Chrome's autofill, you'll want to disable the Make 1Password the default password manager setting on the 1Password X settings page.

    I'd like to clarify what you mean when you mention things getting worse since 1Password started having issues with Chrome. Is the issue you're referring to that 1Password X and Chrome's autofill menu overlap, or are there other issues you're experiencing in 1Password X in Chrome? I'm interested in what changed to make things become worse. I'd like to address your feedback and see what we can come up with to improve the experience.

  • jasondunnjasondunn ✭
    edited March 30

    @kaitlyn I wanted to get a deeper understanding of how this was missing the mark, so I've paid particular attention to how 1Password no longer works properly on forms.

    Form-fill autocomplete should work like this: when I start typing my name in a form field called "First Name" it should offer to autocomplete the entire form with any applicable matching form fields: last name, email, address, etc. This is how form autocomplete has worked for 10+ years.

    It seems the only way to get 1PasswordX to complete a form is if I click on the first field ("First Name"), then do the keyboard shortcut for 1PasswordX, then scroll down past all my credit cards and select my ID card. Then it will populate the form. This is dramatically worse than how browser autocomplete works, so I am seeking an explanation from 1Password why it works this way. Surely this can be functioning as intended?

  • kaitlynkaitlyn

    Team Member

    @jasondunn – I sincerely appreciate the thought you've put into this. I think the expectations you're having are slightly off. 1Password X won't autocomplete. As in, when you start typing something, it won't automatically finish what you're typing. At least, that's what I think of when I think of autocomplete. With 1Password, you'll always need to tell it to fill something for you. There's lots of reasons why we went that route, but you can learn a few from this blog post.

    All that said, 1Password X should work like this:

    • Place focus inside an email field.
    • Inline menu appears automatically.
    • Start typing your name or the title of your Identity item.
    • The inline menu results scale down and the remaining options contain what you've typed.
    • Press the down arrow key to select the Identity, press enter to fill it.
    • The data you have stored in the Identity will fill in multiple fields (name, address, email, phone number, etc.)

    You can fill using the 1Password X pop-up, like you mentioned, but I think the inline menu is more efficient since it's right there on the page. If you're experiencing different behavior on a specific website, feel free to let us know so we can investigate!

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file