TouchID autofill in Firefox not working any more

Hi all,
Last update of 1password seems to have excluded the touchID autofill function in Firefox browser.
Before, I could click on the 1P icon (in the Mac task bar), use TouchID and click "automatic fill"
Now, TouchID open a small windows saying "Install the 1p extension to fill"...

This function of 'touchID autofill" is really useful. Can I get it back?

Thank you for you help!


1Password Version: last
Extension Version: last
OS Version: last
Sync Type: no idea...

Comments

  • ag_tommyag_tommy

    Team Member

    @Doukiwi

    Sounds to me, as if you were using 1Password X, with Desktop APP Integration. If that's the case, you will need the beta of the 1Password X, and the Mac app beta. Those are currently the only ones that support the TouchID feature.

    You can also try the following, if Firefox was in the process of updating.

    1. Open and then quit 1Password completely using ⌘⌥⌃Q (Command Option Control Q)
    2. Quit Firefox
    3. Open and unlock 1Password
    4. Open Firefox
  • Hi @ag_tommy,
    wow... so I had beta apps... not a clue. But that OK. So I will try that and tell you if it works.
    Thanks for you answer !

  • ag_tommyag_tommy

    Team Member
    edited February 19

    @Doukiwi

    I am sorry, I incorrectly read your post, you can indeed have TouchID with the standard Mac app. I misconstrued the details with a 1Password X extension issue. Can you tell me more about the issue you are seeing? Maybe it will give me a clearer picture of what's happening. I would try the quit and restart procedure I mentioned above.

    edit: I was thinking you were part of this issue. https://discussions.agilebits.com/discussion/110838/beta-1-18-6-fails-to-auto-fill-logins-on-firefox#latest

    If you were using 1Password X it may be relevant, so please let me know what extension you were/are using.

    Thanks

  • DoukiwiDoukiwi
    edited February 19

    Hey,
    Yep, I was wondering how it could have been in a beta app since I did not knowingly installed a beta.
    for info, I tried the beta and it's still not working.

    this small windows used to allow me to "automatic fill" the credentials inside the Firefox website. Now it refers to Firefox extension.

    Not sure if I'm clear...

  • ag_tommyag_tommy

    Team Member

    @Doukiwi

    I am following your thoughts. :)

    Do you happen to have more than one copy of the extension enabled in Firefox at any given time? Doing so can cause unexpected results.

  • @ag_tommy ,
    Not that I know, I unistalled the previous one before installing the new.
    It seems that the function was gone after an update of 1P (before I installed the beta version).

  • DoukiwiDoukiwi
    edited February 27

    (EDIT)

    I found the solution in another thread of this forum.
    https://discussions.agilebits.com/discussion/110511/touchid-support-for-firefox-on-mac

    To keep touchID working on Firefox, we need the companion app, not the 1password X extension. (not sure about the diffrerence though).

    thx @ag_tommy for trying to help ;)

  • ag_tommyag_tommy

    Team Member

    :+1::) I am glad you found the solution.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file