1Password application refresh rate seems to be locked to 60Hz

Got myself a new monitor lately which supports 144Hz and 165Hz refresh rates. When I open 1Password app I can clearly see it flickering, which is very annoying. Searched everywhere for a solution, but I seem to be first to complain about the issue.


1Password Version: 7.4.748
Extension Version: 1.18.6
OS Version: Windows 10
Sync Type: Not Provided

Comments

  • MikeTMikeT Agile Samurai

    Team Member
    edited February 29

    Hi @Pe4enie,

    Thanks for writing in.

    Do you have vsync enabled on your monitors globally by default?

    This may be due to the fact we use Windows Presentation Foundation (WPF) to render our UI, it is basically "limited" to 60fps. This isn't something we can change nor fix as far as we know and it appears to affect any apps that uses WPF as well. WPF uses DirectX 9 internally and your graphic drivers may drop the refresh rate down to 60hz because of vsync if it is on. If you turn it off by default, it may stick at your monitor's native refresh rate.

    Also, there's also a known Windows 10 issue related to refresh rates if you use multiple monitors with variable refresh rates that is supposedly better in the upcoming Windows 10 update (2004), you can see the news report here.

  • MikeTMikeT Agile Samurai

    Team Member

    You can also keep an eye on WPF's team work on enabling better support for higher refresh rate here: https://github.com/dotnet/wpf/issues/2294

  • MikeTMikeT Agile Samurai

    Team Member
    edited February 29

    I noticed someone else mentioned that you could set a profile for an app to change their refresh rate, that might fix the flicker issue for you. See if you can add 1Password to your drivers' list of apps and change the refresh rate setting for it.

  • Hi @MikeT ,

    thanks for a quick reply.

    Well, that's a shame, really. I tried playing around with some settings in RivaTuner, MSI Afterburner and NVIDIA control panel to no effect. As far as I am aware there is no way to enforce an app to have higher refresh rate than its internal loop allows. Funny enough, having 1Password out of focus (for example by just pressing "Start" button) works perfectly fine (as in I can still move mouse over elements and see them highlighted properly without any flickering).

    Will keep an eye at this issue, but it's unlikely they'll solve it soon.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @Pe4enie,

    As far as I am aware there is no way to enforce an app to have higher refresh rate than its internal loop allows.

    That is correct. The setting I mentioned is to help the driver know what's going on with the app and gracefully lower its refresh rate, rather than flickering and any stuttering that may occur, it doesn't leave you at the native refresh rate.

    Funny enough, having 1Password out of focus

    Also correct, as long as there's no window visible, the GPU won't redraw it. You can minimize 1Password, close the main window or keep it out of view, and it should keep your monitor at its native refresh rate.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file