AWS - AccountId populated with OTP Code

124

Comments

  • Unfortunately adding the account field and setting its type to Email is still not working for me; 1Password is continuing to fill the account ID input with the MFA code. Is there else I can try? Thanks!

    OS: macOS 10.15.4
    Browser: Chrome 80.0.3987.149
    1Password: 7.5.BETA-0 (70500000)
    1Password extension: 4.7.5.90

  • ag_anaag_ana

    Team Member

    @abercrave:

    Does it work if you set the account field back to a regular text field instead? I know setting it to "email" is necessary on Windows, but other users have reported this working without setting it as an email field on a Mac.

  • We are also experiencing the same issue in our company using 1Password 7.4.3 on mac and Safari

  • njitmannjitman
    edited March 27

    Yeah, @Yaron's method for fixing FireFox on Windows 10 worked, when I try to login via FireFox on Mac it did not (it copied the OTP code again). I had to add a second 'account' field in a different section and set it as 'text' type for it to work on Mac. So, 'account' has to be 'email' type on Windows 10 and 'text' type on Mac and if you use both, then two entries, one 'email' and one 'text' type, both named 'account' and in different sections. I usually don't use Safari on Mac, but I launched it and gave it a try and it worked fine. Mac Catalina 10.15.4, Safari 13.1, 1Password 7.5.BETA-0. Just standard 1P extension in FireFox (no 1PX). I can post a screenshot of one of my entries if you want to see how it looks.

  • Thanks @Yaron ! Works!

    Mac OS 10.15.3
    Safari 13.0.5
    1Password 7.4.4

  • Thanks @ag_ana, setting it back to a text field worked. I could have sworn I'd started out with a text field first but who knows! ¯_(ツ)_/¯

  • With regards to this post from Yaron: https://discussions.agilebits.com/discussion/comment/552844/#Comment_552844

    How do you change the ordering of the form fields in 1Password? There seems to be no drag slider or anything to actually move them around. If it requires deleting all the form fields and re-adding them, that really isn't feasible -- the instant you delete a "Password" form field entry, the password for the entire 1Password entry itself is lost. And please don't say "you'll need to make a new 1Password entry first, then set up the fields, then move your credentials over with copy-paste" because doing that loses the OTP key.

    I'm focused purely on Mac + Chrome. See my post here for versions and plugin/extension details: https://discussions.agilebits.com/discussion/comment/551015/#Comment_551015

  • ag_anaag_ana

    Team Member

    @cfoehrdes:

    Please try the suggestions discussed in this thread and let us know if they work for you too :+1:

  • ag_anaag_ana

    Team Member

    @njitman:

    Thank you for testing all of these combinations! We should have enough screenshots in the post for now, but I'll make sure to take your offer should we need some more :)

  • ag_anaag_ana

    Team Member

    @ihor, @abercrave:

    Thank you for the confirmation! I am glad to hear things are working again for you too :)

  • ag_anaag_ana

    Team Member

    @jchadwick:

    Fields cannot be reordered. However, it shouldn't be necessary to do so if all you want to do is add the account field as per Yaron's instructions.

    And please don't say "you'll need to make a new 1Password entry first, then set up the fields, then move your credentials over with copy-paste" because doing that loses the OTP key.

    Copy-pasting fields does not lose the OTP key, so that is definitely an option if you want to go this route. I have just tested this in my 1Password app and the OTP field was moved without issues, like every other field.

  • You can always copy/paste the OTP key from the field anyway if you need to delete something and add it back. Just click into the key field and it will show the key.

  • ag_anaag_ana

    Team Member

    Indeed :+1:

  • I still haven't gotten Chrome 1pwdx 1.18.1 pushed out to me. I see it in the release notes but I still have 1.18.0. Do I have to force it somehow?

  • ag_anaag_ana

    Team Member

    @conspiracyx:

    I also still see 1.18.0 if I visit the Chrome extensions page here, so perhaps it's taking Google a bit longer to review the update this time.

  • OK, I am going to assume they are having COVID-related slowdowns (there were news of Chrome update issues) and will just hang tight ¯_(ツ)_/¯

  • YaronYaron

    Team Member

    You can install 1Password X beta for now, which did receive the update already: https://chrome.google.com/webstore/detail/1password-x-beta-–-passwo/khgocmkkpikpnmmkgmdnfckapcdkgfaf

    Not sure why the stable update is taking so long to review by the Chrome team but we'll just have to sit tight :)

  • The same thing is happening in Safari, not sure if that got mentioned

  • YaronYaron

    Team Member

    @bentheye The workaround is identical to all browsers, as written many times in this discussion:

    • On Mac, add a new custom "account" field to the login.
    • On Windows, add a new custom "account" field to the login and set the field as type "email".
  • Thanks @ana_ng et al.

    I've confirmed that the workaround described in https://discussions.agilebits.com/discussion/comment/552844/#Comment_552844 does work using 1Password 7.4.3 on OS X / Chrome extension 4.7.5.90. Due to the way the UI is designed, it's very easy to overlook a few key points, and I thought I'd mention them to benefit others:

    • The OTP goes into the section called SECTION (which is the only place you can put it anyway), not Saved Form Details
    • The "account" entry goes into the section called SECTION, label "account", value {AWS account ID number, or AWS account ID alias}, not Saved Form Details
    • The only Saved Form Details fields needed are username and password
  • sheldonhsheldonh
    edited March 30

    I normally label my section entries "2FA" and put it in there, and additional details under "Additional Details" instead of leaving it as empty section. I'm on Windows. It's not working for me right now. Is the name of a section being filled in significant somehow or just metadata?

    I've been using 1Password X for Chrome, not the desktop version

  • Update: I remembered that 1Password X had a beta version. I switched to the beta version which was updated in march and this version works correctly. The other version was Feb 18 2020 update, while the 1Password X was March 17 2020. Thanks! 🎉

  • ag_anaag_ana

    Team Member

    @jchadwick:

    Thank you! Both for the update, and for the additional suggestions :)

  • ag_anaag_ana

    Team Member

    @sheldonh:

    You are welcome :) I am glad to hear this :+1:

  • Can't say exactly if the login page was changed by Amazon, but when doing auto login with 1Password 7 Version 7.4.3 (70403002) 1Password Store using Safari or Firefox the 1 time password is being filled in the account id for some reason (overriding the browser auto fill)


    1Password Version: 7.4.3
    Extension Version: 7.4.3
    OS Version: osx 10.15.4
    Sync Type: dropbox

  • ag_anaag_ana

    Team Member

    @omerh:

    I have merged your message with the ongoing discussion about the same topic. Please read the previous posts for all the information :+1:

  • I've had this same behavior and I can confirm that the workaround works for me too where you add a text-based field named "account" under Section. Running the latest 1P version on Mac.

  • YaronYaron

    Team Member

    Thanks for confirming @hezor .

  • I'm still not getting the 1.18.1 version in Chrome either - very frustrating, because signing into AWS is a bit of a PITA now. Is there any way to force the update? Alternatively, I notice there are beta builds for 1Password X - how do you install those?

  • YaronYaron

    Team Member

    Hey @haggaret ,
    We're not sure why our update got stuck in Chrome's review process but we're hoping the next version push will release both.

    In the meantime, you can definitely install the beta which already contains the fix: https://chrome.google.com/webstore/detail/1password-x-beta-–-passwo/khgocmkkpikpnmmkgmdnfckapcdkgfaf
    Make sure to remove or disable the current 1Password X in your browser before installing this one.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file