AWS - AccountId populated with OTP Code

1235»

Comments

  • sifutommysifutommy Member

    This works for me in 1PWX but the not in the "normal" browser extensions on the Mac. Is this expected?

  • ag_anaag_ana

    Team Member

    @sifutommy:

    Yes, for the moment this is expected as we continue working on this on the companion extension as well.

  • This is driving me crazy.

    I know 1Password is doing everything they can to help us all to resolve this issue. Excellent job guys! This is definitely NOT a P1 High Priority issue, as users can just copy/paste the account id or account alias from 1Password itself.

    I completely disagree. I don't store the account ID as an individual string for each AWS account I use. I've had to copy the URL that's saved and then extract the account ID from that every time, and then manually copy the OTP.

    This probably adds 30 seconds every time I need to login. And, since I'm switching between AWS accounts at least ~10-15 times a day, this amounts to a ~7m30s time suck.

    Frustrating beyond belief this can remain as a bug for a month.

  • YaronYaron

    Team Member

    We have solutions for every single client @breslow .
    If you're using 1Password X - get 1Password X beta and it will work as it should.
    If you're using the companion extension with 1Password 7 for Mac/Windows, simply edit your AWS logins and a new "account" field under the TOTP field as instructed previously in this discussion and you'll save all the time in the world :chuffed:

    Let us know if the fixes suggested here don't work for you and elaborate on what you tried.

  • breslowbreslow
    edited April 20

    I understand that fix works, but it feels more like a workaround than a complete solution. This is going to require me to modify all of my AWS logins and will add an extra step in the future for saving AWS logins. Just feels a hit to the UX of "it just works."

    1Password was able to populate things correctly in this login form since I started using the app a few years ago.

    In any event, I appreciate your prompt response and clear description of the workarounds available at this time.

    Edit: I'm just looking to see this acknowledged as a regression in behavior and that it will eventually be fixed in the 1Password for Mac app.

  • YaronYaron

    Team Member

    Hey @breslow,
    Thanks for sharing!
    I think you might have missed some important highlights in this discussion, although it is a really long discussion so I don't expect you to go over it all.

    The change wasn't from our side and is not a regression, Amazon changed the AWS login form recently in a manner that broke our autofilling logic. We already released a fix in our autofilling logic, which 1Password X utilizes and updates constantly. 1Password 7 for Mac and Windows will take a bit longer but it will get there.

    I understand having lots of logins for AWS might put you off from implementing the self-workaround suggested, but I do believe it's better to invest these 30 seconds on each login now, than to invest these 30 seconds every day, multiple times. :chuffed:

  • The change wasn't from our side and is not a regression, Amazon changed the AWS login form recently in a manner that broke our autofilling logic.

    Got it. Thank you for adding more clarity.

    We already released a fix in our autofilling logic, which 1Password X utilizes and updates constantly. 1Password 7 for Mac and Windows will take a bit longer but it will get there.

    👍👍

    I understand having lots of logins for AWS might put you off from implementing the self-workaround suggested, but I do believe it's better to invest these 30 seconds on each login now, than to invest these 30 seconds every day, multiple times. :chuffed:

    Agreed that this is probably the best course of action for now.

    Thanks for making it clear where the behavior came from, what you guys are doing to fix it, and what we can do now.

  • YaronYaron

    Team Member

    Thanks @breslow.
    I'm glad I could help. :chuffed:

  • edited May 12

    Any updates on this? I just came across this exact issue on Chrome 81.0.4044.138, 1Password 7.5.1 Beta-0, OSX 10.14.6, chrome extension 4.7.5.90
    Thanks

    Edit - Traced back through previous discussions and found the workaround of adding a new account field and that has resolved my issue as well.

  • YaronYaron

    Team Member

    Hey @davidahopp ,
    Glad you found the solution here and that it works well for you :chuffed:

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file