Update Failed Permission Denied Error - 1Password Could Not Finish Updating to 7.4.753

No matter what I do regarding closing all browsers and closing 1Password completely, I am unable to successfully processes the update. Manually updating yields the same results. 1Password continually tries to update and when it can't complete, it rolls back. This has me worrying about system stability and the safety of my password management. Detail message: Error: opw-base\src\error.rs277 permission denied (error code 5: Access is denied.)

Thanks for any help in resolving. Love 1Password, hate to see it have issues.


1Password Version: 7.3.712
Extension Version: 4.7.5.90
OS Version: Windows 10 1909 18363.719
Sync Type: Cloud
Referrer: forum-search:update permission denied

«1

Comments

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @Greg1634z3,

    Thanks for reporting this.

    Do you use Malwarebytes or AVG by any chance? If not, can you tell me which anti-malware solution you're using?

    If yes, can you check within Malwarebytes or AVG for an update and try again? Malwarebytes was causing this issue but several customers confirmed 4.1.0 fixed the issue for them.

    Try rebooting as well, there were updates in the background from Windows and anti-malware solutions that can block 1Password from installing and they needed a reboot.

  • I have the same issue and do not run Malwarebytes nor AVG.

  • this message just repeats and repeats... updated malwarebytes AND my browser... STILL won't finish updating... NEVER "rolls back" and won't let me open it. I'm about to uninstall 1Password and go to a product that you know actually WORKS.

  • ag_anaag_ana

    Team Member

    @ranord:

    Do you use another antimalware solution perhaps, as Mike asked? Also, have you tried rebooting? From Mike's previous post:

    Try rebooting as well, there were updates in the background from Windows and anti-malware solutions that can block 1Password from installing and they needed a reboot.

  • ag_anaag_ana

    Team Member

    @YankeesGirl:

    Can you confirm the version of MalwareBytes that you currently have installed?

  • ag_ana,

    Yes I've rebooted. I've disabled all browser extensions, except 1Password, disabled Norton. Other suggestions?

  • I have the exact same problem. Error: opw-base\src\error.rs277 permission denied (error code 5: Access is denied.) Running Windows 10 with the latest updates as of 3//12/2020 (yes, did complete restart successfully) Running Norton (the xfinity version) 22.20.1.69

    Worked fine until I tried to use it today. Have spent roughly 5 hours trying to get 1Password to run. Zero luck. Help, I have better things to do.

  • bundtkatebundtkate

    Team Member

    @ranord and @jsdean, disabling Norton won't always do the trick. When AVs lock something, that lock sticks until you reboot, which generally re-enables the AV and starts the cycle over. There are two things that can help here:

    1. Whitelisting %LOCALAPPDATA%\1Password in Norton so Norton stops blocking it.
    2. Uninstalling 1Password and installing the update directly from our downloads page. You may also need to delete %LOCALAPPDATA%\1Password\app before installing the latest. This works if it's using the temp folder that Norton doesn't like. We stopped doing this with 7.4 so the next update shouldn't cause the same problem.

    Give both a try (in whatever order you prefer) and let me know if it helps. :+1:

  • I think I fixed my error by quitting Malwarebytes 4.0.4 (without restarting my PC). My 1Password version is now 7.4.753.

    The error experience was pretty bad! 1Password error dialog boxes kept on appearing and the installation process kept looping indefinitely. Please consider better handling this error experience in future.

    I'll be turning off Auto install updates option.

  • ag_ana Malwarebytes version 4.1.0.56 pkg 1.0.20678 component 1.0.848

  • I am about to take 1Password and throw it as far as I can out the door. The program file is embedded so deep on my computer that I can't whitelist it. I try to uninstall the program from the control panel I get an error "error parsing arguments : Parse Errors" I did nothing special installing the original program.... settled for the defaults. Downloaded the new version, can't execute it. Just spinning. I am reasonably competent at dealing with Windows. This is absolutely the worst. Can't delete the program. Can't install the new. All my passwords are locked. Thanks a bunch. I am now up to 8 hours on this stupid problem.

  • @jsdean Does it help to install an older version of 1Password? Go to https://app-updates.agilebits.com/product_history/OPW6

  • Thanks Tran. I solved it. I downloaded the free version of Revo Uninstaller. Shut down the Norton Firewall permanently (and rebooted). Revo successfully uninstalled everything... the Windows 10 utilities failed. I installed the new version of 1Password successfully. Deleted the extension from Chrome and re-added the extension to Chrome. Enabled the Firewall. All in all so "simple" and customer friendly (sarcasm heavy). This at least kept me quarantined today.

  • I've been using 1Password since 2012. This is my first bad experience auto-updating the software :\

  • Hi all & thanks for so many, and several 1Password team members contributing. Everything made hits a snag from time to time. The update/fail loop seems to be stable in that it is not causing problems with feature delivery in the product, still 1Password deals with such sensitive information, any highly visible issue puts people on edge. I recommend development put more attention on solving this in the product. I would also recommend creating a choice to disable automatic updates, especially for business or enterprise customers.

    So, i've noted jsdean's success but hope I don't have to go there yet.

    What I have tried:

    • Updated Malwarebytes free to the latest edition (I keep it inactive as a 2nd on demand scanner) that did not work so I removed Malwarebytes
    • Removed 1Password Chrome Extension
    • Concurrently, I disabled Norton's firewall permanently and rebooted but also without success.
    • I can't find anything in Nortons logs or the Windows event manager where the install program is being blocked but will do more research. It's better to find out exactly which programs are interacting with this.

    My environment:
    Window 10 1909 build 18363.720
    Norton Internet Security - reports latest version but does not enumerate
    1Password 7.3.712

    My Plans

    • Research logs when I have time to hopefully get some precision on this
    • Give this a bit more time for a solution to come to light before trying uninstalling both 1Password and Nortong and reinstalling in reverse order.

    Thanks for all the input. I look forward to a continuing great 1Password experience once this is solved. Thanks again all!

  • Bump, 1password team what diagnostics do you need to take this from guessing to solving?

  • SergeyTheAgileSergeyTheAgile

    Team Member

    @Greg1634z3 there are many reasons why 1Password files can be locked, sometimes it's anti-virus, sometimes it's "system", sometimes it's "Connected Users Experience and Telemetry" service in Windows 10 and sometimes it's browser restarting app too fast. Unfortunately 1Password updater can't tell which process is locking files, that would require admin rights and we are trying hard to not to require it. Sometimes it's one of the folders/files in %LOCALAPPDATA%\1Password is set to read-only.

    You can use Process Explorer or Handle in admin command prompt to search for handles with "1Password" in their name. That will tell which process is preventing the update.

  • Thanks Sergey, process explorer reveals that 1Password is blocking itself. All handles are owned by 1Password and all DLL references are to DLLs inside of 1Password directories. Its distressing that I can't upload a capture of the Process Explorer search. I've used hundreds of software tools and have found forum based support lacking.

    Slowly becoming unsatisfied, here. I've been test driving 1Password personally but the real customer here will be the software company that I am starting. I have a single business licence, would I do better to report the issue over there and receive more enterprise level support?

    As of right now, I see no way out of this issue or any assurance it won't happen again on the next update. I have not seen an issue like this for 5 or more years, perhaps more. They used to be common but the enterprise grade firewalls and AV product have just gotten so much better at detecting only the real problems.

    1Password and it's directories were automatically set up by Norton Internet Security as allow always. Malwarebytes free has been removed. I believe we can take AV as the culprit off the table.

    What could be wrong that 1PW is blocking itself?

    Greg

  • bundtkatebundtkate

    Team Member

    If you'll pardon my unartistic screenshot, @Greg1634z3, you actually can upload images to the forum using the button pointed to here:

    Now, with that said, I generally don't recommend sharing screenshots here unless they clearly include no private information whatsoever. A public forum can be handy when others are encountering the same issue, but this type of screenshot can show things like filepaths that might have information you'd prefer not to share publicly. When that sort of information gets involved, then it's often best to move to email.

    Now, with that said, I do first want to clarify that using Process Explorer is only useful while the error message is active. If you dismiss it, 1Password is going to roll back any changes and start your original version for you. When that happens, indeed, 1Password will likely be the only process utilizing its own folders. Was the error message actively displayed at the time you looked? If not, it may be worth repeating that test.

    I also wouldn't necessarily be so quick to dismiss Norton. While it's sometimes the AV actively blocking 1Password from updating at all, we've also seen active scanning features temporarily lock one of 1Password's folders as it scans them. Many AVs manage active scanning exclusions separately from their overarching "allow" list, which generally applies to the firewall module. Adding an app to this list will allow all internet connections but may still block other activities and will not exempt the app's folders from being scanned and thus locked down for a time. If the timing is right, this can also cause Process Explorer to miss that lock. When the AV is done scanning the folder, it will release the lock so Process Explorer won't see it.

    I'll admit some frustrations with my own AV knowledge here as a limiting factor in the advice I can give. There are so many AVs offering so many different tiers and versions that it is really difficult for me to keep up with them as someone who traditionally avoids anything beyond Windows Defender. But, based on the verbiage "always allow" and the steps listed for excluding from active scans in the guide below, I suspect you may not have whitelisted 1Password for scanning purposes:

    https://support.norton.com/sp/en/us/home/current/solutions/v3672136

    That leaves an avenue for Norton to still block the update, if it is in fact scanning as 1Password completes its update process. It may be worth setting up a scanning exclusion as well to cover that possibility.

    Finally, I should mention that we've made some improvements to the update process aimed at helping with these sorts of issues. The trouble is that it's the installed app – not the updated app – completing part of that process so the benefits are delayed by one update. 7.4 has a big 'un – it avoids using the temp folder which is something AVs often don't like. If that's what's giving you trouble, you may even find the next update installs happily without you doing a darned thing. As you can see there are a lot of moving parts here and what upsets a given AV isn't always the same as what upsets others. We definitely are working on making this better overall, but it's a process and one that may well never be truly finished as AVs continue to evolve. But, hopefully, we can continue to make these cases rare enough they're the extreme exception rather than the rule.

  • Hi the handles are pretty simple and clear. Ok to share. Update error active, here are the handles. No AV is locking or blocking.

  • By the way the frequency of the auto update seems to be increasing. I'm starting to have more trouble just using the product at all. Hope this helps. Truly something unexpected is happening.

  • Sorry hit enter too soon. With my new image posting powers (thankyou) here is the error dialog as well

  • Even the error dialog expresses a bias in thinking

  • By the way, for anyone experiencing this problem, you can essentially stop the update cycle by allowing the update to fail, signing back into 1Password and leave the message that there is an update available untouched. This will halt the update process. If you close the message then the autoupdate process will start again. Hope this helps.

  • Bump up to support. Please let me know that the handle chain while the error was expressed has been seen and is being considered. There is an access of the temp folder, some undefinds, each of which could be causing the hang. There is no other program locking or blocking the update or restricting access as far as I can tell from the window system.

    What would be lost if I uninstall 1password and reinstalled?

    Greg

  • SergeyTheAgileSergeyTheAgile

    Team Member

    @Greg1634z3 sorry for the long wait. Do you know what BrCtrlCntr.exe and BrCcUxSys.exe processes are? They look like ones locking folder and causing updater issue.

    1Password 7.3 downloads updater to TEMP folder and runs it from there.

  • SergeyTheAgileSergeyTheAgile

    Team Member

    Uninstalling and reinstalling 1Password will not lose anything, it's just reload of code. Your local copy of data is stored in the encrypted database %LOCALAPPDATA%\1Password\data\1Password10.sqlite

  • BAM! Light went on. I thought it was one of yours. Misinterpreted. It's a Brother Printer control software. I closed it and .... wait for it ... am now updated without a hitch. Awesomeness!

    So to net out this thread. If you get an error like the above - you will get more friendly results from Process Explorer that from Handles. Both are Microsoft written and distributed but not supported. Trusted. Use them to find out what's blocking you.

    Thanks contributors and support team!

  • bundtkatebundtkate

    Team Member

    I'm thrilled you found it, @Greg1634z3! Of course, now you've just got me interested to know what your printer software wanted with our folder in the first place ... :lol:

  • I don't get it. Nothing has changed on my high-end computer or software yet all of a sudden I am getting the same above errors. Does anyone have a real answer or fix? I have tried all of the above.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file