Update Failed Permission Denied Error - 1Password Could Not Finish Updating to 7.4.753

2»

Comments

  • SergeyTheAgileSergeyTheAgile

    Team Member

    @Greg1634z3 wow, printer software locks 1Password files? Did you try to print something while using 1Password? I'm failing to see how that could happen.

    @cterry877 there are few tricks that work, but there is no single one that works for everyone:

    • close browsers while updating, they can try and start 1Password while it's being updated
    • whitelist 1Password/pause anti-virus software
    • finish pending updates in browsers, anti-virus or Windows. I actually had my browser once stuck on update for 4 months!
    • reboot
    • see my other post https://discussions.agilebits.com/discussion/comment/551664/#Comment_551664 with link to Process Explorer tool, it can tell you process names that are getting in the way of update.
  • MikeTMikeT Agile Samurai

    Team Member

    Hi @Greg1634z3,

    So, it's still trying to lock 1Password folder? I strongly recommend you touch Brother's support to explain what they're doing in there. There is zero reason any other process should be looking at our folders or any other folders they're not a part of.

    Check your Brother's software settings, there might be something they're scanning all folders for.

  • I asked this question on ServerFault.com, since solving these issues in a forum is usually fruitless because it's just a transcript of people trying to figure something out, instead of a ranking of solutions:

    1Password in stuck in continuous update loop with Windows 10 denying permission
    https://serverfault.com/questions/1014712/1password-in-stuck-in-continuous-update-loop-with-windows-10-denying-permission

    Could someone from 1Password answer there with a definitive list of things to try?

    Your app could also could improve the error message that occurs.

  • bundtkatebundtkate

    Team Member

    I can't speak for Sever Fault, but when there is a single solution to a problem, we try to mark it as such here and update the original post with a link when something has been more widespread. In this case, though, there really isn't an authoritative solution. There are some more common issues which we've outlined here, but there are definitely outliers.

    As for the error message, 1Password is sharing all it knows in these cases. It's Windows that is telling us the folder can't be written to or isn't able to modified or whatever the case might be and we're relaying exactly what Windows tells 1Password, with a bit of context based on what we know about the typical issue of this type. Depending on what version you're stuck on, you may not see this, but as we learned more about the problems folks were having and the common solutions, we also added a "learn more" button that links to the guide I included here with that error message, so that's something else we've tried to do to help.

    Our hope is that this gets most folks sorted – permanently in many cases – but for those running into something different, the best and only option is one-on-one help. In that case, I tend to agree forums aren't the best choice and would suggest dropping us an email to [email protected] instead so we can work with you directly. :+1:

  • Hi All,

    I had this issue for a while, but I managed to solve it doing the below (I use Malwarebytes and Windows Defender as my protection of choice):
    1. Update Malwarebytes to the latest version (4.1.2.73 as I type this). I was on 4.1.0.xx (I think 4.1.0.56, but I didn't jot this down).
    2. Open Malwarebytes's "Allow List" and add the following rules:

    • Add > Allow a file or folder > select "Add a folder" button > navigate to %localappdata% and select the 1Password folder (in my case: "C:\users\my profile\AppData\Local\1Password\"
    • Add > Allow an application to connect to the internet > Browse > navigate to and select "%localappdata%\1Password\app\7\1Password.exe"
    1. Open 1Password and sign in. From the top menu > 1Password > Settings > Update, ensure "Automatically install updates" is checked (I haven't opted into the beta), then click the button to check for new versions (the one to the left of the "Show Release Notes" button).

    If you're still experiencing issues, I recommend checking that Windows Firewall and Malwarebytes haven't blocked and quarantined anything in the 1Password directories respectively, then try again. Hope this helps!

  • GregGreg

    Team Member

    Hi @Zectzozda,

    Thank you for these steps! They are indeed really helpful.

    I'd like to add that I would always recommend using the latest versions of the software on your devices, especially if it is security software, be it 1Password or Malwarebytes. It is a good security habit.

    Let us know if you have other questions about 1Password now, we are always ready to help.

    Cheers,
    Greg

  • FYI, I encountered the same error. By reading this and other support disucssions, I resolved this situation by:

    • Looking at the installer logs at %LOCALAPPDATA%\1Password\logs\setup[most recent file] to see where and what was failing. I noticed the access denied issue occurred when renaming the "app" folder to "previous"
    • Navigated to %LOCALAPPDATA%\1Password
    • I already had a folder there called ...\previous
    • Manually renamed that existing folder from \previous to \previous-old
    • Attempted the update installer again and it worked!
  • bundtkatebundtkate

    Team Member

    Interesting find, @EC_7. Looks like perhaps a prior update had failed back before the installer properly tidied and Windows wasn't allowing us to rename a folder to have a name that matched an existing folder. I'm not sure if we can handle that better – depends how detailed the feedback the installer gets is – but I'll be sure to share with our development team in case we can handle that scenario on our own. :+1:

  • I can confirm @EC_7's solution solved this for me.

  • bundtkatebundtkate

    Team Member

    Glad to hear it, @andrewrobbinsd! :chuffed:

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file