Installed 1PasswordX in Firefox; website not detecting extension is installed. Please advise

Hi,

I just joined 1Password and have installed 1Password X as a Firefox Extension. Firefox shows that the extension has been installed, however when I go to a website (say LinkedIn), the website does not recognize 1Password has been installed. Hence, no login and password autofill are suggested.

Please advise.

Thanks,
Sub


1Password Version: Not Provided
Extension Version: 1.18.1
OS Version: Firefox 74 (64-bit)
Sync Type: Not Provided
Referrer: forum-search:Installed 1PasswordX in Firefox; website not detecting extension is installed

Comments

  • kaitlynkaitlyn

    Team Member

    Hi @subhrangshu! I'm glad you reached out. I'm wondering if you see a 1Password icon inside username/password fields. It'll look something like this:

    Do you see a menu underneath fields with the 1Password icon inside them? That's the inline menu, which will contain existing Logins for the website you're visiting. That means the URL inside the Login item would need to match the URL that you're currently visiting. I hope that helps, but let me know if you have any questions!

  • Hi Kaitlyn,

    I appreciate the note. I do not see the 1Password icon inside the username/password fields.

    Regards,
    Sub

  • kaitlynkaitlyn

    Team Member

    @subhrangshu – Thanks for letting me know. The inline icon is part of 1Password X, so those icons should appear automatically once you sign into your 1Password account. I'm curious what happens when you click the 1Password icon in your Firefox toolbar. Does a new tab open asking you to sign into your account, or do you see a pop-up appear with your 1Password items?

  • Hi Kaitlyn,

    That's exactly what I was expecting. No new tab opens when I click on the 1Password icon in my Firefox toolbar, neither does a pop-up appear.

    Regards,
    Sub

  • kaitlynkaitlyn

    Team Member

    @subhrangshu – Interesting. Would you mind sending me a screenshot of the 1Password icon you're clicking? I want to make sure we're looking at the same extension.

  • Hi Kaitlyn,

    Did my image come though?

    Regards,
    Sub

  • ag_tommyag_tommy

    Team Member

    @subhrangshu

    It was held up in our moderation/spam prevention queue. It is now shown in the forum for @kaitlyn

  • kaitlynkaitlyn

    Team Member

    @subhrangshu – Super interesting. Can you try visiting https://my.1password.com and signing into your account? Do you see a prompt asking if you'd like to add the account to 1Password X?

  • Hi Kaitlyn, I don't see any such prompt. All I see is the screen shot below:

  • Hi Kaitlyn,

    I click on "Get the apps" and then on the "1PasswordX" for Firefox, I see the following in a new tab:

  • ag_anaag_ana

    Team Member

    @subhrangshu:

    I am curious to see if any other browser extensions are interfering with 1Password X on your device. I have just tested it here in my Firefox browser and things worked fine. My browser only has the 1Password extension installed, so can you try temporarily disabling all of the other extensions, quitting and relaunching Firefox, and seeing if the behavior changed afterwards?

  • @ag.. I have not tried on other browser extensions and will try. I just realized that I run Firefox in private mode. Would that have anything to do with my problems? That said, I have enabled 1Passsword extension to work in private mode for Firefox

  • ag_anaag_ana

    Team Member

    @subhrangshu:

    No, I don't think using 1Password X in private mode is the cause of this.

  • @ag_ana what do you propose I do?

  • @ag_ana I had downloaded Keeper earlier and it seemed to work fine on my version of Firefox

  • I am also experiencing this issue, but only with the 1passwordX extension. The older extension available on the website currently works (requires the desktop app to be installed an logged into). I can successfully login to the full web interface at my.1password.com without issue.

    I think it is unintentionally my fault, as I use a custom user.js file for Firefox (for browser hardening, privacy, etc). That specific file can be found here - https://github.com/pyllyukko/user.js/blob/relaxed/user.js

    I have disabled all other addons, and that didn't solve the issue. Restart of both browser and computer have been attempted, but did not fix the issue. I am using the latest FF x64 public version, 74.0.

    For me, the addon is installed, but when I click on it in the toolbar, nothing happens. No new tab pops up, no login request, nothing. Its like something was blocked from completing the request to open the extension.

    Would it be possible to find out which setting or combo of settings is causing the issue so I can modify them without losing the greater ability to use the custom user.js file? I'm happy to provide whatever extra information might be needed.

    I just transferred everything from Dashlane to 1password yesterday, as 1password seems to be better at communicating, listening to users, and actually follows "the right darn way to do things" philosophy with privacy. My only frustration so far is the Dashlane extension in Firefox has never had this problem, which I'd say is pretty minor.

  • kaitlynkaitlyn

    Team Member

    @subhrangshu – Ah, thanks for pointing out that you're using Firefox in private browsing mode. While in private browsing mode, Firefox prevents extensions from accessing the local database, which 1Password X relies on in order to function properly. That used to result in a blank page when trying to open the extension, but now that you mention it, I wonder if that behavior changed recently. Everything that you're describing reminds me of that issue aside from the blank page appearing. Just to check, could you try disabling the Always use private browsing mode option and seeing if the issue still occurs?

    Let me know what you find!

  • kaitlynkaitlyn

    Team Member

    Hi @silver_bill! Thanks for jumping in. 1Password X needs access to the local database to function properly. Do your privacy settings happen to restrict that at all? That's the issue with private browsing mode, but I haven't put in the effort to create a custom js file myself.

  • @kaitlyn the challenge was indeed having the Firefox in private brower mode. Switching that off has taken away the problem. Thanks!

  • kaitlynkaitlyn

    Team Member

    @subhrangshu – Awesome! You're very welcome. If anything else comes up, I'll be here for you. :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file