Window in system tray and browser extensions do not stay open

For the last couple of updates, all of my Windows computers have the same issue of the window closing immediately after clicking either the system tray icon or any of the browser extensions (Firefox, Chrome, Edge). Of course, this makes it difficult to use to have to open the full app and copy/paste all elements.

Is there a fix to this? I tried uninstalling/rebooting/reinstalling all pieces of 1Password and disabling AV/AS...on all computers. This occurs on all Windows computers (all are Windows 10 Pro [Lenovo and Microsoft Surface models] with the latest updates). Thank you.


1Password Version: 7.4.753
Extension Version: Latest for Firefox, Chrome, and Edge
OS Version: Windows 10 Pro
Sync Type: 1Password paid service (not 'X' extensions)

Comments

  • I am also having this issue on one of my PCs, but not others, interested to know if there is a fix.

    1password 7.4.753
    Chrome 80.0.3987.149
    OS Windows 10 Pro 1909, all updates installed

  • MikeTMikeT Agile Samurai

    Team Member

    Hi guys,

    Thanks for taking the time to write in.

    At the moment, there are no known issues like that and I can't reproduce it on any machines.

    Do you have multiple monitors or anything like that?

    Does bringing up 1Password via Control + Alt + \ or Control + Shift + \ shortcuts work for you guys?

  • Hello and thank you for the reply.

    The shortcuts work. No multiple monitors. I had to turn off the auto-update because it keeps failing thinking files are locked or read-only. I use process explorer to ensure nothing is using the files. This started a few weeks ago with an update and has not been fixed if I manually uninstall and re-install with the latest updates since.

    A long time with no issues with auto-updates...now the past month have been very annoying...I have been a customer since the version 3.x days.

    This has become time-consuming and unusable. Please let me know if there is anything I can share.

    Soon, I will have to stop my subscription and switch to another tool. I rely heavily on this as an IT person and can no longer keep fighting it or working around it (most of my usage is through the web browsers where I have to manually open the full 1Password app, search, then copy and paste elements one at a time - also this avoids anti-phishing feature).

  • bundtkatebundtkate

    Team Member

    The update issue could be Malwarebytes in need of an update, if you use it, @kamintech. They fixed an issue that interfered with 1Password's updates in their latest update so if you do use Malwarebytes, checking for updates to Malwarebytes and giving your PC a quick reboot should sort out future update issues.

    As for the disappearing windows, that sounds like mini losing focus. Is there anything running on your PC that might be stealing focus? As an alternative to digging in as well, if you largely use 1Password in your browser, you might try 1Password X in your browser and see if that helps:

    https://support.1password.com/getting-started-1password-x/

    This won't help with your system tray and is a different experience from the companion extension, but may serve as a viable alternative in your browser or at least alleviate the struggles while we continue troubleshooting.

  • Thank you for the reply.

    I do have Malwarebytes with the latest updates and rebooted again...no difference. As mentioned, I tried disabling AS/AV completely, and it didn't help.

    I tried the X option in the past and am not fond of it compared to the desktop option. I understand it is a temporary option suggestion...but to setup the replacing of the extensions as a work-around for all browsers on all computers (and I have locations I support with my same issue) is a major time loss that I cannot afford.

    The desktop app option with browser access is one of the reasons I and some others I assist stayed with 1Password.

    Using my multi-computer environment, the only non-AS/AV software that updated since this started (besides 1Password) is Windows itself. Unless 1Password has a conflict with one of the latest Windows updates, I am guessing this is an issue within the latest versions of 1Password.

    The issue to too consistent on various computers in my world that it doesn't seem to be anything but 1Password (and maybe a Windows update since all have received the latest updates).

    By the way, I see many forum entries about the auto-update failing and incorrectly stating that files are locked by other processes. I have this issue too. Maybe this is related to this problem...? The auto-update (or manual update which has the same issue) seems to have been popular online for the last month...about the same timeline as my "mini window focus" problem.

    As a side note, there are no issues like this on the few Macs I work with. It is Windows-only.

    If there is other information I can provide, please let me know. Thank you.

  • bundtkatebundtkate

    Team Member

    The frequency of the update issue is predominately a result of an unfortunately timed Malwarebytes issue. Now, I think you should have sorted things if that's what you're running into, but juuust in case I want to emphasize that disabling won't necessarily do the trick. What happens is that there genuinely is a file in use and that lock isn't released absent a reboot so disabling alone isn't enough. It becomes a bit of a self-fulfilling prophecy in the case an AV is the cause because it'll lock a file, you'll disable, that lock sticks so that won't work, you reboot and the AV re-enables again. If you're able to disable your AV and keep it disabled through a reboot, that can rule it out, but for most that takes a bit more doing. Specifically when it comes to Malwarebytes, though, this was fixed in an update they pushed so if you updated to get the fix, then rebooted to release the lock, that should do the trick. If you've not done that dance, even if you have tried disabling, it is absolutely worth doing. If you absolutely did do that dance and are still having trouble, I wrote up some tips recently that can be found here.

    On the disappearing window front, your experience says something external specifically on your systems to me. I do think a change in 1Password likely caused it and whatever else to get into a fight here so I'm not blaming a third-party by any means, but I personally have seen a total of one other report of this issue and, unfortunately (for me anyway), that person found 1Password X and preferred it so I never got to track down the trouble. That's not say I don't think 1Password plays a role here – I'm certain it does – but that I don't think it's an inherent defect as I'd expect to see more of it than I have.

    Now, with that said, I had a chat with one of our development team this morning and he has seen a bit more of this than me and is looking into it as we speak. Last note I see he was working with some other folks impacted to get some additional logging from them with a special build of 1Password. My hope is that will yield some results on its own, but to do my part and not leave you with nothing here, I would still like to know if there is any chance something on your computer might impact where focus ends up. Think about anything that automates a click for any reason or anything that might need to focus a particular part of your screen to make something happen. This would need to be something present across all impacted machines so that may help narrow it down if your environment is a bit different across devices. Finally, you mentioned multiple browsers – dose this affect more than just one? To this point, it looks like most folks have been using Firefox so if this happens to folks using other browsers as well, that could be a potentially useful datapoint.

    Thanks!

  • Thank you for the reply and information. When I disable, I disable like an IT person (like myself) would. I remove all from memory and keep instances from running for Malwarebytes - even on reboot. Latest Malwarebytes update and reboot had been tried.

    I went as far as installing on a newly-setup Windows 10 computer that had not yet had Malwarebytes or other security software installed (disabled the services for Microsoft's security software). It has the latest Windows updates but has nothing except an Office 365 trial on it (no junkware - clean OS install). It still has the same behavior on this clean setup.

    As for the focus element, I am a disciplined IT person and can say with confidence that nothing (except for what I mentioned earlier) has changed. So something taking over focus all of the sudden on all computers in different environments/networks is highly unlikely...especially in my network where nothing has changed except for AS/AV and Windows updates. Not everyone, by the way, is using Malwarebytes that I assist with this issue.

    As mentioned in the request, all browsers and the system tray are affected on all computers. Edge (newer version), Chrome, and Firefox are included.

    I appreciate you taking the time to consult the development team. I will re-assure people it is being looked into and that there may be a solution before they require me to change the setup next week.

    As a veteran IT person, I suggest that 1Password reaches out to me to establish a remote session and is welcome to "poke around" to see if they can find a solution on one of my computers. This is the standard approach when I support my customers that cannot easily be fixed through messaging.

    I again appreciate the detailed information and thoughts...I will be happy to try a remote session with someone from 1Password to be more efficient with this troubleshooting process. If that is not an option, I will simply wait through the weekend to see if there are any updates before beginning a mass migration to another solution.

  • bundtkatebundtkate

    Team Member

    We definitely will do remote sessions when needed, @kamintech, but we've found we don't need them too terribly often. Looks like this one has proven no different as I just got word a fix for the disappearing extension window is in the works. This time, I don't have any details on the exact cause as I decided I'd probably be contributing more to slowing down the fix by asking, but I'll make sure to pass along your report so we can drop you an update when that's ready.

    On the installation front, we'd have to look at Process Explorer or Resource Monitor to see what's locking down those folders. We actually don't even make the call as to whether the file is in use or not, Windows does. We're just showing our own error that hopefully puts the problem in more context based on the error code Windows returns. I've seen both OS5 (permission denied) and OS32 (used for both file in use and read-only). The read-only mention is only included with the OS32 error, so that's probably the one you're getting. That's not to say Windows couldn't be wrong, but so far as the OS is concerned something is using that file/folder and its not going to let 1Password complete that update until it's released so we need to find out what it thinks it is, one way or another.

    You may already know how this works, but I'd rather not cause delay by assuming. I've included instructions for Resource Monitor below since it's what I'm familiar with using, but if you know Process Explorer and prefer it, by all means.

    1. Reproduce the update error (old versions are available for download here, if needed) and leave the error dialogue up.
    2. Bring up the Run dialog via Windows Key + R.
    3. Type resmon and press enter.
    4. Switch to the CPU tab and type 1Password in the search field next to Associated Handles.

    This should give you a list of processes interacting with 1Password at that time. Anything other than the installer is probably going to be a problem. Now, normally I ask for a screenshot of that list, but if you feel you're able to move forward on your own, by all means. If you're not sure about next steps, I'm happy to help. You can post a list or screenshot here, if you're comfortable, or you can send it to [email protected] and share the Support ID you get back via autoreply here and I'll take a look. Whatever you prefer. :+1:

  • kamintechkamintech
    edited March 28

    Thank you for the reply and details. As stated earlier in the thread, I used Process Explorer (PE) to determine nothing is using 1Password files during installation. What I didn't share is that I also tried resmon to be sure PE wasn't missing something.

    With a fix in the works, I won't spend anymore time on it. I hope the fix will happen sooner than later. For me and the many other people I help, this has been a thorn in our side for about 5 weeks now. I understand some people with the desire to move on. I will wait as long as the other people will allow me to.

    Thank you again for your attention to this. Crossing fingers that it doesn't take weeks to publish the fix...

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file