Why is 1Password launching Google Chrome with Open&Fill?

My system default browser is Edge, but 1PW launches Chrome with Open & Fill. I want 1PW to launch the system default browser.

Both browsers have the 1PW extension installed and the extensions work correctly.

1PW version is 7.4.758.

Chrome extension is Version 4.7.5.90

Edge extension is Version 1.18.0

Thanks.


1Password Version: 7.4.758
Extension Version: Not Provided
OS Version: Windows 10
Sync Type: Not Provided
Referrer: forum-search:default browswer

Comments

  • ag_anaag_ana

    Team Member

    Hi @nealsacon! Welcome to the forum!

    This is because the Open & Fill option only works with the companion browser extension (version 4.7.5.90). In your Edge browser you have 1Password X installed instead, which is an independent browser extension that does not communicate with the desktop app. So when you click on Open & Fill, the only browser that 1Password recognizes with the companion browser extension is Chrome.

    If you want to use the open and fill feature in Edge, make sure you install the same extension that you installed in your Chrome browser.

  • Thanks for the reply.

    I removed 1Password X and installed 4.7.5.90 from the link you sent.

    Same result - 1PW launches Chrome.

  • bundtkatebundtkate

    Team Member

    Is this the case when you have both browsers closed, @nealsacon? 1Password sends the message to open and fill to the foremost connected browser. If you have Chrome open and focused, it'll go there. If Edge is open and focused, then Edge will be chosen. If neither is open, it should default to the system default.

  • 1PW always launches Chrome. It doesn't matter what browsers are open - one or none. Edge launches as the default for all my other apps regardless of what's open.

  • bundtkatebundtkate

    Team Member

    Are you able to fill at all in Edge, @nealsacon? For example, if you manually navigate to the sign-in page for a site you've already saved in 1Password, then press Ctrl + \, does that work? It almost sounds to me like Edge simply isn't connected and we're missing the actual problem here because we're focusing on the "Go" part first when, in fact, that will only work if "fill" works in the first place.

  • nealsaconnealsacon
    edited March 23

    Ctrl + \ works and the Edge extension works fine - it auto-captures new site logins, communicate with the database, and auto-fills from the extension. The only thing that doesn't work is that the desktop app launches Chrome instead of Edge.

    Also, it doesn't matter which browser is set as the default - I've cycled through IE, Chrome, Edge and Firefox. The system correctly recognizes the correct default browser for everything but 1PW, which launches Chrome regardless of the default setting.

  • GregGreg

    Team Member

    Hi @nealsacon,

    If you have 1Password extension installed in Chrome on your PC, could you please try to disable/remove it, reboot your PC, and check how 1Password behaves after that?

    Thanks! :+1:

    ++
    Greg

  • OK, well, I didn't remove the extension from Chrome, and actually didn't make any changes in my system or my browsers since the replies above on 3/23 and this morning found that 1PW now launches Edge as it should. So F.B.I.

    I wasn't paying attention, but there was an update pushed at some point, and it might have been yesterday, to version 7.4.759 and my guess is that the push resolved whatever the issue was.

    Anyway, I really appreciate you guys jumping on this and trying to figure it out. All's well that end's well.

    Take care - stay healthy.

  • bundtkatebundtkate

    Team Member

    I'm not sure what might have sorted it in that update, @nealsacon, but fixed is fixed and you'll hear no complaints from me. Thanks for your patience while we tried to narrow things down and you stay safe out there too. :chuffed:

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file