Firefox extension not working

Hi,

The 1password Firefox extension is no longer working for me. Nothing happens when I click on the 1password icon in the toolbar. I don't see a 1password icon inside username/password fields in any sites I visit.

I've followed the instructions found here: https://support.1password.com/extension-troubleshooting/
Including rebooting computer, starting 1password application and then trying the extension. Updating 1password application and extension. Uninstalling and reinstalling the extension.

The 1password extension in Chrome (80.0) still works.

I am currently using Firefox 74.0 but the problem began in 73.x.

Some potentially useful screenshots below.

Thanks for your help.

Brett

Firefox extension icon:

Lack of icon in username/password fields example:

1password is the only extension installed in Firefox:

1password extension settings:


1Password Version: 7.4.758
Extension Version: 4.75.90
OS Version: Windows 10 1909
Sync Type: Not Provided

Comments

  • bundtkatebundtkate

    Team Member

    It sounds like you were previously using 1Password X, @bhdbiz, and have ended up with the companion extension instead. The latter requires the 1Password desktop apps so it won't work without one installed. It also never shows icons in fillable fields like 1Password X does. Try reinstalling 1Password X:

    https://1password.com/downloads/windows/#1PX-download

    This should disable the companion extension, but if it doesn't, go ahead and disable it yourself, just to be safe. Let me know if that gets you up and running. :+1:

  • Hi Bundtkate,

    It may very well have been the case that I had 1Password X installed before. Unfortunately, installing X and removing the companion extension doesn't seem to help. I still get no response when clicking the (new) toolbar icon.

    I do indeed have the desktop 1Password installed. It was just updated to 7.4.759.

    Thanks,

    Brett

    New toolbar icon:

    Windows Apps and Features:

    1Password X in Firefox:

    Still no fillable field icon:

  • kaitlynkaitlyn

    Team Member
    edited March 26

    Hey @bhdbiz! I'm on the 1Password X team, and Kate asked if I could take a look.

    I see a couple things wrong to start with, the first being that the 1Password X icon is unresponsive when clicked, so let's begin there. Just so I'm clear, when you click the 1Password X icon (the one with the little padlock on it) in your browser toolbar, does anything look like it's even so much as trying to happen? I'm looking for a new tab opening, a pop-up appearing (even if it's blank), or anything else, really. In addition to that, go ahead and try right-clicking the 1Password X icon as well. Do you see a context menu appear? If so, try selecting Settings and let me know how that goes.

    To help get to the bottom of the issue, would you be able to grab a copy of your 1Password X log as well as your browser log? At this point, both logs could potentially be throwing errors, so checking each of them out wouldn't hurt. We've got handy guides of how to obtain each log:

    Feel free to post the log here (either as a screenshot or as text) as long as you're comfortable with it. If you'd prefer to send them through email, let me know and we can go that route instead.

    As far as troubleshooting goes, I wonder if simply reinstalling 1Password X would help us out. That said, I'm under the impression that you just installed this copy of 1Password X, which makes me think reinstalling wouldn't be very effective. It's worth a shot, though. Go ahead and remove 1Password X and reinstall it in Firefox here.

    The next issue is regarding the 1Password icons not appearing inside fillable fields. I believe that'll be related to the first issue, though. While I do acknowledge that the icons not appearing inside fields is a problem, I'd like to first figure out what's going on with the unresponsive icon in your browser toolbar. Once that's resolved, we can move onto the next issue, if need be.

    I'll wait until I see a copy of your logs before going any further than that. I look forward to hearing back from you.

  • Hi Kaitlyn,

    Yes, the 1Password X icon is completely unresponsive.

    Right clicking icon reveals a context menu with no 'Settings' option:

    1Password X log:

    Could not map contract ID '@mozilla.org/sharepicker;1' to CID {1201d357-8417-4926-a694-e6408fbedcf8} because no implementation of the CID is registered.
    Initializing 1Password X... background.js:27:633766
    UnknownError: The operation failed for reasons unrelated to the database itself and not covered by any other error code.
    Use of nsIFile in content process is deprecated. 2 NetUtil.jsm:253:8
    

    Browser log:

    Unknown category for SetEventRecordingEnabled: fxmonitor
    Error: Can't find profile directory. XULStore.jsm:66:15
    IndexedDB UnknownErr: ActorsParent.cpp:612
    Error: Can't find profile directory. XULStore.jsm:66:15
    Key event not available on some keyboard layouts: key=“i” modifiers=“accel,alt,shift” id=“key_browserToolbox” browser.xhtml
    Error: Can't find profile directory. XULStore.jsm:66:15
    Use of nsIFile in content process is deprecated. NetUtil.jsm:253:8
    Error: Can't find profile directory. XULStore.jsm:66:15
    Content Security Policy: The page’s settings blocked the loading of a resource at inline (“default-src”). 2 panel.js:62:24
    Use of nsIFile in content process is deprecated. NetUtil.jsm:253:8
    Error: Can't find profile directory. XULStore.jsm:66:15

    I did indeed just reinstall 1Password X. I'll try reinstalling again after posting this message.

    Thanks for taking a look!

    Brett

  • Reinstalled and no joy. Same problems as described above.

  • kaitlynkaitlyn

    Team Member

    @bhdbiz – Thanks so much! I really appreciate you sharing all the details with me. After thinking on this for a bit, I'm wondering if you're using Firefox in private browsing mode. What you're describing sounds familiar, so I'm wondering if things may have changed in regards to using 1Password X in private browsing mode recently. Let me know whenever you get a chance.

  • Hi Kaitlyn,

    The problems occur in regular mode. When I launch a private browsing mode window the 1Password X icon doesn't appear in the toolbar.

    Thanks,

    Brett

  • I don't know if this is relevant or not but using the 'Open and Fill' option in the full 1Password program opens the webpage in Firefox (my default browser) but does not fill in a username or password. Perhaps another small clue...

  • kaitlynkaitlyn

    Team Member

    @bhdbiz – 1Password X doesn't communicate with the 1Password for Windows app, so the "Open & Fill" button will only work with the 1Password companion extension. Do you still have the companion extension installed in Firefox?

    If you have a few minutes, would you be able to set up a brand new Firefox profile and give 1Password X a try there? The new profile will have completely fresh Firefox settings. That'll let us know if it's an issue with your current profile or something larger. Check out Mozilla's guide on creating a new profile in Firefox if you need any help. I'll be here if you have any questions as well.

  • Bingo.

    First I uninstalled 1Password X. Next I created a new profile and set it as default. Then I reinstalled 1 Password X and it took me to the 1Password page to set up (enter secret key, email and master password). This referral to the 1Password page is something that didn't happen the last few times I installed 1Password X and it didn't occur to me at the time that it should be happening.

    Everything seems to be working as intended now. Thanks for your help Kaitlyn!

    Brett

  • kaitlynkaitlyn

    Team Member

    @bhdbiz – I'm so glad to hear that did the trick! If anything else comes up, don't hesitate to get in touch. In the meantime, stay safe and healthy out there. ❤️

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file