Suggestions pops up instead of filling (MacOS Safari)

Hey,

for some time I felt like something was off with 1Password and just recently found some time to investigate.

It seems like, while before I could hit a shortcut to fill the details on the webpage, right now it almost always shows the Suggestion box from 1Password Mini. I was able to find some time to troubleshoot the issue and that's what I found:

  1. Suggestions pop up if there are at least 2 entries in the same domain even if the subdomain has been setup in both

Example: I have only 2 entries
Entry A one page: login.somecompany.com with credentials: XXX:YYY
Entry B on page: service.somecompany.com with credentials: QQQ:PPP

If I go to either login.somecompany.com or service.somecompany.com suggestions with BOTH items being suggested, requiring additional confirmation.

  1. Even if suggestion is set as "do not suggest" and won't appear in suggestion window the sole remaining entry won't be autofilled

Example: I have only 2 entries
Entry A one page: login.somecompany.com with credentials: XXX:YYY
Entry B on page: service.somecompany.com with credentials: QQQ:PPP

If I hide entry B and go to page login.somecompany.com suggestion window with the sole entry A will popup.

-

Example: I have only 2 entries
Entry X one page: login.somecompany.com with credentials: XXX:YYY
Entry Y on page: login.somecompany.com with credentials: QQQ:PPP

Even if I hide entry X and go to login.somecompany.com suggestion window will pop up with entry Y.

This is not consistent with behavior that happens when only 1 entry exists for the site, i.e.:
Pressing autofill shortcut fills data in fields.

Note, this is especially annoying since it usually requires 3x confirmation per page of login credentials.


1Password Version: 7.4.3
Extension Version: Not Provided
OS Version: MacOS 10.15.3
Sync Type: Not Provided
Referrer: forum-search:Suggestions pops up instead of auto-filling

Comments

  • YaronYaron

    Team Member
    edited March 25

    Hey @pkaminski ,
    Thank you kindly for the time and effort put into this investigation! Well done.

    1Password will indeed pop up with the mini window if there is more than one login for a specific domain, but if you changed some logins to never be suggested in the browser, when autofilling it should indeed autofill the only option left. I wasn't able to replicate the behavior you are describing. Here's what I did:
    1. Created multiple logins for https://dash.cloudflare.com/login
    2. Changed some of them to https://cloudflare.com and left some on dash.cloudflare.com.
    3. Edited all of them except for one to "never suggest in browser".
    4. Tried to autofill on https://dash.cloudflare.com/login and it did autofill the only option left.
    5. I then moved them around and switched between them but still kept only one to show in suggestions and it always filled the right one.

    If that is not what you are experiencing, please repeat my test with that specific URL and create a few test logins for it. The only other difference I can think of is that I'm using the latest 1Password beta version while you are on stable, but I don't think that should have any effect on this matter.

  • After initial setup I can confirm that this - in fact - doesn't take place on dash.cloudflare.com. I verified that the same issue doesn't happen on amazon.com (testing multi-page login forms)

    There is something different there, though. Neither on dash nor on Amazon login form I have additional items such as Form Identities or Credit Cards which appears on the sites I noticed this (both are banking).

    Without hiding anything it looks like this:
    Entries shown

    And even hiding those still show pop up:
    hidden

    Tried removing login items but to no avail. One common factor I found is that all of those have "autocomplete" set to off. Might this be the core cause?

    I've found at least 3 banks that this behavior is consistent:
    ING Poland login page: https://login.ingbank.pl
    Santander Poland login page: https://centrum24.pl
    Alior Bank (another polish bank): https://system.aliorbank.pl/sign-in

  • YaronYaron

    Team Member

    Thanks for testing this further.
    I can confirm identity items or credit card items do not affect this issue so we can rule them out.

    I was able to reproduce the issue on https://login.ingbank.pl and on https://centrum24.pl. The third website autofilled properly without showing 1Password mini so you might want to create a new login for that website by following these steps: https://support.1password.com/create-multi-page-login/

    Looking at these pages HTML code, they definitely do not follow the standards for autofilling and name their fields in Polish or in a non standard descriptive name, which prevents even 1Password X from identifying them. The "autocomplete" tag is being ignored by 1Password as a default so that does not affect things.

    I have filed these websites for our developers to improve 1Password's autofilling logic for them in the future. Hopefully it will help in other Polish websites as well.

  • Thanks a lot!

  • ag_tommyag_tommy

    Team Member

    On behalf of Yaron, you're welcome.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file