Just installed X Beta v1.19.0 is saying my account is not setup in 1Password for Mac, but it is.

Just installed 1Password X Beta v1.19.0 and I get a message saying my account isn't setup in the 1Password for Mac client, yet it clearly is. I even logged out and back in via the Mac client and no change, same error.


1Password Version: 7.5.BETA-0 705000000
Extension Version: 1.19.0-BETA
OS Version: Not Provided
Sync Type: 1Password

Comments

  • ag_anaag_ana

    Team Member

    Hi @NeckBeardPrince!

    Can you please post a screenshot of this message? Thank you!

  • @ag_ana here is a screenshot, I just posted in the mac beta topic, but noticed this post here as well. Having the same issue as OP.

  • kaitlynkaitlyn

    Team Member

    @artooro – Thanks for sharing that screenshot! Would you mind grabbing your 1Password X log for us? It'd be really helpful to see that as well as a diagnostics report from your computer. The latter can only be emailed in, though. If you're up for it, please send an email to [email protected], and mention a link to this post as well as your forum username. You can find instructions on how to obtain both your diagnostics report and your 1Password X log below.

    1Password X Logs
    Diagnostics Report

    Let me know once you've sent the email, and I'll take a look!

  • @kaitlyn thanks I've sent in the report via email. Hope it helps.

  • kaitlynkaitlyn

    Team Member

    Thanks, @artooro! Let's chat via email. I've responded to you there. :)

    ref: XBG-11565-362

  • For anyone else having this issue, these steps resolved it for me. I believe a 1Password bug in the latest beta caused this.

    1. Disable desktop integration in 1Password X. (Right-click on the icon in the browser toolbar, and click Settings)
    2. Sign out of the problematic account.
    3. Add account, and re-add the 1Password account. - Verify it works without desktop integration
    4. Re-enable desktop integration
  • I had this problem, and @artooro 's solution worked for me, although step 3 was confusing, as they said to add the account twice.

    To clarify: Disable desktop integration. Sign out and back into the bad account in 1Password X (not in Desktop). Verify the account works without integration. Re-enable desktop integration.

  • ag_anaag_ana

    Team Member

    Thank you both for the suggestions @artooro and @mwdiers! :+1: And I am glad to hear that things are working fine for you again :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file