1Password update failing, windows 10

Using a desktop computer built in 2011, running Windows 10. I keep everything up to date. I keep logging into this machine and am greeted with an error from 1Password: "Your 1Password folder is in use or is read-only. Check the permissions of the 1Password directory and close other programs that may be using that folder."

From a recent Windows 10 update, I was prompted that I could now change my user name in Windows. I'd be surprised if this wasn't related to my problem with 1Password, but this is the only thing that seems to be acting up throughout the whole system. I'm sorry for the vagueness, this was days ago as well, and I don't recall the exact verbiage or where/what I changed at a glance, but can look into further if it seems relevant.

This has been going on for a couple of weeks. I think it was late last week or over the weekend, I spent some time attempting to resolve, including downloading the latest Windows installer and running it (similar error). I found an article on this forum I believe, that had me remove a folder from AppData> Local, thought I couldn't remove everything, I believe because of permissions related to this overall problem. When I ran a fresh download of the installer, I was able to install, launch, check for updates, and everything seemed fine until today when I logged in.


1Password Version: 7.4.758
Extension Version: 4.7.5.9
OS Version: Windows 10 Pro v1909
Sync Type: 1Password?
Referrer: forum-search:troubleshooting

Comments

  • bundtkatebundtkate

    Team Member

    Do you use Malwarebytes by chance, @MrBurbles? If so, go ahead and check for update to Malwarebytes, install them, reboot once more and try updating 1Password again. That should get you sorted out. There was a brief problem where we were getting into a fight with Malwarebytes, but the fine folks over there fixed it and we've now made up. :chuffed:

    If you don't use Malwarebytes but do use a different anti-virus, it's also worth checking for updates to that anti-virus and seeing if that helps. If none of this helps, let me know if you use Microsoft Edge at all and we'll give something else a try. :+1:

  • Hi bundtkate, thanks very much. I do run Malwarebytes as part of the same Eero package that nets me 1Password Fam, and it did want an update (not sure how I missed/was never prompted). Upon rebooting the computer for that update, 1Password now reports its up to date on this machine with no errors. I think that was the silver bullet, thank you kindly!

  • ag_anaag_ana

    Team Member

    On behalf of bundtkate, you are welcome @MrBurbles! If you have any other questions, please feel free to reach out anytime.

    Have a wonderful day :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file