Manually typed secret key doesn't work, but copy and paste does?

I am trying to setup a new windows box with 1pass. But I couldn't log in. So I went to my old windows box, and tried to log in to the web interface the same way. I found if I manually typed the secret key I couldn't log in. But if I copied it from the 1pass app I could. On the new box, copy and paste isn't an option since 1pass isn't setup yet... Any ideas what could be special that is breaking it? I've verified the key is type right many times, and check everything else. I have even tried on several different days just to get a fresh look. Still it just won't work... I am trying to avoid emailing my secret key around as that seems like a bad idea. Thoughts?


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: win 10
Sync Type: Not Provided

Comments

  • ag_tommyag_tommy

    Team Member
    edited April 1

    @Randell

    Any ideas what could be special that is breaking it?

    Possibly, an errant space at the beginning or end of the key. Perhaps a mistyped letter, such as 0 and O or swapping g and q. I would strongly advise against emailing the key. That method is not secure at all. Please transfer it over an encrypted USB of something of that nature.

    Once you get the machine setup, start a Secure Note and type in the Secret Key. Then open 1Password settings and copy out the Secret Key and paste it below the one you typed and look for any differences. That may help you locate where the issue is.

  • Thanks, but yeah I checked for those... And I tried at least 7 different times... Even trying on the computer I already had the 1pass app on and working so that I could literally paste it to notepad, and type it in manually, and put the notepad window just below it so the two were right next to each other and I could compare. Still didn't work. When I then copied from notepad into the field, I saw no change, but the login worked. It's like there is some kind of control character hidden in there or something. I dunno. Anyway, I can't use USB on the new device for security reasons. I encrypted a file with the key and password locked it... emailed it, and used cut and paste. So I am in, but I am professionally baffled.

  • ag_tommyag_tommy

    Team Member
    edited April 4

    @Randell

    I am a Mac guy and offered a few suggestions from my knowledge. :) Would you mind if I moved this over to the Windows forum so the folks there can take a look? It could be something specific to Windows.

  • Yeah, move over is fine. I used 1pass on the mac for 3 years also. I am pretty sure I manually typed in the secret key on that mac, and on another windows box I setup 3 years ago, and it worked then. Though I think I was still on win7 then.

  • GregGreg

    Team Member

    Hi @Randell,

    Do you enter your Secret Key in the web interface on 1Password.com in the browser or in 1Password 7 for Windows? If it is the former, does the issue remain in all browsers?

    Please clarify and let's investigate. Thank you! :+1:

    ++
    Greg

  • I was doing the web interface. But if I am really the only person who has seen this, it must be something funny with my chrome or something.

  • ag_anaag_ana

    Team Member

    @Randell:

    It's possible that something is happening in your Chrome browser, yes. The quickest way to test this is to try it on the same machine, but on a different browser. Have you given that a try?

  • Great thought... easier than what I was thinking of disabling all my extensions. But on firefox it also didn't work.

    And I retried copying from notepad into the log in, and that didn't work. double checked that with chrome and also doesn't work. So my previous statement that I could copy and paste from 1pass app to notepad and then from notepad to the form may have been wrong.

    But if I use the copy from the 1pass app and paste straight into the form, it works. Now curiously, I pasted into a libre office doc, encrypted and password locked, emailed it to myself, brought it up on the computer that was new, and was able to copy and paste from there and get it to work.

    This is very curious. There simply has to be more than one oddity at work here.

    To be clear, I have worked around the issue, so this is just a professional curiosity at this point (I work in QA). So I don't think anyone should put any serious time into this clearly edge case. But I will test any simple ideas people have. :)

  • bundtkatebundtkate

    Team Member

    Any different if you choose to "paste as plain text" from the right-click menu rather than doing a straight Ctrl + Shift + v? Basically, I'm wondering if this is an encoding issue possibly specific to something like your input setup? If you paste into Notepad, I'm 99% sure that puts it into plain text regardless so that could maybe explain why that works (sometimes? maybe?) and copying direct from 1Password does not. I use LibreOffice myself (though not a ton these days) but it could maybe do the same. Just a thought. I copy/paste into my browsers often with no issues, but one of the fun things about Windows is just how diverse it can be. There's a good reason "works on my machine" is never really a good excuse. :wink:

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file