Problem attempting to connect to the desktop application (Error 10009)

edited April 1 in 1Password X (beta)

Hi there,
as explained in the thread title, I've that error if I try to unlock my 1password X beta extension on my Chrome browser (80.0.3987.162, 64-bit). I can reproduce the issue 100% of times. There are no issues if I first unlock my desktop app and then use the Chrome extension.

EDIT: I've just been able to reproduce the issue from Chrome extension even if the Desktop app was open, unlocked and active.


1Password Version: 7.5.BETA-0 (70500000)
Extension Version: 1.19.0
OS Version: macOS 10.15.4 (19E266)
Sync Type: 1Password cloud syncing

Comments

  • More info:
    while my desktop app is unlocked, the Chrome extension keep giving me that Error 1009, but the extension perfectly work, actually. Because if I go to the input field for the log-in of a web page, the suggested item on my 1password vault is perfectly filled.

    It seems only a problem to open/show the items of the vault for the Chrome extension.

  • kaitlynkaitlyn

    Team Member

    Hi there @wizard86pz! That's interesting. I ran into something similar, but it was super brief, to the point where I didn't even have time to grab a screenshot. I'm really glad you reported it to us. I'd love to take a look at both your 1Password X log and a diagnostics report from your computer. That error, in particular, typically happens when 1Password X thinks there's a connecting, but 1Password for Mac says otherwise. That's why it'll be nice to see what's happening from both ends. If you wouldn't mind emailing the log as well as your diagnostics report in to [email protected], I'll get it reported to our developers ASAP. You can find the instructions below.

    1Password X Log
    Diagnostics Report

    Let me know if you have any trouble!

  • Hi, I see exactly the same error and behavior and have been for a few days. Anything I can do?

    Thank you.

  • edited April 6

    Hi @kaitlyn,
    today I've disabled the Desktop app integration in the extension settings. And then re-enabled like before. And now it's working well every unlock from desktop app (reflected in the extension) and vice versa.

    Not sure my logs would be helpful since I cannot reproduce the issue.

    In case I'm able to do it, I'll send them.

  • kaitlynkaitlyn

    Team Member

    Hey @pool1892! If you don't mind grabbing a copy of your 1Password X log after the issue occurs, that would be fantastic. Refer to my previous comment on how to grab it and where to send it.

  • kaitlynkaitlyn

    Team Member

    @wizard86pz – Ah, interesting. I'm glad to hear it's working well for you now. If the error does creep up again, and you have a chance to grab the log, please do and let me know!

  • Hi @kaitlyn , I've sent over my logs. They state in the Chrome extension console that everything is unlocked while I still see the error. At the very end, I unlocked via menubar and you see that the events have been received, but the status of the Chrome extension menu did not change. But I could use 1pw on websites at the same time.

  • ag_anaag_ana

    Team Member

    @pool1892:

    Thank you! I confirm that I have managed to locate your diagnostics report in our system :+1: We will take a look and get back to your email as soon as possible :)

    ref: NBD-77724-142

  • @kaitlyn I've been able to reproduce the issue again. To reboot my macOS device was enough.

    Here my steps:
    1. reboot the device affected
    2. run chrome and 1password x
    3. do not unlock desktop app that was running too after device boot
    4. press on the 1password X extension to have the Error 10009 shown in the first message of this thread
    5. collected the 1pass x extension log from the console after to have reproduced
    6. collect logs from the desktop app with the 1PasswordTroubleshooting.app you suggested by links for procedure

    Just sent email with SUBJECT "Problem attempting to connect to the desktop application (Error 10009)".

  • ag_tommyag_tommy

    Team Member

    @wizard86pz

    I found your submission and someone will be in touch ASAP.

    cc @kaitlyn

    ref: DCQ-92792-432

  • Great, thanks @ag_tommy.

    Hoping that devs can have a little more info about my test, to fix this issue, here what I've found: doing these steps, I've no longer any issue even after I reboot the OS/device. I'm no longer able to trigger it:

    1. reboot device/OS and open Chrome browser
    2. with the desktop app already running and not unlocked, in 1pass X extension settings, disable the linking to desktop app
    3. unlock the 1pass x
    4. unlock the desktop app
    5. enable the linking between 1pass x and desktop app

    Fixed in this way.

    cc @kaitlyn

  • jadchaarjadchaar
    edited April 9

    I am continuously getting this after the upgrade to 1.19.x on Firefox. Solutions that have worked thus far: restart Firefox or restart 1Password app.

    I am going to email my logs in a bit.

    Edit: support ID [#TXT-46556-338]

  • ag_tommyag_tommy

    Team Member
    edited April 9

    @jadchaar

    I also found your submission. Hang in there! Someone will get in touch ASAP.

    ref: TXT-46556-338

  • Just faced again even I was sure to have done all those things.

    It has been enough just reboot my macOS device.

  • kaitlynkaitlyn

    Team Member

    Thanks, @wizard86pz! I believe we've figured out where the issue was coming from, and we're working on reverting the change. That said, we have to wait for the Chrome Web Store to approve the current update before we can push another one. In the meantime, folks have had luck with simply unlocking the 1Password desktop app or restarting their browser.

  • Wow, good news @kaitlyn. So, if I've got it right, now we are to 1.19.0, there is already a new release waiting for Google review, and after that will be pushed another new release, to see fixed this issue?

  • ag_anaag_ana

    Team Member

    @wizard86pz:

    Correct :)

  • I'm having the same issue on both Firefox and Chrome.

    On Firefox there was a browser update pending and I had to restart the browser. This seem to have solved the issue in Firefox but I can't tell if it was from restarting or updating the browser.

    On Chrome, there is no pending update and I'm currently experiencing the issue. I have the logs available from 1Password X if necessary.

  • Glad to hear a fix is imminent - going into the 1P app and doing "Help -> Troubleshooting -> Restart 1Password Extension Helper" does the trick for me.

  • kaitlynkaitlyn

    Team Member

    @pmcatarino – Can you try switching over to the 1Password desktop app and unlocking from there? If the error still remains in 1Password X, try restarting Chrome to see if that helps. We've got an incoming fix, so the issue shouldn't happen for too much longer.

    @rjacoby – That's perfect! Thanks for letting me know of another potential solution. I'll keep it in mind. :)

  • Good news, the fix is confirmed in the coming beta builfd (https://app-updates.agilebits.com/product_history/B5X#beta), can't wait to see it in my Chrome.

  • ag_anaag_ana

    Team Member

    Thank you for the update @wizard86pz :)

  • kaitlynkaitlyn

    Team Member

    @wizard86pz, @pool1892, @jadchaar, @pmcatarino, and @rjacoby – I just wanted to reach out to let ya'll know that 1.19.2, that includes the fix for error 1009, has been published on the Chrome Web Store (Firefox should have already received the update)! There's a good chance that you've been automatically updated to the most recent version already, but just in case you haven't, you can go ahead and update now. If you happen to run into the issue again (while using 1Password X version 1.19.2), please let me know. :blush:

  • Thanks! Brave updated the extension yesterday and I have not seen the error since.

  • ceceliacecelia

    Team Member

    Awesome @jadchaar! Thanks for letting us know <3

  • Great, already updated! Thanks for letting was know!

  • kaitlynkaitlyn

    Team Member

    @pmcatarino – No problem at all! Have a good rest of your week.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file