Custom Sections/Fields duplicate themselves

billjbillj Junior Member

Today I created a new Login, then entered CONTACT in the first custom Section and set the first custom field to Phone. Then I went to a web page to copy the phone number. When I switched back to 1Password, the Section and Field had duplicated themselves. Oh?

This has happened on more than one occasion. Though I can't tell you if it's new to 7.4.3 or first appeared in 7.4.2. I deal with it by clicking on Save, then Edit, then using the delete widget to remove the extra Section/Field.


1Password Version: 1Password 7 Version 7.4.3 (70403002) 1PWD Store
Extension Version: 4.7.5.90
OS Version: macOS 10.15.4
Sync Type: iCloud

Comments

  • ag_anaag_ana

    Team Member

    Hi @billj!

    Can you please share with us the exact numbered list of steps to reproduce this, so we can test this here too? I tried to create a new section here but I could not reproduce this behavior. Thank you!

  • vplewisvplewis Junior Member

    @ag_ana I'm able to reproduce this as well. Using Version 7.5.BETA-0 (70500000). All I need to do is change the type of the "new field" in the first section and it down drops a new label plus a whole new section. A comparison is shown here.
    Before:

    and After:

    The extra field goes away after saving if left empty, but not the extra Section. hth

  • ag_kevinag_kevin Junior Member

    Team Member

    Hi @vplewis ,

    I think what you show in your screenshots is intended behaviour. 1Password will show a blank section so you can create a new one. So as long as something has been changed in the first custom section, a blank one will appear below it in case you want to add an additional custom section. If you make changes to that second one, you'll see a third one appear. Note this blank one is not saved to your item, it only appears in edit mode.

    @billj it sounds like your issue is different You are seeing a duplication of your actual data, correct? I have a question, is your item in edit mode when you switch away to the browser, or did you save the item before switching over to the browser?

    Thanks,
    Kevin.

  • I'm not using the beta, but since this discussion exists, I figured I would add to it.

    I've stumbled across the same issue and I'm able to reproduce easily via the following steps:

    1. Create a new Login item
    2. Click on any blank SECTION, type in anything you want.
    3. Immediately change the first item within the section to be a Password
    4. Notice that there is a brand new additional SECTION named the same as the one before it

    Notes:

    • In the supplied video (gif), I named my Login item, but it's not required to reproduce this issue.
    • This happens regardless of sync type: iCloud and 1Password accounts both result in the same issue.
    • I haven't tried it on anything other than a Login item, but it might happen on others types.
    • Above I noted to create a new Login item, but performing the steps above on an existing item leads to the same issue.

    1Password 7 Version 7.4.3 (70403002) 1Password Store
    macOS 10.15.4

  • ag_tommyag_tommy

    Team Member
    edited April 18

    @ryanolton

    Thanks for sharing, I was able to replicate the behavior. Thanks for reporting it.

    ref: apple/issues/-/issues/4692

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file