Updated to 7.4.4 broke autoful option

kagykagy

I have the stand-alone version of 1PW and just updated this morning to version 7.4.4 as suggested by a pop-up.

Doing so broke both Firefox and Safari extensions, which I was sort of able to fix via your support forum. But I can only copy/paste passwords from the extensions.

The App doesn't work any better. There is no longer an auto-fill button, and each login page has a "read only" button at the top.

The keyboard shortcut command backslash no longer works either.

In short, the only option I have for filling passwords is copy/paste.


1Password Version: 7.4.4
Extension Version: 4.7.5.90
OS Version: 10.15.3
Sync Type: Dropbox
Referrer: forum-search:no autofiil option on 7.4.4

Comments

  • ag_tommyag_tommy

    Team Member

    @kagy

    Please try the following:

    1. Quit Safari and any other open web browsers.

    2. Open and then quit 1Password completely.

    • Hold down the Control and Option keys on your keyboard and choose 1Password > Quit 1Password Completely from the menu bar.
    1. Restart the Mac.

    2. Open 1Password.

    3. Open the browser(s).

    4. Verify that you're able to use the extension to fill logins.

    This has worked for others, I think it will fix you up.

  • kagykagy
    edited April 8

    No, didn't work. I saw this suggestion on another post, and tried earlier. But I went ahead and tried it again with same results. Firefox extension has always been intermittent in opening at all, and at the moment it's broken (won't open at all). Safari opens, but will not give me an option to auto populate username and password fields. And as I type, Firefox extension has decided to open again, but still only gives me the option of "generate new password," or "pin on screen." No options to fill username/password

    Back to the main app: there is now a "read only" button which I've never noticed before. Clicking on that reveals a popup informing about a subscription for 1PW 7. Don't want a subscription. Is version 7.4.4 subscription only? If so, how do I go back?

  • BenBen AWS Team

    Team Member

    There hasn't been any change to the licensing model with 1Password 7 for Mac. If you have a license for v7 you can use that on any 1Password for Mac v7.x installation from our website. It sounds like your license may need to be applied to your installation, though. Please locate your license file and double click on it.

    That said, membership is the way forward. I would highly encourage you to reconsider.

    About 1Password membership

    All of our development effort is focused on membership, and so to get the best of 1Password that's the place to be. Our sales team would be happy to discuss an upgrade path for you, considering you've already purchased a license: [email protected].

    The app being read-only (unlicensed) would explain why you cannot use the browser extensions, but if you're still having trouble after applying your license please let us know.

    Ben

  • Thank you, Ben. I've been a long-time user of the individual license of 1PW, going back many many years. In fact I tried the membership model when it first started, and went back to the stand-alone, which is what I still prefer today.

    I had a working model of version 7 until updated to 7.4.4.

    Clicking on the "read only" button produces a window that does not give me the option to insert a license key.
    Apparently the only option is to subscribe.

    I have my order number, stored within 1PW's "software licenses." There is also stored there an attachment labeled "1Password 7 License.onepassord7-license-mac." But double clicking it opens a widow asking me to choose an application to open this file, and no application options exist. What kind of file is it, and how do I apply it to my current version of 7.4.4?

  • BenBen AWS Team

    Team Member

    @kagy

    The file should be opened with the 1Password application.

    Ben

  • ag_tommyag_tommy

    Team Member
    edited April 9

    Hey @kagy

    I apologize, this statement threw me off.

    I have the stand-alone version of 1PW

    and just updated this morning to version 7.4.4

    I totally missed the portion where you mention 7.4.4

    It looks like you moved over to the Mac App Store version somehow. To use a license, you need to be on the website version. This topic will explain how to do that. https://support.1password.com/switch-from-mac-app-store/

    Once you are moved back to the website version, your license should be all set. If you experience issues, I would suggest rebooting the Mac.

    When all of the above is complete, visit the Mac App Store and hide the purchase for 1Password. This will hopefully prevent it from offering updates in the future. https://support.apple.com/en-us/HT201322

  • Thank you @ag_tommy ! This fixed my problem.

    I'm in love with this app. Far and away my favorite and most "must have" app. But I've little interest in the subscription model. I have tried it in the past, but alas, my personality just hates revolving charges. I am much happier paying for upgrade fees, even while understanding that you have probably stopped supporting us stand-alone users.

    The only thing I could not accomplish in your recommendation above was hiding the purchase within the Mac App Store. If you can, guide me through that please.

  • ag_tommyag_tommy

    Team Member
    edited April 9

    Sure thing!

    Visit the Mac App Store and go to your Purchase history. Locate 1Password and click the "..." beside it, and then select hide purchase. Follow that with any confirmations you may receive.

  • Got it! Thank you! Over and out!

  • ag_tommyag_tommy

    Team Member

    You're welcome. Stay safe!

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file