Citi Credit Cards website autofill not working


Hey there! I've been noticing a problem when trying to log on to my Citi Credit Cards login. The website is https://online.citi.com/US/login.do and I have that site along with just https://online.citi.com/ saved in my "Citi Credit Cards" login profile. However, when I get to that page, after clicking in the password box, I get what you see in the screen shot - a suggestion box as if 1Password isn't recognizing that I've already got a password saved for this website. The only way to fill the password is to go up and click the 1Password extension button, then select the blue Autofill button. Can y'all fix this, or tell me how to fix this please?


1Password Version: 1Password X Beta
Extension Version: 1.19.1
OS Version: Windows 10 Enterprise 1809
Sync Type: Not Provided
Referrer: forum-search:Sign in to Citi Credit Cards website

Comments

  • ag_tommyag_tommy

    Team Member

    Hey @SunDevil2213

    I see the same behavior with my username set to be remembered. If you attempt to use the inline button, in the password box, I get suggestions. If I use the button by the url bar I can successfully fill the login. Also if you never select the remember me box then filling will work from either the URL bar or the username field.

    Looks like the button will always offer a suggestion in the password field.

    I am not part of the 1Password X team, so I cannot comment on if this is intended behavior. Just a fellow Citi user. I hope that helps...some.

  • Thanks @ag_tommy I'm only seeing this behavior on my Citi login page. Every other login, when I select the password box, 1Password pops up with the option to autofill my password. Hoping one of the devs can look at this particular page and fix it. I've seen other posts from devs about how they use a very specific Citi login page, but that's not a solution, just a workaround, as this is the page my particular card gives me to log in to.

  • kaitlynkaitlyn

    Team Member

    Hey @SunDevil2213! Yep, definitely not expected behavior. 1Password X seems to think that's a new password field. It's been reported to our developers, and I'll add you in as an affected user as well. That said, you should still be able to fill from the username field if your username wasn't stored. Are you able to have it un-remember your username? I'm not a Citi user myself, so maybe @ag_tommy will be able to comment on that.

    In the meantime, you can also click Suggestions in the 1Password X inline menu, then select Logins to see Logins available to fill. I hope that helps!

    ref: dev/core/core#358

  • ag_tommyag_tommy

    Team Member
    edited April 21

    Hey @SunDevil2213

    I cheated and cleared my browsing history to wipe out the saved user name. I am uncertain if there is a complete logout button on the site. :(

    You may be able to remove specific cookies for sites.

  • Hey guys just following up on whether or not you're going to be able to fix this issue?

  • kaitlynkaitlyn

    Team Member

    Thanks for checking in, @SunDevil2213! It's been reported to our team, but I don't have a timeline to share for when it'll be fixed. Another option to fill, for now, would be to fill via the 1Password X pop-up.

  • @kaitlyn the popup doesn't work (see original post with screen grab) as it acts as if there's no saved password. It's not a huge deal, because currently I just go up to the 1P icon in Chrome and click it, then click autofill. I do see what you were saying about clicking "Suggestions" in the popup, but that involves 3 or 4 more clicks. Again, not a HUGE inconvenience - more just an annoyance that 1P doesn't work like it does everywhere else for this specific site. Glad it's on your radar and hopefully a fix can be worked out. Appreciate all y'all do.

  • kaitlynkaitlyn

    Team Member

    My apologies, @SunDevil2213. I should have explained myself better. The 1Password X pop-up can be accessed by clicking the 1Password icon in your browser toolbar. It sounds like that's exactly what you're already doing, though. As I mentioned, you could also try to have Citi not remember your username so you can use the 1Password X inline menu (the menu directly underneath fields) to fill from the username field. Then, it would fill both your username and password with one click. I realize all of these options are only workarounds and not a long term solution, so we'll continue to work on improving the behavior on our end. Thanks for sharing your troubles with me. :)

  • same problem with citi card. did not save username; both username and password fields blank at signon. i'm using 1password extension in chrome.

  • ag_yaronag_yaron

    Team Member

    Hey @twf ,

    We fixed Citi's website a few months back, it should be working well. Here's a video of me saving a new login there right now and autofilling: http://recordit.co/TiWXd9pCKP

    Does that not work the same for you? Which version of the 1Password extension is installed in your browser?

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file