Auto filling is not working for the new Vivaldi 3.0 browser

Yesterday Vivaldi released their new browser, v3.0. I updated my browser and now 1password doesn't work. I am using 1Password extension (desktop app required) btw. It used to work before I upgraded.

I can click on 1Password extension icon, but nothing happens. I removed and reinstalled the 1password extension, still the same.

I have another pc, with the previous Vivaldi version (2.11.1811.52 (Stable channel) (64-bit)), no problems there.

So it must be the new version. Unfortunately i dont see any debug messages. Dont know how to get there for extension.

I hope it can be fixed soon. Vivaldi is a great browser. Now there's even a v1 for android which I am also using. I know 1password isnt working their either, but thats a diffrent topic.


1Password Version: 7.4.763
Extension Version: 4.7.5.90
OS Version: Windows 10
Sync Type: Not Provided

Comments

  • My issue has been resolved. Apparently restarting my browser after deinstalling and installing the extension again did the trick.

  • ag_anaag_ana

    Team Member

    Hi @Ido!

    I am glad to hear that restarting the browser helped you get this one sorted out already :)

    If you have any other questions, please feel free to reach out anytime.

    Have a wonderful day :)

  • I have the same problem - it often doesn't work, and if I click on the 1password extension icon it shows the looking for 1Password screen - however I get a launcher prompt, and it does launch 1Password, leaving the 1password not found screen behind it (see photo).

    I also find that when I press cmd-\ it show the "install the extension" message, and yet if I type some characters into the 1p mini window, it then finds passwords in 1P. Its really weird and frustrating. However on another identical computer it works more reliably (but still glitches from time to time).

  • ag_anaag_ana

    Team Member

    @365nice:

    Can you please go through all the troubleshooting steps in this support article and see if they help?

    If you see “couldn’t connect to 1Password” in your browser

  • I restarted by browser, and then restarted my computer - and I am now consistently seeing this window when I press cmd-\ (osx, with vivaldi).

    If I type into that window (which says install the plugin) - it will show the website I'm on (e.g. meetup), and then I can copy and paste the username/passwords, but can't reliably get autofill to work.

    If I click on the browser extension 1p icon (not the menubar 1), I am getting the message about unable to connect, in the new tab it opens up in Vivalidi.

    I have followed the steps on the page you have show.

    I am using 1p= 1Password 7
    Version 7.5 (70500002)
    Mac App Store

    Vivaldi = 3.0.1874.38 (Stable channel) (64-bit)

    I have had this working before, but the last few weeks its been doing this, and its a shame as I like vivalidi.

  • ag_anaag_ana

    Team Member

    @365nice:

    What is the version of the 1Password browser extension that you have installed in Vivaldi?

  • Just to add to this, I went back and installed Chrome (this was a new computer where I experienced this again) - and Chrome works fine when I install the 1p extension - cmd-\ on the same login page as Vivalidi just fills in my details.

    There is something weird going on with Vivaldi that makes it temperemental.

  • ag_anaag_ana

    Team Member

    @365nice:

    It looks like we posted at the same time :) I wonder if you installed a different browser extension in Chrome from the one you have in Vivaldi. What version of the 1Password browser extension have you installed in each browser?

  • On the browser where its working (and only occasionally seems to glitch) - the 1P and Vivaldi are the same version, the extension is: Version
    4.7.5.90

    (will go to other computer and reply again)

  • On the other computer its the same:
    Version
    4.7.5.90

    So its the same (they were installed from the chrome store)

    There is one difference I can think of - the other non-working account is not an administrator account (its a standard account) - could that make a difference?

  • 365nice365nice
    edited May 15

    On that new computer, I switched to my admin account and just installed the extension, and it does the same - doesn't seem to connect properly to 1Password, giving that blank - install extension message.

    If I click on the extension in the browser (not the menu bar) - there is a long - 5-6 second pause before it shows a tab saying looking for the 1Password app - then I get an opener window, and I can click on open, and it successfully shows the 1Passwored desktop app, but the tab in the background is says - 1Password not found?

    The settings in 1P do have the keep 1p open checked... it seems like some sort of race condition/timing issue - but I'm not familiar the internals or anything.

    The only thing I can say is that its new installations that are consistently not working - the one that is working has been an account on my macbook that I've had a long time and have upgraded 1P and Chrome and Vivaldi on for several months (e.g. since Dec - and even then is was a laptop setup from a time machine backup). So there is a chance that there is something from the past that makes it work, that new installs are not getting.

  • ag_anaag_ana

    Team Member

    @365nice:

    Thank you for the additional information. I would like to ask you to generate a diagnostics report from your Mac and email it to us to [email protected], so we can take a closer look at why this is happening to you.

    After you have sent the email, please feel free to post the ticket number you received so we can locate your message and connect it with this forum discussion.

    Looking forward to your message!

  • I've sent a report and referenced this thread - not sure if its in automated email, if so, I'll include the ticket info. Would be nice to get it working reliably.

  • ag_anaag_ana

    Team Member

    @365nice:

    Have you received a ticket number already? If you could post it here it would be great, so we can easily locate your message in the system.

  • It’s [#RSQ-52919-339], and it’s seems the diagnostic tool crashed and didn’t give full results, but I’ve got some more steps to try. Will report back

  • ag_anaag_ana

    Team Member

    @365nice:

    Thank you! I confirm that I have managed to locate your message in our system :+1: I also see that my colleagues have replied to you over there already, so to avoid duplicating support times, I am going to let you continue the conversation via email :)

    ref: RSQ-52919-339

  • Yes - I’ll follow the instructions but as it’s basically an uninstall/ reinstall I’m a bit dubious it will fix it as I reported this on a new machine (so it’s essentially a fresh install ), and on my machine where it mostly works - in a separate user account in that same machine it fails like on my second new machine.

    However I will follow the steps to confirm

  • ag_anaag_ana

    Team Member

    Sounds good :+1:

  • Hi - you know what, hurrah - its working on the machine that it previously wasn't working on! Reinstalling 1P seems to have kicked something into action, which is a bit mysterious but a great outcome. I need to verify that our other computers will do the same (my wife indicated that her Chrome installation was doing the same thing - but I'm hoping that this will also cure it too - and thinking about it, I think she got 1P via a backup restore, and so this might be the link as to why).

    Thanks for your patience - and I'll come back to you.

  • ag_anaag_ana

    Team Member

    Sounds good @365nice! And thank you for the update :+1: We are here if you need us :)

  • Hi - I just tried it on another failing computer (in this case it was chrome, not vivalidi, but it had the same issue of insisting the extension wasn't installed and/or coming up with empty logins on activation) - anyway the steps I was sent do seem to work - AND i think i've spotted a difference - I was installing from the Mac OSX appstore, whereas the instructions are to install from your website (that might be a crucial different - as maybe the app store sandboxing does something else you didn't realise?).

    For anyone following along there were the steps I was sent:

    Right-click on the 1Password mini icon in the menu bar at the top right corner of your computer > select “Quit 1Password Completely” >

    Uninstall 1Password 7 from your computer by moving the 1Password icon in /Applications folder to the trash => restart Mac => go here to our website and install the latest version of 1Password to your computer: https://1password.com/downloads => Open your browser and try again. [I found I didn't have to restart my mac, just cleared my trash]

    Right-click on the 1Password mini icon in the menu bar at the top right corner of your computer > select “Quit 1Password Completely” > Quit all browsers > Restart your computer > Try 1Password again [I didn't have to do this step either, it was working after reinstall]

    Hopefully this will also work in my computers that have secondary accounts where I also saw this issue (yet to confirm this, but it seems hopeful)

  • ag_anaag_ana

    Team Member

    Thank you for sharing these steps with us @365nice! I am sure that other users will find them useful if they encounter the same behavior on their machines :+1:

  • 365nice365nice
    edited July 13

    Sorry to pick this one up again - but its annoyingly failed again... this is incredibly frustrating. The computer that I fixed in the message above, a month later has been rebooted, with vivaldi relaunching and now I get the exact same issue again. There is definitely something broken/wrong - in all the years I've used 1password I've never had so many troubles on a new computer.

    So I've repeated the steps above, quite 1P, deleted it, reinstalled it from your website - I didn't have to restart my computer but did have to restart Vivalidi, and again its working....

    So here's a thought - as I have 2 accounts on my mac (but they share /applications which is standard - is there any way that you aren't storing settings properly for different user accounts? I'm wondering if I now login to the other account on my computer - if I will find that 1P doesn't work in vivalidi?

  • So - yes, i went back into the other account and sure enough its now broken... and I'm sure that if I follow the steps above (which I may well have done a month ago in the other account - leaving my work one running), it will fix it and bork the other one. So my hunch is that you are storing something in a place that isn't user specific somehow - or reinstalling isn't initialising something for other accounts and so then they are are broken when you restart.

  • ag_michaelcag_michaelc

    Team Member

    Hey @365nice. There's nothing we are storing on a per-user basis in terms of browser code signatures or anything like that. You mentioned "Vivaldi relaunching" — can you clarify that statement for me? Is Vivaldi set to launch upon logging in to macOS? 1Password recently had a major update, so needing to go through the steps here wouldn't be unusual, but you shouldn't have to reinstall, especially not twice for two separate user accounts.

  • Hi , thanks for following up - by relaunching I mean that when my computer restarts and I login to my account - OSX restores/relaunches previous running apps, Vivaldi was running and thus restores and it is then broken until I do those reinstall steps described above. I haven’t exhaustively tried just limiting myself to one account and restarting to verify it still works (My hunch is yes, as this is how I use my other laptop), it’s when I have multiple accounts and discover that the other one is broken - fix it as above and then if I need to reboot i find the other account is now broken. I haven’t yet confirmed if it’s a reboot (probably closing Vivaldi will do the same - I will verify).

    I’ve also seen this with chrome and safari (on other computers too), so I think there is something weird lurking in the background.

    Tim

  • ag_michaelcag_michaelc

    Team Member
    edited July 16

    Hey Tim.

    That could be the smoking gun here. If macOS launches your browser before 1Password (as a part of restoring your previously running apps), the connection between 1Password and your browser likely won't be properly established. In that case, I'd suggest either starting up the computer without restoring the running apps, to see if that makes a difference. If it does, but you'd like to retain your current behavior of restoring open apps (which is totally reasonable), then give that link in my previous comment a try, to reacquaint the apps with one another and make sure 1Password is launched prior to your browser.

    Michael

  • Interesting thought - but if you close the browser and then relaunch it, would you expect it to then work again properly ? I don’t think it does from memory (but will need to confirm). It seems odd they I have to reinstall - and that this reinstall then breaks the setup in the other account? I don’t think I see this behaviour in a single account system - which is another suspicious thing?

    If it is this - I could try autolaunching 1Password in the account startup as the first item (which hopefully runs before auto-restore). I’m doubtful, but certainly things I can try,

  • ag_michaelcag_michaelc

    Team Member

    if you close the browser and then relaunch it, would you expect it to then work again properly ?

    Probably, although you may find that you need to completely quit 1Password, relaunch it, then launch your browser.

    It seems odd they I have to reinstall

    Yeah, you shouldn't have to reinstall regularly. For now I'm suspecting startup timing being an issue. Let me know what you find.

    I could try autolaunching 1Password in the account startup as the first item (which hopefully runs before auto-restore).

    I'm not sure about macOS's timing of opening Login Items vs. previously opened windows, but do not add 1Password to macOS's Login Items. 1Password has its own startup mechanism, and adding 1Password to your Login Items can cause other issues.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file