1 Password X Beta recommends password on Gmail search box

marcio_nmarcio_n
edited May 5 in 1Password X (beta)

Hi all,

I use Gmail on Microsoft Edge (81.0.416.68) and 1 Password X Beta keeps bringing up the suggestion box on the search box.
It does not stop me from using the search box, it's just a bit annoying. And it actually suggests the Gmail login.

Thanks,
Marcio

(somehow the draft does not save all the apps infos, please find them below)
1 Password Desktop App: Version 7.5.1.BETA-0 (70501000)
1 Password Browser Extension: 1.20.0.beta (build #20108)
OS: macOS Catalina 10.15.4

Comments

  • kaitlynkaitlyn

    Team Member

    Hey @marcio_n!

    That's no fun at all. I really appreciate you getting this on our radar. I just want to confirm, do you have your system language set to Portuguese?

    It'd also be helpful to see the HTML for the search field. I'm thinking the issue is subject to the language selection since I'm not able to reproduce the issue while my language is set to English. Could you please right click the search field on Gmail's site and select Inspect? Go ahead and screenshot the code that appears on the right side of the page and post that in a response back to me. After that, I'll get it reported to our developers so they can work on resolving the issue.

  • Yep, system language is pt-br.

    Please find the HTML below (let me know if I got the right snippet):

  • @kaitlyn , something that I also noticed is that some fields on the other search options also trigger the 1Password recommendation:

    Don't know the exact name field translation, but it's the field where you search all e-mails fields.

    here is the html snippet:

  • kaitlynkaitlyn

    Team Member

    Thanks so much, @marcio_n! I went ahead and passed the report along to the rest of my team in regards to 1Password X appearing in the Gmail search field when the language is set to Portuguese.

    I wasn't able to reproduce the second issue you mentioned. Generally, when you right click on a field, the HTML will be highlighted automatically, but it doesn't look like that happened correctly in your screenshot. Can you try right clicking on the "Contem as palavras" field and selecting Inspect one more time? It may just be selecting the entire div rather than the input field, but I wanted to be sure.

    ref: dev/core/core#1401

  • @kaitlyn , it is just highlighting this:

  • kaitlynkaitlyn

    Team Member

    Thanks, @marcio_n. I still haven't had any luck reproducing the second issue in Edge with my language set to Portuguese (Brasil) in Gmail. I also tried setting my language to Portuguese in Edge's settings, but that didn't do the trick either. However, the HTML I'm seeing is ever so slightly different. Here's what I see:

    <input type="text" class="ZH nr aQb" value="" id=":l5">

    The value is the only difference, but that must be what's throwing 1Password X off. That said, I'm still not sure why that would make 1Password X appear on that field. I'll continue to investigate it on my end.

  • Great @kaitlyn, thanks for your effort!

    I have tried in Google Chrome here (81.0.4044.138) and it does not happen. The HTML snippet in Chrome:

  • ag_anaag_ana

    Team Member

    @marcio_n:

    The HTML snippet in Chrome:

    Were you planning on adding a new screenshot here?

  • I was @ag_ana , apologies.

  • kaitlynkaitlyn

    Team Member

    @marcio_n – Ah, interesting. There may be an incoming update for Edge that resolves things if you're unable to reproduce it in Chrome. That's good to hear.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file