Read Only data on my Mac

I have 1Password on my iPhone, synchronized with iCloud.
From years I'm using also the Mac version (got from your 1Password Store, not from App Store).
Since few days everything worked well, I can add/modify data on my iPhone app and also on my Mac app.

But today I noticed that I cannot edit nor add data on Mac app.
I can still add / edit on iPhone 1Password, but on Mac 1Password it says "Read Only".

If I click on "Read Only" button, a popup will appear saying that I have to buy a license. But I don't have any account. I'm using 1Password with just iCloud sync, and it's free.

How can I fix that "Read Only" message?

Thank you!


1Password Version: Version 7.5 (70500003)
Extension Version: Not Provided
OS Version: Catalina OS X 10.15.4
Sync Type: iCloud

Comments

  • BenBen AWS Team

    Team Member

    Hi @PaoloAlby

    I'm using 1Password with just iCloud sync, and it's free.

    I'm sorry but that isn't correct. 1Password is not free. To use 1Password you either need a membership (recommended) or a license (no longer advertised).

    Ben

  • https://support.1password.com/it/sync-with-icloud/

    Here I can read that, if I need to sync only 1 "Cassaforte" ("Safe" in english?) I don't need anything than iCloud sync.

    Anyway, why for years I used 1Password, with iCloud sync on my iPhone and my Mac, and now it require membership or license?

  • ag_tommyag_tommy

    Team Member
    edited May 13

    @PaoloAlby

    Did you perhaps recently update to 1Password 7 from something earlier, like 1Password 6. If so, 1Password 7 would require a separate purchase for a license or the use of a membership.

  • I don’t remember honestly.
    Do you think that, if I re-install 1Password 6 it will go back to work like in the previous months?

  • ag_tommyag_tommy

    Team Member
    edited May 13

    @PaloAlby

    It is possible to return to 1Password 6 if you have your license for that version. I should note the following details.

    In September 2019, Apple discontinued the Safari Extension Gallery which was required to install the 1Password 6 extension in Safari. Because of this change, you can no longer install the 1Password 6 extension in Safari. The last major update was in 2018. 1Password 6 is no longer being actively developed and will only receive critical security updates in the future.

    1. https://discussions.agilebits.com/discussion/106771/1password-6-in-safari

    2. https://discussions.agilebits.com/discussion/104999/1password-6-legacy-support-information

    My recommendation would be to continue forward and use 1Password 7. If you go with a membership, you are always covered and never have to worry about future upgrades as they are always included.

  • Hi, I am having a similar problem.

    I have the Mac and the iOS version of 1Password. I can still edit login and app passwords on the iOS version, but not on my Mac.

    As of this week it says Read-only.

    I can't figure out what to do. I upgrade to version 7 in fall 2019 and have an email confirmation, paid about $67 for it. Since it worked until now, I think it must not be a license issue.

    What do I need to do? The browser menu bar extension isn't working today either, but was last week.

    Thanks,

    Perkins

  • PerkinsPerkins
    edited May 21

    Edit: comment posted twice, I deleted this second one by editing it thusly, but this is not really better

  • Also, I just noticed that it says Mac App Store in the window that opens after clicking About 1Password in the menu bar. But I also have a licence that was emailed to me, which I thought meant that I bought it on your web store, and I don't usually use the Mac App store, so I am confused about this.

  • BenBen AWS Team

    Team Member

    @Perkins

    I'm sorry for the trouble.

    Also, I just noticed that it says Mac App Store

    That would be the problem. 1Password from the Mac App Store only works with 1Password.com membership accounts. It does not work with licenses. To use a license you'd need the version from our website. Please try these instructions:

    1. Quit Safari
    2. Open and then quit 1Password completely — ⌘⌥⌃Q (Command Option Control Q)
    3. Drag 1Password to the Trash, but DO NOT use a "cleaner" app to remove 1Password if you have one (MacKeeper, CleanMyMac, AppZapper, etc)
    4. Empty the Trash
    5. Restart your Mac
    6. Install 1Password from our website: Download for Mac
    7. Open 1Password
    8. Make sure the extension is shown and enabled in Safari under Preferences > Extensions (do not click "More Extensions")
    9. Verify that you're able to use the extension to fill logins

    Let me know how it turns out. :)

    Ben

  • How did the Mac App store version get on my computer? How do I prevent it from happening again?

    I didn't download it, unless there was an old version from the App store that somehow update in the background?

    Thanks.

  • It works! Until now I thought that 1Password 7 was a greatly diminished app vis a vis 1Password 6 without many of the features I used to enjoy, but it might be because right from November when I started using it there was an issue with the app store version and your web store version somehow both being installed or something to do with this.

    Now I can use the autofill and generate password feature again - it was weird and just this click to pin function before today.

    I am very happy to see 1Password 7 works now as I expected it to and thank you for the help.

  • BenBen AWS Team

    Team Member

    @Perkins

    The only way I'm aware for a Mac App Store app to be on your system would be for you or another user of your system to have installed it.

    Ben

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file