Cannot Delete Vaults Whose Name Has Special Characters

I just wanted to report that when using 1Password on the web to manage one's account, it is not possible delete a Vault when the Vault name has special characters. I had a vault with an apostrophe and despite me typing in the name of the vault correctly, the 'Permanently Delete Vault' button was still grayed out. When I changed the name of the vault to remove the apostrophe, viola - I was able to delete it.


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

Comments

  • DanielPDanielP

    Team Member

    @Keifer:

    Sorry for the wait here! I will let the developers know about this so we can see if we can reproduce the issue. Thank you for the report! :+1:

  • DanielPDanielP

    Team Member

    @Keifer:

    In the meantime, can you please confirm what client you tried this in? I have just tried this on the 1Password.com web app, but I was able to delete the vault even if it contained an apostrophe, so I wonder if you were doing it in one of the desktop apps, for example.

  • I thought I did it on the web in Chrome (latest version).

    I didn’t even know you can delete a vault in the Windows desktop client... can you?

  • DanielPDanielP

    Team Member

    @Keifer:

    Not in the Windows app at the moment, but it's possible in other clients (1Password for Mac has this feature in the desktop app, for example). Thank you for confirming that it was in the web app however.

    I wonder if the vault had other special characters in it, because the deletion form seems to be handling apostrophes correctly for me. If you don't mind, would you mind sending us an email with the vault name, if it's something you are comfortable with sharing, so we don't leave this on a public forum? You can reach us at [email protected]

    You will receive a ticket number a couple of minutes after sending the message. If you post the ticket number here once you get it, I can link your email to this forum discussion so we don't start the discussion over from scratch :)

  • You can stand down I guess. I just re-tested myself.

    For the record, the vault name was Moody's

    The delete button is now always working, which means one of two things:

    1) The developers saw the post and fixed the bug already or...
    2) There was some other issue going on or I was high...

    I'm rooting for #1 :-D

  • ag_anaag_ana

    Team Member

    Thank you for the update @Keifer! I am glad to hear that things are working for you again :)

    If you have any other questions, please feel free to reach out anytime.

    Have a wonderful day :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file