1Password not locking

I recently installed 1Password on a new iMac and I'm having an issue where it doesn't ever seem to lock at all. I can come back to the computer after a couple hours or even overnight, press the keyboard shortcut in any browser, and it auto-fills the password for the site I'm on. I have all the Auto-lock options checked under Security preferences in the main app and the "Lock after computer is idle" option is set to the default 5 minutes. This happens even with the main app closed, in Chrome, Safari, and Firefox. I've also restarted the computer several times, but I'm still encountering this issue.

I'm a longtime 1Password user--wasn't there an option at one point to auto-lock 1Password after, say, 20 minutes if you hadn't used it to fill in another password in that amount of time?


1Password Version: 7.5
Extension Version: 7.5
OS Version: MacOS 10.15.4
Sync Type: Not Provided

Comments

  • BenBen AWS Team

    Team Member

    Hi @garchow1

    I'm sorry to hear you're having trouble getting 1Password to lock when expected. I'd be happy to help troubleshoot that situation with you.

    I'm a longtime 1Password user--wasn't there an option at one point to auto-lock 1Password after, say, 20 minutes if you hadn't used it to fill in another password in that amount of time?

    I've been here 11 years, and I don't recall such an option. That could definitely be a fault in my memory rather than yours, though. In any event, that isn't one of the options now. That said I think we can get you to a good state without it. :)

    I recently installed 1Password on a new iMac and I'm having an issue where it doesn't ever seem to lock at all. I can come back to the computer after a couple hours or even overnight, press the keyboard shortcut in any browser, and it auto-fills the password for the site I'm on. I have all the Auto-lock options checked under Security preferences in the main app and the "Lock after computer is idle" option is set to the default 5 minutes. This happens even with the main app closed, in Chrome, Safari, and Firefox. I've also restarted the computer several times, but I'm still encountering this issue.

    If you unlock 1Password and then click the  > Lock Screen option in the menu bar, does that cause 1Password to lock? Also, would you be able to post a screenshot of 1Password > Preferences > Security here for us?

    ▷ How to take a screenshot

    Please let me know. Thanks!

    Ben

  • Hi Ben,

    It could definitely be me mis-remembering a particular setting, but on the iMac I just switched from, which I'd been using 1Password on since 2014, I would press the keyboard shortcut to fill passwords, and be able to continue to do so, but after about 20 minutes of using the computer but not filling any passwords, if I used the shortcut again I would be required to enter the main 1Password password again. That's basically the functionality I'm looking for.

    I did just confirm that 1Password does lock if I choose  > Lock Screen, but I'm just thinking of the times when I may walk away from my computer for a moment with the screen still on and someone being able to come up and use the keyboard shortcut to gain access to my passwords. I know I could lock the screen each time, but that's not the way I've gotten accustomed to working with 1Password on my computer. Any thoughts? Thanks.

  • ag_tommyag_tommy

    Team Member
    edited May 20

    @garchow1

    Interesting that you mention 20 minutes. That's the default time on your screensaver activating. I think you have linked the two items, and it seems appropriate given it does what you want when the screensaver is activated. :)

    Do you currently have your screensaver setup? Do you use any apps that would keep the Mac alive and not allow it to sleep? If you're on a MacBook, I have seen reports in the Apple forum where a fan running on the same desk (causing vibration) was enough to keep the Mac from going idle or allowing the screensaver to activate. The Mac interpreted the vibration as the user was present. I am not saying that's your issue, just merely an observation, and something you may wish to consider.

  • I do have my screensaver set to the default 20 minutes on my iMac, but I'm is that I want 1Password lock itself while I'm using the computer after a certain number of minutes, which is what it would do on my old iMac. In fact, I just tested it on the old iMac by using invoking 1Password to log into a site, waiting 30 minutes while keeping the computer screen on the entire time, and using the keyboard shortcut again, at which point I was prompted for the main password, so it's still working the way I'm used to it working on my old computer.

    Contrast that with my waking my new iMac from screensaver this morning after several hours (I do have it required to use the Mac password to deactivate the screensaver), going to my bank's website, pressing the the 1Password keyboard shortcut, and it filling in the password without me having to type anything else.

  • ag_tommyag_tommy

    Team Member
    edited May 20

    @garchow1

    Sure, I follow you, I only mentioned the screensaver as it's one of the options in the 1Password Security settings that will lock 1Password. If something is keeping the Mac alive, you will not get desired results such as 1Password not locking. Likewise, if the screensaver is not properly reporting itself as activated, then 1Password would not lock.

    You mention old Mac, did you move over to this Mac using something like Migration Assistant? I ask as sometimes things like preferences do not get carried over properly.

    As a test can you deselect all of the options for Auto-Lock and then restart, enable those settings, and finally check for proper operation. To speed up the process, can you temporarily change the screensaver start time to something like two minutes.

  • I set up the new Mac as a clean installation without using Migration Assistant and downloaded and installed 1Password fresh as well.

    With the auto-lock options checked, 1Password definitely locks when I lock the Mac or when I manually trigger the screen saver using a hot corner. It doesn't lock when the screen saver automatically comes on (like when I came back to my computer this morning, the screen saver was on, but when I logged into the Mac I could fill in passwords without using the 1Password main password.

  • ag_tommyag_tommy

    Team Member
    edited May 20

    @garchow1

    Would you be so kind as to run the following command via the Terminal app?

    1, Open the Terminal application which in in the Utilities folder.
    2. Paste this code into the application pmset -g
    3. Copy and Paste the output here.

    You will get an output like this.

    lidwake 1
    autopoweroff 1
    standbydelayhigh 86400
    autopoweroffdelay 28800> proximitywake 1
    standby 1
    standbydelaylow 0
    ttyskeepawake 1
    hibernatemode 3
    powernap 1
    gpuswitch 2
    hibernatefile /var/vm/sleepimage
    highstandbythreshold 50
    womp 1
    displaysleep 10
    networkoversleep 0
    sleep 0
    tcpkeepalive 1
    halfdim 1
    acwake 0
    disksleep 10

  • Currently in use:
    standby 1
    Sleep On Power Button 1
    womp 1
    halfdim 1
    hibernatefile /var/vm/sleepimage
    proximitywake 1
    powernap 1
    gpuswitch 2
    networkoversleep 0
    autorestart 1
    standbydelayhigh 86400
    sleep 0 (sleep prevented by Plex Media Server, sharingd)
    hibernatemode 3
    disksleep 0
    ttyskeepawake 1
    displaysleep 57
    highstandbythreshold 50
    standbydelaylow 86400

  • ag_tommyag_tommy

    Team Member
    edited May 20

    @garchow1

    Try shutting down 'Plex Media Server' and testing 1Password again. In addition to Plex, do you have your Mac hd/ssd or CD shared? The commands also indicate sharingd is in use, which I suspect this specific instance is actually something in use by Plex.

  • Plex was always running on my old Mac too and 1Password operated fine. I guess my question at this point is whether 1Password is supposed to stay unlocked indefinitely as long as my computer isn't locked or put to sleep? Is it supposed to auto-lock at any time if the computer is constantly in use?

  • ag_tommyag_tommy

    Team Member

    If you Mac is reporting it is in use, then the only recourse is to lock 1Password manually. We are using system status as reported by the Mac to trigger locking the app.

    If you had Plex up and running on the previous Mac, that would leave us with sharingd as the possible culprit. Do you have any disk sharing setup? If so, I would look at temporarily stopping it and see if the issue is rectified.

  • ag_tommyag_tommy

    Team Member

    You can enable the lock when the main window is closed, but you will need to close the window each time, manually.

  • So I tried resetting my iMac's SMC and that appears to have solved the problem. 1Password now auto-locks as expected after the specified amount of time of computer inactivity. Thanks for your help--your suggestions definitely got me pointed in the right direction. Much appreciated.

  • ag_anaag_ana

    Team Member

    On behalf of ag_tommy, you are welcome @garchow1! If you have any other questions, please feel free to reach out anytime.

    Have a wonderful day :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file