Auto-lock many times in a day.

PassPass
edited May 29 in 1Password X (beta)

1Password auto-lock many times in a day (without closing computer or 1Password) even if leave unchecked all auto lock settings including lock on sleep. I integrated 1Password X extension with 1Password Mac app (not app store version) Screenshot is in the below.


1Password Version: 1Password 7 Version 7.6.BETA-0
Extension Version: 1Password X Chrome Extension Beta 1.20.1
OS Version: 10.15.4
Sync Type: Cloud

Comments

  • BenBen AWS Team

    Team Member

    Hi @Pass

    1Password X has its own locking settings. This may be causing 1Password X and 1Password for Mac to lock. These should be ignored when integration with 1Password for Mac is enabled, but that integration is still in beta for a reason. ;) If you temporarily turn off integration, do you see lock settings in 1Password X? Please try turning those off, and then re-enable integration:

    Ben

  • PassPass

    @Ben
    There is no security or lock settings in 1Password X beta channel

  • BenBen AWS Team

    Team Member

    @Pass

    Did you first turn off "Integrate with 1Password for Mac"?

    If you temporarily turn off integration [...]

    Ben

  • I am having the same issue. Automatically lock in not set on 1passwordX and then I enabled integrate with 1password desktop. my autolock settings are all set to not lock same as above.

  • ag_anaag_ana

    Team Member

    @jeffreyh:

    What version of the 1Password for Mac app and of the 1Password X browser extension are you currently running?

  • 1Password 7
    Version 7.6.BETA-1 (70600001)
    1Password Beta

    This is with MS Edge on the Mac Version 83.0.478.45

  • kaitlynkaitlyn

    Team Member

    @jeffreyh – Do you happen to be quitting your browser at all, or is 1Password X locking in the middle of your browser session? It'd be helpful to see your 1Password X log after it locks on you. If you're up for it, could you grab the log and post it here? If you feel more comfortable emailing it to us instead of posting on a public forum, please send a copy of the log to [email protected] with a link to this forum thread as well as your forum username. You can find our guide that explains how to obtain the log here. Let me know if you have any trouble!

  • I just signed up to add to this. My 1Password locks out every 10 minutes even though I have auto lock disabled everywhere including following Ben's recommendation above.

    Desktop app version: 7.6.BETA-2 (build #70600002) – released 2020-06-05



  • 1Password 7
    Version 7.6.BETA-1 (70600001)

    1Password X
    1.20.1.beta

  • 1Password 7
    Version 7.6.BETA-1 (70600001)
    1Password Beta

  • 1Password 7
    Version 7.6.BETA-1 (70600001)
    1Password Beta

  • ag_anaag_ana

    Team Member

    @jeffreyh:

    Thank you for confirming your 1Password X version once again. Can you please follow kaitlyn's instructions here and answer the questions in her post?

  • ag_anaag_ana

    Team Member

    @unknownsolo:

    Thank you for all the information! May I ask if you have seen kaitlyn's instructions here already? Do you happen to be quitting your browser at all, or is 1Password X locking in the middle of your browser session?

  • @ag_ana - just to add few more details, I am using the extension with MS Edge at home, if I leave the browser open and go to the kitchen for a quick bite and come back, both 1Password extension and app are locked. I have my computer set to go to sleep in 15 minutes but I am normally back before the computer goes to sleep (within 10-12 minutes) and 1Password app "Lock on sleep" is disabled.

    I read somewhere else in this forum and according to what Ben said above that this could be because of the browser extension not fully working correctly. I disabled the browser extension integration, disabled "Automatically lock 1Password" and set "Lock after system is idle for "999" minutes" then disabled "Automatically lock 1Password" and turned on browser extension again. I will test this and report back.

    I will also test completely disabling the browser extension and see if the app locks.

  • ag_anaag_ana

    Team Member

    Sounds good @unknownsolo! Please let us know what you find :+1:

  • Unfortunately non of the above helped.

  • ag_anaag_ana

    Team Member

    @unknowndomain:

    Thank you for the confirmation! Have you perhaps sent us the logs already, as per kaitlyn's message?

  • I will pull he logs and send them your way. I think the problem is the app itself. I have all the auto lock settings turned off but it keeps locking.

  • I switched back to the non beta build and installed the regular standalone extension and everything is working as expected. I dont have integration between the extension and the app anymore but at least they are not automatically locking every 10 minutes.

  • PassPass
    edited June 10

    Hi! Sorry for late reply. @Ben 's solution solves my problem. Maybe, some UI changes on browser extension may be good for users.

  • ag_michaelcag_michaelc

    Team Member

    @unknownsolo: I'm glad you have a working solution, but we'd be happy to investigate further should you choose to go back to the betas and turn on Integration once more.

    @Pass: I'm happy to hear that the issue has been resolved for you. :smile: Indeed, there is still some work to be done on Integration, which is why it hasn't left beta yet. Thanks for helping us test; cheers!

  • cryptochromecryptochrome Junior Member

    Same problem here and Ben's solution isn't working for me, unfortunately.

  • YaronYaron

    Team Member

    Hey @cryptochrome ,

    To make sure we're on the same page, please confirm (or correct) the following:

    • You disabled the desktop app integration in 1Password X's settings.
    • You turned off "Automatically lock 1Password" in 1Password X's settings.
    • You changed the auto-lock settings in the 1Password 7 desktop app's preferences as you'd like.
    • You then turned the desktop app integration feature back on in 1Password X's settings.
    • Both 1Password X and the 1Password 7 desktop app still lock automatically after 5-10 minutes of idle computer time?
  • cryptochromecryptochrome Junior Member

    Hey @Yaron - actually I had desktop app integration turned on all the time without issues and without 1PX automatically locking itself. It just started to lock itself without me touching any of my settings. So I am assuming all my settings are correct. My desktop app is set to never lock (except for computer restart). 1PX does no longer respect that setting. It started to lock itself maybe 2-3 days ago.

    I disabled desktop app integration, disabled auto-lock in 1PX, turned app integration back on and it still keeps locking itself.

  • YaronYaron

    Team Member

    Thanks @cryptochrome .
    The only way I am able to reproduce this is if I turn off integration, turn on the auto-lock settings in 1PX, then turn integration back on.

    If auto-lock is off in 1PX, and 1Password 7 for Mac is set to never lock, then it stays unlocked here. Would it be possible for you to reproduce the issue after turning off auto-lock in 1PX and making sure that 1Password 7 is set to never lock? If so, please generate the following and send it over to [email protected] with a link to this discussion:

    Thanks.

  • cryptochromecryptochrome Junior Member

    Hey @Yaron - this is weird now. I did exactly that yesterday without success and just tried it again and now it no longer locks. /shrug

    Case closed. Thanks! :)

  • ag_michaelcag_michaelc

    Team Member

    A little peculiar, but I'm glad things are working well now, @cryptochrome. :smile: Let us know if things start acting up again.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file